Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Suspension

Notices

Roaring after lift installation

Reply
 
Thread Tools Search this Thread
Old 10-24-2011, 05:24 PM   #1
SlapNuts [OP] SlapNuts is offline
Junior Member
SlapNuts is on a distinguished road
Joined: Oct 2011, #65028
Gender: Male
Posts: 1
SlapNuts's Tacoma Gallery
Roaring after lift installation

I installed a day star lift this weekend and it sounds to me like I am hearing tire noise around 40 mph and when breaking. I had it aligned right after I finished the installation. Could I have screwed something up during the installation? I know most of the members on here recommend the 5100's so please hold the comments about the spacer lifts. I am having the alignment checked first thing in the morning to make sure that it is within spec. I am just wondering if I could have messed something up during installation. Thanks in advance.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tip for lift installation Magnetic Suspension 13 08-17-2011 01:34 PM
Roaring noise from front end on 05' DC 4x4 Taco aacomi 2nd Gen. Tacomas 11 06-02-2011 01:54 PM
roaring going down the road Ricky B 1st Gen. Tacomas 8 02-02-2011 08:01 AM
Installation price for lift? Jay-Hawks Suspension 8 10-30-2009 11:02 AM
Roaring Power Steering Pump anvilhead 1st Gen. Tacomas 3 08-31-2009 12:18 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.