Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Suspension

Notices

Anybody actually had this issue?

Reply
 
Thread Tools Search this Thread
Old 04-28-2014, 03:02 PM   #1
deerman [OP] deerman is offline
Deer Huntin Fool
deerman is on a distinguished road
 
deerman's Avatar
Name: Michael
Joined: Feb 2014, #122137
Location: Raleigh, NC
Gender: Male
Posts: 43
deerman's Tacoma Gallery
Anybody actually had this issue?

I am leaning towards getting an OME kit put on my 2014 DCSB here in the next couple weeks. And obviously, I'd like to keep the warranty if possible. My local dealer said that they would have to be able to prove that it was the lift that caused the issue in order for the warranty to be void. He said if he were talking to me outside of that uniform, he'd say "they've been lifting these trucks for 20 years. They've got it figured out". Told me that he'd do it if he were me without worry.

I have seen other threads on related topics on what the dealer can and can't do (and Magnuson-Moss Act), but my question is...has anybody actually had an issue within 3 years that was an issue that is related to your lift? It seems like there is a lot of could-be scenarios on here, but I haven't seen anyone that actually had issues with the OME lift within 3 yrs/36k miles.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Issue? or ABS Issue? qnyla 2nd Gen. Tacomas 16 03-08-2014 07:47 AM
sub issue Gaabstopper7 2nd Gen. Tacomas 0 10-26-2012 04:54 PM
My issue or the dealer's issue...Rubbing AllMountainToy 2nd Gen. Tacomas 13 05-03-2012 09:52 PM
Is the "rusty frame issue" still an issue on the 2nd gens? Black Sheep 2nd Gen. Tacomas 2 10-26-2010 06:55 AM
Rotor issue or tie rod issue HeadlampRevamp 1st Gen. Tacomas 37 05-16-2010 08:32 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.