Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Suspension

Notices

Who uses .....

Reply
 
Thread Tools Search this Thread
Old 03-05-2008, 07:11 AM   #1
IRISHDEVIL [OP] IRISHDEVIL is offline
Senior Member
IRISHDEVIL is on a distinguished road
 
IRISHDEVIL's Avatar
Joined: Jul 2007, #2187
Posts: 158
IRISHDEVIL's Tacoma Gallery
Who uses .....

I have heard from a few people that i should put 885 OME coils on my 5100's and that i would love it but i have heard that the 885's are very stiff and tend to sag over time. Has or is anyone doing this set up and if so how is the ride quality? I also dont do a hole lot of offroading so ride quality on ride is pretty important to me

Thanks in advance.
  Reply With Quote
Old 03-06-2008, 11:22 AM   #2
Senior Member
Toycoma06 will become famous soon enoughToycoma06 will become famous soon enough
 
Toycoma06's Avatar
Joined: Dec 2007, #3983
Location: Richmond Va.
Gender: Male
Posts: 108
Toycoma06's Tacoma Gallery
Very good question !!! I just installed 884's and i was very happy at first but it looks like only after three weeks my springs have started to sag. I only have 38'' from the ground to the bottom of the fender. The ride quality of the 884's is great .. very smooth but i think im going to buy the spacer puk and put the stock springs back in for the 3".

This is a thought??? buy the 5100's put them on the highest setting with the stock springs and then purchase the .5 inch plate with the longer press in studs through Toytec for a full 3"
  Reply With Quote
Old 03-06-2008, 12:22 PM   #3
nd nd is offline
Radical Town. It's a hell of a place!
nd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these partsnd is infamous around these parts
 
nd's Avatar
Name: Nate
Joined: Mar 2007, #1047
Location: Greenville, SC
Age: 32
Gender: Guy
Posts: 12,740
nd's Tacoma Gallery
Quote:
Originally Posted by Toycoma06 View Post
Very good question !!! I just installed 884's and i was very happy at first but it looks like only after three weeks my springs have started to sag. I only have 38'' from the ground to the bottom of the fender. The ride quality of the 884's is great .. very smooth but i think im going to buy the spacer puk and put the stock springs back in for the 3".

This is a thought??? buy the 5100's put them on the highest setting with the stock springs and then purchase the .5 inch plate with the longer press in studs through Toytec for a full 3"
they HIGHLY recomend that you do not use spacers in addition to the 5100's. dont know why but they say not to
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.