Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   Suspension (http://www.tacomaworld.com/forum/suspension/)
-   -   TC spindles with 5100's (http://www.tacomaworld.com/forum/suspension/56359-tc-spindles-5100s.html)

951TRD 10-13-2009 08:58 PM

TC spindles with 5100's
 
Im currently running 5100's all the way around with the front set at 2.5" and an 1.5" AAL in the rear. The way my truck sits right now is pretty close to the factory rake. I was thinking of setting the Billies at 0 and installing the 3.5" TC spindles. Does anyone have any pictures of this setup? I looking for more clearance up front for off road performance as well as the prerunner look.
http://www.tacomaworld.com/gallery/d...m/DSC03927.JPG

Kenny650 10-13-2009 10:03 PM

I have Camburg 4" spindles and I currently have my 5100's at stock height. I have a slight rake in the front for some weird reason. i only have a tsb and an aal in the back.

951TRD 10-13-2009 10:11 PM

How much did the tsb lift your truck? What AAL did you get? I got mine from Toytec and it said and 1.5" lift but it actually lifted it 2". What size tires are you running?

Kenny650 10-13-2009 10:43 PM

Quote:

Originally Posted by 951TRD (Post 1021983)
How much did the tsb lift your truck? What AAL did you get? I got mine from Toytec and it said and 1.5" lift but it actually lifted it 2". What size tires are you running?


I got the wheelers TSB AAL. I am running 285/70/17 BFG KM2's

951TRD 10-13-2009 10:46 PM

Quote:

Originally Posted by Kenny650 (Post 1022045)
I got the wheelers TSB AAL. I am running 285/70/17 BFG KM2's

Any trimming required?

Kenny650 10-13-2009 10:58 PM

Yep. I'm having a lot of rubbing on the back side of the fenders. But that might be also because I haven't aligned it yet. Kinda wish I kept it at 1.85"

951TRD 10-13-2009 11:01 PM

Quote:

Originally Posted by Kenny650 (Post 1022087)
Yep. I'm having a lot of rubbing on the back side of the fenders. But that might be also because I haven't aligned it yet. Kinda wish I kept it at 1.85"

What is your truck set at in the pictures that you have up?

Kenny650 10-13-2009 11:05 PM

The pictures I have on my profile and sig was my old 3" Revtek. Here it is with the spindles and 5100's set at 1.75

http://i672.photobucket.com/albums/v...g?t=1255500320

951TRD 10-13-2009 11:16 PM

Quote:

Originally Posted by Kenny650 (Post 1022103)
The pictures I have on my profile and sig was my old 3" Revtek. Here it is with the spindles and 5100's set at 1.75

http://i672.photobucket.com/albums/v...g?t=1255500320

That looks really good, exactly what I am looking for. Thanks for the help.


All times are GMT -7. The time now is 09:38 PM.