Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

code P0102

Reply
 
Thread Tools Search this Thread
Old 07-20-2010, 10:47 PM   #1
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
code P0102

threw this code today P0102 Mass or Volume Air Flow Circuit Low Input. what is the part number for the MAF Sensor?
  Reply With Quote
Old 07-20-2010, 11:08 PM   #2
Senior Member
MurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shed
 
MurphyZ's Avatar
Air Force: Air Traffic Control
Name: I HATE SPICYTACOS
Joined: Jan 2009, #12441
Location: Barksdale AFB
Gender: Male
Posts: 732
MurphyZ's Tacoma Gallery
before you buy a new one, clean yours with MAF cleaner. let dry completely then reinstall. should clear code.
  Reply With Quote
Old 07-21-2010, 12:06 AM   #3
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
i am going to do that tomorrow, but just wanted the part number just in case.
  Reply With Quote
Old 07-21-2010, 12:11 AM   #4
Senior Member
MurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shed
 
MurphyZ's Avatar
Air Force: Air Traffic Control
Name: I HATE SPICYTACOS
Joined: Jan 2009, #12441
Location: Barksdale AFB
Gender: Male
Posts: 732
MurphyZ's Tacoma Gallery
i dont have that but on my 06 my milage went down to like 12mpg and it through this code, i cleaned my filter and then sprayed the MAF and my milage went back up to 17.7mpg. it screws with the airfuel mix.

are you having mpg issues? or just hte code?
  Reply With Quote
Old 07-21-2010, 10:05 AM   #5
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
i just threw the code out of nowhere. i should've cleaned my maf last night, but got lazy. i am going to do it right after work.
  Reply With Quote
Old 07-21-2010, 10:34 AM   #6
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
The part number is on top of the MAF
  Reply With Quote
Old 07-21-2010, 04:22 PM   #7
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
ok i just cleaned my maf and throttle body. my truck had a hard time starting than idle pretty good. i turned it off and i tried to start it again any my truck starts and dies. i tried a couple more times and same thing it dies or doesn't even start. what should i do?
  Reply With Quote
Old 07-21-2010, 04:23 PM   #8
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Check and see if you blew the EFI fuse.
  Reply With Quote
Old 07-21-2010, 04:44 PM   #9
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
didn't blow a fuse, but got it to run after i had to give it some gas after getting it started. it was idling very high and took forever to shift when i took it for a drive. is that normal?
  Reply With Quote
Old 07-21-2010, 04:51 PM   #10
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
The ECU may have to relearn the sensor now that it's clean.
  Reply With Quote
Old 07-21-2010, 04:54 PM   #11
wo ai ni bao bei ^_^
blackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shedblackhawke88 is one of the sharper tools in the shed
 
blackhawke88's Avatar
Joined: Jan 2009, #12478
Location: SGV, CA
Gender: Male
Posts: 16,257
blackhawke88's Tacoma Gallery
make sure the cleaner is dry before starting it. try disconnecting the battery for 15+ minutes.
  Reply With Quote
Old 07-21-2010, 07:59 PM   #12
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
so i had let my truck sit for over an hour with the battery disconnected and still the same problem. i can start it but if i don't give it some gas it dies. this is bugging me since this is my only ride and i gotta take to get checked.
  Reply With Quote
Old 07-22-2010, 04:56 AM   #13
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Are your vac lines connected/leaking? It almost sounds like the butterfly is stuck or the IAC needs cleaned.
  Reply With Quote
Old 07-22-2010, 11:57 AM   #14
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
Quote:
Originally Posted by 98tacoma27 View Post
Are your vac lines connected/leaking? It almost sounds like the butterfly is stuck or the IAC needs cleaned.
checked all my lines and it was good. what is IAC? the start up this morning was a little rough, had to do it twice and it got going. a weird thing happened when i was checking my scangauge at a stop light to check the code my truck shut off, but i was able to get it started again no problem. the truck ran fine going to work, but the RPMs was kind of high. when i got to work i shut the truck off waited like 30 seconds and started it back up with no problems whatsoever. i am going to try make an appointment with a mechanic to check it out.
  Reply With Quote
Old 07-22-2010, 12:27 PM   #15
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Idle Air Control Valve, but nevermind about that. I just now saw you have a 4.0.........
  Reply With Quote
Old 07-28-2010, 04:54 AM   #16
Senior Member
MurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shedMurphyZ is one of the sharper tools in the shed
 
MurphyZ's Avatar
Air Force: Air Traffic Control
Name: I HATE SPICYTACOS
Joined: Jan 2009, #12441
Location: Barksdale AFB
Gender: Male
Posts: 732
MurphyZ's Tacoma Gallery
my 06 did this. i figured because i "refreshed" the ecu it would take some time to relearn what air flow mix was needed to drive healthy. if you are sure your vacuum hoses are fine and you are not showing any codes...

clean your MAF with the cleaner( put it in a place that is: dry, away from dust and dirt, allow to dry for at least 15-30min.) after that check your throttle body- just to clean it if dirty. put back together and drive like a grandma around for 100 or so miles. ( your MPG will suck- i got 13) after that your ECU should start to change the settings and return to normal settings.

that is what i did and after the intial trip ( i went from medford OR. to Crater Lake OR) my truck started and re started with no throttle.

hope this helps
  Reply With Quote
Old 07-28-2010, 01:17 PM   #17
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
Quote:
Originally Posted by MurphyZ View Post
my 06 did this. i figured because i "refreshed" the ecu it would take some time to relearn what air flow mix was needed to drive healthy. if you are sure your vacuum hoses are fine and you are not showing any codes...

clean your MAF with the cleaner( put it in a place that is: dry, away from dust and dirt, allow to dry for at least 15-30min.) after that check your throttle body- just to clean it if dirty. put back together and drive like a grandma around for 100 or so miles. ( your MPG will suck- i got 13) after that your ECU should start to change the settings and return to normal settings.

that is what i did and after the intial trip ( i went from medford OR. to Crater Lake OR) my truck started and re started with no throttle.

hope this helps
i've cleaned my maf with cleaner, cleaned my throttle body too, let it dry two times already and nothing. my gas mileage has been the same and i still get around 17-18 mpg. i have low end power loss and shifts at higher rpms. my truck can't start on its own without me reving my engine once, after i rev it my truck runs and if i don't rev in on the intial start it dies.
  Reply With Quote
Old 08-05-2010, 05:40 PM   #18
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
changed the sensor and everything works now, just gotta get the CEL to go off
  Reply With Quote
Old 08-05-2010, 06:04 PM   #19
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Pull the NEG cable on the battery
  Reply With Quote
Old 08-12-2010, 10:18 AM   #20
happyb [OP] happyb is offline
Senior Member
happyb has a spectacular aura abouthappyb has a spectacular aura about
Name: Brandon
Joined: Mar 2009, #15098
Location: on a beach in hawaii
Gender: Male
Posts: 337
happyb's Tacoma Gallery
i pulled the neg off the battery for 15 minutes and the light is still on. i used my scangauge to see if i was throwing anymore codes and it is still the same one. i replaced the sensor and still the same sh*t is going on. my truck starts after the second time i try and it still takes forever for my automagic to shift.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
p0102 p0113 No Start 05tacoma33 2nd Gen. Tacomas 3 09-12-2011 09:01 PM
what does this code mean? ironman_jon 2nd Gen. Tacomas 1 01-14-2011 09:00 PM
P0102 code, truck won't start without gas Evildcustoms 2nd Gen. Tacomas 12 12-07-2010 04:02 PM
airbag code 1 bad tacoma 2nd Gen. Tacomas 5 09-14-2010 03:19 PM
Code Help !!!! WorkTruck 1st Gen. Tacomas 0 12-29-2008 08:06 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.