Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

'96 taco ,V6 runs rough until warm?

Reply
 
Thread Tools Search this Thread
Old 02-12-2011, 09:52 AM   #1
dustinJ [OP] dustinJ is offline
Senior Member
dustinJ is on a distinguished road
 
dustinJ's Avatar
Name: Dustin
Joined: Dec 2010, #47331
Location: Amarillo tx
Gender: Male
Posts: 134
dustinJ's Tacoma Gallery
'96 taco ,V6 runs rough until warm?

My mechanic told me over the phone that it could be the temp sensor that tells the motor how to run. It stumbles and idles very rough on cold start. After warming up it runs smooth as silk. Where is this thing located at? Can I change it out myself at home?

96 v6 144xxx. 4x4

Thanks
dustin
  Reply With Quote
Old 02-16-2011, 02:18 AM   #2
Me l've got brains.
island808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shed
 
island808's Avatar
Name: Jedediah
Joined: Oct 2010, #44414
Location: hawaii
Gender: Male
Posts: 1,896
island808's Tacoma Gallery
man I don't know where it is, and no one is answering so I'll throw in.. Check a book... maybe a parts site's exploded diagram. Might show you where it goes.

and yes you can change it yourself at home.

If it's the IAT sensor, look around the intake and its manifold. And I like the diagnosis. Though I don't know how prone they are to failure.
  Reply With Quote
Old 02-16-2011, 07:08 AM   #3
dustinJ [OP] dustinJ is offline
Senior Member
dustinJ is on a distinguished road
 
dustinJ's Avatar
Name: Dustin
Joined: Dec 2010, #47331
Location: Amarillo tx
Gender: Male
Posts: 134
dustinJ's Tacoma Gallery
Thanks for your reply. He told me to drive it and that it may line out. I just thought I would go ahead and switch it out. This truck was beaten to death in the oil field for 144 thousand miles and not very well taken care of. Everything is caked up with oil and mud.

Thanks again ill keep workin on it
  Reply With Quote
Old 02-16-2011, 10:31 AM   #4
Me l've got brains.
island808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shedisland808 is one of the sharper tools in the shed
 
island808's Avatar
Name: Jedediah
Joined: Oct 2010, #44414
Location: hawaii
Gender: Male
Posts: 1,896
island808's Tacoma Gallery
You do a good tune up on it?

Also, you might disconnect the battery and see if it resets something. The 4.0 is a newer generation sure, but it can get confused easily. Maybe the 3.4 is the same.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
96 rough ride carylin 1st Gen. Tacomas 2 02-03-2012 10:28 AM
Runs rough, check engine light on. drifter Technical Chat 17 12-10-2011 10:52 PM
Low/rough idle with warm engine restart. mtnjam72 1st Gen. Tacomas 2 12-10-2009 05:06 PM
Many codes and engine runs rough TWM2001 1st Gen. Tacomas 41 11-08-2009 07:36 PM
Truck runs rough on A/C Roadrunner Technical Chat 0 06-30-2009 04:00 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.