Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

Mass air flow

Reply
 
Thread Tools Search this Thread
Old 06-30-2011, 01:08 PM   #1
JDenny15 [OP] JDenny15 is offline
Senior Member
JDenny15 is on a distinguished road
Name: Jason
Joined: Feb 2011, #50579
Location: Bozeman, Montana
Age: 25
Gender: Male
Posts: 105
JDenny15's Tacoma Gallery
Mass air flow

Has anyone had problems with the mass air flow sensors on the 05 tacoma? I recently have been going through 1 to 2 sensors a week, and took it in to get checked and toyota told me nothing was wrong with the truck... they said that it was the after market O'Rilley's sensors that kept failing, and that if i get the toyota oem sensor it would work great. has anyone ever used an aftermarket sensor and had similar troubles?
  Reply With Quote
Old 06-30-2011, 06:24 PM   #2
Senior Member
skytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shed
 
skytower's Avatar
Navy: Gunners Mate
Name: Dave
Joined: Jun 2010, #38505
Location: virginia
Gender: Male
Posts: 3,199
skytower's Tacoma Gallery
Are you sure it's the sensor and not the wiring? That seems like an awfully high failure rate.
  Reply With Quote
Old 07-01-2011, 07:25 AM   #3
JDenny15 [OP] JDenny15 is offline
Senior Member
JDenny15 is on a distinguished road
Name: Jason
Joined: Feb 2011, #50579
Location: Bozeman, Montana
Age: 25
Gender: Male
Posts: 105
JDenny15's Tacoma Gallery
I rewired the harness, and checked voltage drops and resistance and all is good is the wiring. toyota checked it over too. that was what i thought went wrong...
  Reply With Quote
Old 07-01-2011, 07:31 AM   #4
I support a velociraptor free workplace.
BrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shed
 
BrokenTusk's Avatar
Name: Marcelasaurus
Joined: May 2010, #36607
Location: AB, Canada
Age: 27
Gender: Chick
Posts: 32,105
BrokenTusk's Tacoma Gallery
Have you tried cleaning or checking your air filter? maybe you have a big hole in it and dirts pelting your sensor?
  Reply With Quote
Old 07-01-2011, 07:32 AM   #5
I support a velociraptor free workplace.
BrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shed
 
BrokenTusk's Avatar
Name: Marcelasaurus
Joined: May 2010, #36607
Location: AB, Canada
Age: 27
Gender: Chick
Posts: 32,105
BrokenTusk's Tacoma Gallery
OOOOOOH, wait you have the URD TCAI intake system? do you have the water shield that the new ones came with? the original ones have issues in moist climates
  Reply With Quote
Old 07-01-2011, 07:44 AM   #6
Senior Member
skytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shed
 
skytower's Avatar
Navy: Gunners Mate
Name: Dave
Joined: Jun 2010, #38505
Location: virginia
Gender: Male
Posts: 3,199
skytower's Tacoma Gallery
Did they take a look at the hoses between the MAF and the intake. Maybe it has a leak. What code were you getting?
  Reply With Quote
Old 07-01-2011, 01:30 PM   #7
JDenny15 [OP] JDenny15 is offline
Senior Member
JDenny15 is on a distinguished road
Name: Jason
Joined: Feb 2011, #50579
Location: Bozeman, Montana
Age: 25
Gender: Male
Posts: 105
JDenny15's Tacoma Gallery
i have the pre filter on the intake. i checked all the hoses, no leaks. i cleaned the filter and tried it dry and oiled, and both ways popped mass air flow sensors. I ordered up a toyota mass air flow, and toyota seems to think that will fix my problems, so we'll see.....
  Reply With Quote
Old 07-01-2011, 01:32 PM   #8
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,265
98tacoma27's Tacoma Gallery
Tacomas are famous for not liking aftermarket sensors. Try getting a Denso from rockauto.com (or anywhere but the stealership). You've probably already spent enough to buy 2 of them.
  Reply With Quote
Old 07-01-2011, 01:45 PM   #9
I support a velociraptor free workplace.
BrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shedBrokenTusk is one of the sharper tools in the shed
 
BrokenTusk's Avatar
Name: Marcelasaurus
Joined: May 2010, #36607
Location: AB, Canada
Age: 27
Gender: Chick
Posts: 32,105
BrokenTusk's Tacoma Gallery
Good luck
  Reply With Quote
Old 07-01-2011, 02:52 PM   #10
JDenny15 [OP] JDenny15 is offline
Senior Member
JDenny15 is on a distinguished road
Name: Jason
Joined: Feb 2011, #50579
Location: Bozeman, Montana
Age: 25
Gender: Male
Posts: 105
JDenny15's Tacoma Gallery
i already spent enough to get three or four.... but i talked the stealership into putting on a one year warranty on the sensor. but if i goes out i'll check out that site. thanks
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTS Mass Air Flow Sensor yote69301 1st Gen Tacoma Marketplace 5 02-29-2012 12:09 AM
Mass air flow sensor?? antf42080 1st Gen. Tacomas 4 07-18-2011 05:26 PM
Mass Air Flow problem dann 190 Technical Chat 15 03-28-2011 07:25 PM
Mass Air Flow Sensor? bp_phil16 2nd Gen. Tacomas 3 07-30-2009 12:32 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.