Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

Threw some codes today: P0606 and P0138, need advice

Reply
 
Thread Tools Search this Thread
Old 03-26-2012, 08:26 PM   #1
TRDguyKC [OP] TRDguyKC is offline
Senior Member
TRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shed
 
TRDguyKC's Avatar
Name: Kris
Joined: Sep 2008, #9316
Location: Glendale, AZ
Age: 28
Gender: Male
Posts: 1,007
TRDguyKC's Tacoma Gallery
Threw some codes today: P0606 and P0138, need advice

So as the title states, I threw these codes today:

P0138: 02 sensor circuit high voltage (bank I sensor 2)
P0606: ECM processing error

Heres the deal: I have TRD CAI and DT longtubes. I have been running with the CEL on for the last 2 years or so and emissions time came around so I decided to order the URD O2 sim. At any rate, I installed it roughly a month ago and all has been well thus far. I went and did some wheeling and went through a few small puddles.

Now Im throwing these codes. I took the neg. batt. terminal off for 30 minutes and hooked it back up and it threw the codes again immediately.

Im wondering if its possible that water got into the harness where the O2 sim connects and is now "bad" and causing the codes, but I honestly have no idea.

I would like any input and your thoughts!

Thanks for reading guys!
-Kris
  Reply With Quote
Old 03-26-2012, 09:30 PM   #2
TRDguyKC [OP] TRDguyKC is offline
Senior Member
TRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shed
 
TRDguyKC's Avatar
Name: Kris
Joined: Sep 2008, #9316
Location: Glendale, AZ
Age: 28
Gender: Male
Posts: 1,007
TRDguyKC's Tacoma Gallery
*also forgot to add that it threw these codes after the wheeling trip, then cleared themselves for a day.... now theyre back.
  Reply With Quote
Old 03-27-2012, 06:38 AM   #3
TRDguyKC [OP] TRDguyKC is offline
Senior Member
TRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shed
 
TRDguyKC's Avatar
Name: Kris
Joined: Sep 2008, #9316
Location: Glendale, AZ
Age: 28
Gender: Male
Posts: 1,007
TRDguyKC's Tacoma Gallery
early morning bump!
  Reply With Quote
Old 03-27-2012, 07:28 AM   #4
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,255
98tacoma27's Tacoma Gallery
I'd double check the connectors at the simulator. One maybe loose or wet.

http://www.ncttora.com/fsm/05+/data/...ta/0050042.pdf
  Reply With Quote
Old 03-27-2012, 12:26 PM   #5
TRDguyKC [OP] TRDguyKC is offline
Senior Member
TRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shedTRDguyKC is one of the sharper tools in the shed
 
TRDguyKC's Avatar
Name: Kris
Joined: Sep 2008, #9316
Location: Glendale, AZ
Age: 28
Gender: Male
Posts: 1,007
TRDguyKC's Tacoma Gallery
yea I went last night and unplugged the 02 sim and reinstalled it.... still getting the codes. Im thinking water got in and either trashed the O2 sensor or trashed the sim.
  Reply With Quote
Old 03-05-2013, 07:58 PM   #6
Member
DOUBLEJTACOMA is on a distinguished road
Name: Jeremy
Joined: Feb 2012, #72324
Location: Jasper, Alberta
Gender: Male
Posts: 35
DOUBLEJTACOMA's Tacoma Gallery
Any update on this? I'm experiencing a similar situation. Big dump of snow followed by a big melt event = many many puddles. Now throwing P0138 ie. my urd sim isn't functioning anymore. Just wondering if you were able to solve this without having to purchase another sim....?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
p0158 p0606 after long tubes and URD o2 sim TheHansen Technical Chat 10 03-27-2012 11:15 AM
Made it threw Porter Rd today!!! punisher03 North East 15 01-16-2012 06:47 AM
Engine Throwing 3 Codes, need some advice ripewithdecay 2nd Gen. Tacomas 8 06-11-2010 01:31 PM
Check Engine Light with codes P0420, P0430, P0606 P. Bauer 2nd Gen. Tacomas 2 07-18-2009 02:46 PM
Threw a code. dually 1st Gen. Tacomas 7 10-02-2008 07:07 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.