Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

PO171/174 (AARGH)

Reply
 
Thread Tools Search this Thread
Old 05-04-2012, 05:49 AM   #1
jax45 [OP] jax45 is offline
Junior Member
jax45 is on a distinguished road
Marines: Staff Sgt
Joined: Apr 2009, #15907
Location: Sharpsburg Ga.
Gender: Male
Posts: 12
jax45's Tacoma Gallery
PO171/174 (AARGH)

My 2005 tacoma has the PO171/174 Codes. Last year cleaning MAF and air filter made it go away. Now, have changed MAF and air filter, still have codes. Long fuel trim is way high on both banks, this is setting code. I either have a whopper vacuum leak or fuel pump issue. Has anyone had trouble with vacuum leaks on the 1GRFE? Intake gaskets, or throttle body gaskets?
Any suggestions will be greatly appreciated. Oh yeah, also changed PCV valve.
  Reply With Quote
Old 05-04-2012, 06:40 AM   #2
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,265
98tacoma27's Tacoma Gallery
Maybe the A/F sensor heater relay is bad.

For those playing the home game:

http://www.ncttora.com/fsm/05+/data/...ta/0050027.pdf
  Reply With Quote
Old 05-04-2012, 11:51 AM   #3
jax45 [OP] jax45 is offline
Junior Member
jax45 is on a distinguished road
Marines: Staff Sgt
Joined: Apr 2009, #15907
Location: Sharpsburg Ga.
Gender: Male
Posts: 12
jax45's Tacoma Gallery
Thanks!

Thanks for the suggestion. I can do that before reinventing the wheel. I'm lucky to have an 07 4runner with the same engine, so I can do a swapatronic. I have a scan tool so I'll know if its successful immediately. Just hope the wife doesn't catch me swapping her parts. Thanks again.
  Reply With Quote
Old 05-12-2012, 10:21 AM   #4
jax45 [OP] jax45 is offline
Junior Member
jax45 is on a distinguished road
Marines: Staff Sgt
Joined: Apr 2009, #15907
Location: Sharpsburg Ga.
Gender: Male
Posts: 12
jax45's Tacoma Gallery
PO171/174

Have replaced maf, pcv and a/f heater relay. Can find no vacum leaks(checked with propane), anyone know if computer is too quick to fool? Freeze frame shows that long term fuel trim is at 40% when fault(s) occur. So it definitely is in a lean condition. Ideas anyone? The truck is always running with too much correction. It is running at about 20% all the time on the long term fuel trim. The short term is about normal. Seems that a/f sensor readings are fairly normal except when fault is logged.
  Reply With Quote
Old 06-06-2013, 05:06 AM   #5
Junior Member
mark1257 is on a distinguished road
Name: mark
Joined: Nov 2012, #90711
Location: ga
Gender: Male
Posts: 7
mark1257's Tacoma Gallery
I had the same problem with my 2005.
I changed the MAF and the dealer diagnosis "twice" was the fuel ratio sensors.
The problem is the fuel pump!!!!!
The real problem is the filter/screen attached to the pump,its flat and small.
I don't know if you can just buy the screen.
The computer is trying to richen the mixture to the point it can't and sets the codes,starving for fuel.
I bought a denso fuel pump kit from advance auto parts for just over $100.00,its a pump and filter with good instructions. Fairly easy to change.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thrown PO171 code help Phearson 1st Gen. Tacomas 10 06-05-2012 12:49 PM
PO171, PO174: Found Problem, Fix? 01111000 Technical Chat 2 04-30-2012 06:48 PM
Po171 I'm at a Lose. ChiefThickums 1st Gen. Tacomas 11 11-21-2010 09:01 PM
Ion Alloy 174 91Toyotabogger Wheels & Tires 0 08-02-2010 07:42 PM
PO171 OBD2 Code NLamb1978 1st Gen. Tacomas 4 04-16-2010 04:55 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.