Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

switches killed battery (i think)

Reply
 
Thread Tools Search this Thread
Old 01-09-2009, 10:00 AM   #1
Senior Member
caliKxracer is a jewel in the roughcaliKxracer is a jewel in the roughcaliKxracer is a jewel in the roughcaliKxracer is a jewel in the rough
 
caliKxracer's Avatar
Name: kyle
Joined: Jul 2008, #8240
Location: san diego
Age: 22
Gender: Male
Posts: 244
caliKxracer's Tacoma Gallery
switches killed battery (i think)

ok first off, im on my phone, so I don't have pics. I was wiring up all my lights last night, I used the mini add a circut and used one fuse from interior panel, and the two other ones from the engine bay fuse box, I wired everything up they worked, the interior fuse was switched hot, the other two are constant hot, ok so I figure all is good, so I go inside for the night, then I come out In the morning, and turn the key clicks couple times and died, I had to go to school fast, so I just pulled power from switches jumped the truck and left. the switches were turned off when I went in for the night, so im really confused as to what could have drained the battery.any ideas?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
HO alternator/Dual Battery/Battery Separator/"Big 3 Upgrade chazjb 1st Gen. Tacomas 13 04-09-2012 05:13 AM
What killed your buzz? SlurpeeBlueMetallic 2nd Gen. Tacomas 7 05-27-2011 09:09 PM
i killed my truck. MsTRD 2nd Gen. Tacomas 257 02-25-2010 11:29 PM
I think I killed my LSD dtrujillo63 2nd Gen. Tacomas 19 01-24-2009 01:32 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.