Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

Certain Interior Lights Quit Working

Reply
 
Thread Tools Search this Thread
Old 02-17-2013, 08:35 PM   #1
That One Guy
Turbomeister is on a distinguished road
 
Turbomeister's Avatar
Joined: Feb 2013, #97788
Location: Missouri
Gender: Male
Posts: 13
Turbomeister's Tacoma Gallery
Certain Interior Lights Quit Working

So I'm new here, been lurking for a while but this is my first post.

I decided to do the DTRL Switch Mod here and successfully got it working.



There's where I put my switch.

But right after I finished, a front blinker bulb burned out (Great timing). I didn't realize what happened, so I pulled the switch back off, looking for a loose connection. And being the impatient idiot that I am, I used a circuit tester (Light bulb and battery, about 5 volts) to test the switch without unplugging it from the truck wiring.

I quickly realized this was a mistake, because now not only is my blinker bulb burned out, but now the HVAC control backlights, all driver side dash button backlights except fogs and traction control, and all window control lights except the driver's are not lit anymore.

My question is, did I completely fry the interior computer and make an expensive mistake, or is each individual bulb burned out? I thought about a fuse, but I figured that if it was a fuse, all the interior lights would be out, not just select ones.

Any ideas? I know I made a stupid mistake, but just how stupid? Has anyone ever done or seen something similar, and if so how did you fix it?
  Reply With Quote
Old 02-18-2013, 06:44 PM   #2
That One Guy
Turbomeister is on a distinguished road
 
Turbomeister's Avatar
Joined: Feb 2013, #97788
Location: Missouri
Gender: Male
Posts: 13
Turbomeister's Tacoma Gallery
Update:
Tonight I replaced the blinker bulb, but still no dice. I still have no front blinker on that same side, and the rear is blinking fast like you'd expect from a burned-out bulb. I'm thinking I may have fried some module computer under the dash, unless somebody knows of a special combination of fuses I could have blown to get these lights out?? Tomorrow night when I get time I'll go checking fuses
  Reply With Quote
Old 02-18-2013, 06:54 PM   #4
That One Guy
Turbomeister is on a distinguished road
 
Turbomeister's Avatar
Joined: Feb 2013, #97788
Location: Missouri
Gender: Male
Posts: 13
Turbomeister's Tacoma Gallery
No, the running lights are off, but that may be a result of my terrible switch I was troubleshooting when I caused this mess.

I just thought once I got the blinker and interior lights working again, then I can troubleshoot the running lights, which are only off because of a SPST switch on one wire. Before I burned whatever it is up, I tried the blinkers with the wire cut. Everything worked as expected, just minus the running lights.
  Reply With Quote
Old 02-19-2013, 04:57 PM   #5
That One Guy
Turbomeister is on a distinguished road
 
Turbomeister's Avatar
Joined: Feb 2013, #97788
Location: Missouri
Gender: Male
Posts: 13
Turbomeister's Tacoma Gallery
Summary:

Ok, here's a summary for my long rambling series of posts. (Sorry!) Front right blinker not working (for blinkers or hazards). Bulb is good. Certain interior lights (power window switch backlights, driver's side dash button backlights for everything except fogs and traction control, and climate control knob backlights) not working. DTRL not working (although that was the goal I was trying to achieve, so it's a non-issue). Everything else in the truck works.

After some research, I've decided it must be the body ECU on the backside on the fuse block in the lower dash on the driver's side. Does anyone have any diagrams or information on this module or any others that control these lights? I can't find any information on it, or even any place that stocks it.

My question is first, is this the only possible module that could control these lights? I know nothing about this, and am having trouble researching it. Secondly, does anybody have any information at all about this module? Like pricing or where I could get it or anything? Any experiences at all with the body ECU?

Please....I really need some help here! Thanks
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower motor quit working then starts working. Ideas? cmf21 1st Gen. Tacomas 3 12-19-2012 12:44 PM
Cruise control quit working 06RedComa 2nd Gen. Tacomas 4 12-06-2012 04:08 PM
Sub quit working... UTVols Audio & Video 5 11-07-2012 10:25 AM
HIDs randomly quit working Snow.White.Tacoma 2nd Gen. Tacomas 7 08-02-2012 04:12 AM
Horn quit working... any suggestions? eltaco Technical Chat 9 06-11-2010 09:50 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.