Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

Pesky P0420 trouble code

Reply
 
Thread Tools Search this Thread
Old 02-24-2013, 12:28 PM   #1
Junior Member
travisdean54 is on a distinguished road
Army:
Name: Travis
Joined: Jun 2012, #79933
Location: Camden, NC
Gender: Male
Posts: 2
travisdean54's Tacoma Gallery
Pesky P0420 trouble code

I still own my first Tacoma (2000 4wd 2.7L) with 261k. Every 2 years or so I get a check engine light and its always the P0420 code (catalyst below threshold bank). I've changed o2 sensors and it takes care of it for a while. I'm thinking its the converter going bad but the truck has the CA emissions package on it and there are 2 converters. Has anyone else had this problem and if so what did you do to fix it? Any help is greatly appreciated.
  Reply With Quote
Old 02-24-2013, 06:37 PM   #2
Formally afroman5015
bellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shedbellassaiw10 is one of the sharper tools in the shed
 
bellassaiw10's Avatar
Army: 31B 1132 MP Co.
Joined: Jun 2010, #39032
Location: Currituck NC
Age: 22
Gender: Male
Posts: 3,835
bellassaiw10's Tacoma Gallery
My MAF sensor was gunked up from the K&N, also welcome to the forums I'm from currituck
  Reply With Quote
Old 02-24-2013, 10:06 PM   #3
Senior Member
01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold01kingtaco is a splendid one to behold
 
01kingtaco's Avatar
Name: Kodiak
Joined: Sep 2012, #87393
Location: Maui hawaii
Gender: Male
Posts: 265
01kingtaco's Tacoma Gallery
Had a exhaust leak fixed the leak no more code
  Reply With Quote
Old 02-25-2013, 08:10 AM   #4
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 46
Gender: Male
Posts: 8,051
BamaToy1997's Tacoma Gallery
Quote:
Originally Posted by travisdean54 View Post
I still own my first Tacoma (2000 4wd 2.7L) with 261k. Every 2 years or so I get a check engine light and its always the P0420 code (catalyst below threshold bank). I've changed o2 sensors and it takes care of it for a while. I'm thinking its the converter going bad but the truck has the CA emissions package on it and there are 2 converters. Has anyone else had this problem and if so what did you do to fix it? Any help is greatly appreciated.
You are definitely looking at a possibility of a bad catalytic converter. Getting 261K miles on one is not a bad lifetime for it. Do you have a scan tool that will give you live data? If so, look at the graph for your post cat sensor. If it is jumping up and down like the pre cat sensor, then you are looking at a catalytic converter that will need to be replaced, assuming that you have replaced both sensors and that there are no air leaks in your exhaust system.
  Reply With Quote
Old 02-25-2013, 10:04 AM   #5
Junior Member
travisdean54 is on a distinguished road
Army:
Name: Travis
Joined: Jun 2012, #79933
Location: Camden, NC
Gender: Male
Posts: 2
travisdean54's Tacoma Gallery
I've replaced both O2 sensors a couple of times. I've even replaced the #2 cat since I have two on this truck. I'm gonna crawl underneath and. Check for leaks again but maybe it's just time to replace the cats.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
How serious is a p0420 code? ToyoTaco02 1st Gen. Tacomas 14 09-17-2012 06:10 PM
P0420 Code flesheatingvirus 1st Gen. Tacomas 7 05-08-2011 09:27 PM
Trouble code P0420 el contrador 1st Gen. Tacomas 12 03-04-2011 06:47 AM
p0420 code wildjerseyfirefighter 1st Gen. Tacomas 2 11-27-2010 08:40 AM
Code P0420 CoreyF 1st Gen. Tacomas 1 01-26-2010 05:02 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.