Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Technical Chat

Notices

Interference in CB and radio when engine is on

Reply
 
Thread Tools Search this Thread
Old 04-19-2013, 10:24 AM   #1
dad32509 [OP] dad32509 is offline
Thinking of something clever
dad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the sheddad32509 is one of the sharper tools in the shed
 
dad32509's Avatar
Name: Dave
Joined: Sep 2011, #64230
Location: San Diego
Age: 31
Gender: Dude
Posts: 3,072
dad32509's Tacoma Gallery
Interference in CB and radio when engine is on

I helped my friend put in an aftermarket double din stereo in his truck a couple months ago, and after we got it all hooked up we had some interference in the audio. It gets worse when something electrical comes on, like the windshield wipers, or A/C. We thought maybe we had a bad ground, but I ran a ground wire to the engine cab and tried all ground cables behind the stereo and have the same issue.

Yesterday we installed a cb radio in his truck, and the exact same thing is happening in the cb. We didnt tie the cb into anything. Straight power to the battery, and ground to a bolt on the engine cab that the negative on the battery was also going to. Any feedback or info would be awesome. Thanks
  Reply With Quote
Old 04-21-2013, 08:08 AM   #4
Senior Member. Hey, what's That supposed to mean?
coma09 will become famous soon enoughcoma09 will become famous soon enough
Joined: Jun 2009, #18751
Location: BC Canada
Gender: Male
Posts: 206
coma09's Tacoma Gallery
Whine that increases with engine rpm? Alternator
Static that increases with rpm? Spark

Alternator whine can be cleaned up with a filter.

Spark noise fixed with resistive core wires. Better shielded coax to antenna may help, different path to run antenna may help, but the antenna is picking up the rfi generated by the spark.
However my 2013 has direct connected plugs to the coils, so I'd be screwed as for changing spark plug wires as a solution.

My factory radio does have some whine with the wipers on, ESP on AM. Considered a filter for the wiper motor, but then I don't use am

If you have a ham radio shop nearby, see them re a filter. Goes between alternator output and ground. A good car audio shop should have them too. Also filters to put on power wire at the radio are available.

Start there. Spark noise is harder to address, though they may have some ideas.
  Reply With Quote
Old 04-21-2013, 08:10 AM   #5
Useful Idiot
thebigsmit is on a distinguished road
 
thebigsmit's Avatar
Name: Brent
Joined: Jan 2013, #95107
Location: South Carolina
Gender: Guy
Posts: 94
thebigsmit's Tacoma Gallery
Aliens
  Reply With Quote
Old 07-20-2013, 03:36 PM   #6
2011 TRD Sport 4x4
Junebug55210 will become famous soon enoughJunebug55210 will become famous soon enough
 
Junebug55210's Avatar
Name: Kyle
Joined: May 2011, #56115
Location: Gainesville, FL
Gender: Male
Posts: 471
Junebug55210's Tacoma Gallery
You want to run the power wire straight to the battery and have a ground no longer than a couple feet.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
CB radio help, loud interference with braking/ignition Fire Force Audio & Video 21 08-20-2014 03:48 AM
Cobra 75 WX ST Install & CB Interference With HIDs. zero4 Technical Chat 13 12-26-2013 01:27 PM
Interference or non-interference engine in the TACO Boudreaux 1st Gen. Tacomas 2 11-07-2011 08:42 AM
HIDs causing radio interference? What gives? james Lighting 5 08-23-2010 05:19 PM
Static radio interference after HIDs?? nolanspawn Audio & Video 5 10-18-2009 08:50 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.