Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   Technical Chat (http://www.tacomaworld.com/forum/technical-chat/)
-   -   ac stopped working and light flashed (http://www.tacomaworld.com/forum/technical-chat/285175-ac-stopped-working-light-flashed.html)

RedBaron 07-05-2013 10:15 AM

ac stopped working and light flashed
 
While driving the ac light started to flash and ac did not cool. Tried recharging and it would not take one can. Now nothing happens at the ac switch.

Thanks for replies. Problem is not the relay. Was replaced with a known good one and the a/c still does not work. I suspect the high pressure switch. Does the system have to be evacuated to change that? The system seems to be fully charged.

totmacher 07-05-2013 10:26 AM

Fan and defrost are still working? Just not a/c?
Had something similar on mine. Push and pull on the fan speed knob. Mine had bad contact on that knob that affected whether ac would come on.
Pop out the knob panel and just make sure plugged in. I ended up having to bend the metal tab inside to get more pressure for contact.

Or, check fuses?

Benson X 07-05-2013 10:30 AM

1 Attachment(s)
I had a similar problem recently, and searched around on TW. It seems there is a known issue among Toyotas in general, where the A/C Fan Clutch relay goes out intermittently.

This is usually remedied by turning the A/C off and back on, but a replacement relay may be necessary.

http://www.tacomaworld.com/forum/att...8&d=1373041780

Attachment 221568

Here's some good info. from another thread:

Quote:

Originally Posted by buddywh1 (Post 2062986)
To follow up...I couldn't find a replacement relay at pepboys or autozone...and I'm not ready to pay the $90 I hear Toyota is charging for one SOOOOooo...

I swapped the TOWING TAIL lights relay with it since I'm not towing anything right now. A/C works just fine, but it had only done the b blinking thing twice before so I suppose I'll never know for certain if that was it.

But...for anyone who'd be interested...this relay (the A/C clutch control relay, part no 90987-02028) is a REAL common problem for Toyota's. For some reason Toyota dealers want to charge heinous price for it, and it's just a SPST 12 volt relay using industry standard pin-outs and form. Mazda sells one that works just fine...their p/no is B115. If I can't find one for the normal price of $15 or so I'll be looking for a Mazda dealer.

Quote:

Originally Posted by RCBS (Post 2063047)
Thepartsbin.com has a relay referred to as "AC fan clutch relay" for 17.95 ea. Their part number is W0133-1762256. its a Denso relay.


jammdogg 07-05-2013 10:38 AM

I saw this and immediately went looking for your post Ben. Did the relay fix it?

Benson X 07-05-2013 10:40 AM

I haven't replaced it yet, as it only happened once on out TSF trip. I just pressed the A/C button off, then back on and haven't had a problem since.

I originally thought the refrigerant was low, but after reading up on it more, I'm leaning towards a bad relay.

09GreenSugarTaco 07-13-2013 06:12 AM

I am having an AC issue. The AC always works on full blast but when it's set on another setting it turns on and off on its own. Would this be the relay issue? I had posted on another thread and was told to check the blower fix on this website. Thanks for any help

RevAdam 07-13-2013 06:16 AM

Mine does that if you have a good splashdown in the water. Cycle the A/C switch, fixes it immediately.

09GreenSugarTaco 07-14-2013 08:04 AM

I cycle through them but usually takes a little while for it to start working. Usually while driving down the highway it will stop and then start back up. It seems to be fine after I drive for a while. It did rain pretty hard a couple weeks ago. Not sure if that has something to do with it. Makes me curious now that you say that.


All times are GMT -7. The time now is 09:05 AM.