Go Back   Tacoma World Forums > Tacoma Garage > Towing

Notices

Tekonsha P3 Installation on 2002 Tacoma

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-16-2009, 06:53 PM   #1
dellaquila [OP] dellaquila is offline
Junior Member
dellaquila is on a distinguished road
Air Force: Separated Meteorologist (SSgt)
Name: Mark
Joined: Aug 2007, #2402
Location: Huntsville, AL
Age: 29
Gender: Guy
Posts: 20
dellaquila's Tacoma Gallery
Question Tekonsha P3 Installation on 2002 Tacoma

Hey everybody, I've been reading stuff and lurking on here for a long time and have learned a lot about towing and my Taco in general. I bought a 2002 Xtra Cab TRD with the 3.4L back in 2005 and have loved it so far. I'm going to be separating from the Air Force at the end of June and want to move all of my stuff myself to make some extra money. I'll have about 3000-4000 pounds of stuff to move I'm thinking and plan on using my Tacoma and an enclosed 6x12 trailer that I'm still shopping around for. I know that's pushing the limits of the V6 but I think for one trip it'll be ok. I don't have the factory "tow package" but it's not an automatic so that doesn't change much, just the fan right? Anyway, on to my question.

I installed a Tekonsha P3 brake controller and a 7 pin plug the other day and ran all the wires and everything required. I have pictures I can upload later if anyone's interested in what I did/where I mounted stuff. I've tested all of the wires and everything is working right except the brake. I spliced the red wire from the P3 into a green wire w/white stripe on the brake switch after testing to make sure it was the right one. I get voltage and amps when the brake pedal is pushed, but not when it's released, so it seems to be the right one.

I hooked up a trailer to test pull it today and everything worked except it wasn't picking up when I pushed the pedal. The manual override worked though and activated the trailer brakes. I've tested it again twice since then and both times it worked right, at least on my multimeter. I'm testing it at the plug for the P3. Soooo, if the red wire going INTO the P3 is getting the right signal and the blue wire coming OUT OF the P3 works with the manual override, doesn't that make all fingers point to the P3 itself, or am I missing something? The P3 seems to function right and knew the trailer was there and didn't throw any error messages at me, but it wouldn't activate the trailer brakes when I pushed the truck's pedal. If I put the "Stoplight" diagnostic up and push the brake it'll spike up like it should, but still, no signal going to the trailer. Any ideas? Thanks for reading that ridiculously long post by the way... it shouldn't happen again.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rostra Cruise Control installation on 2002 V6 Auto Sign Guy 1st Gen. Tacomas 12 04-02-2014 08:59 PM
Tekonsha P3 brake controller. Can I borrow your brains? ChuckLee Towing 6 05-18-2012 06:36 PM
Tekonsha P3 Install. Mongrel Towing 3 08-02-2011 04:05 PM
2002 Tacoma Viper 5901 installation issue Fastracer 1st Gen. Tacomas 5 06-22-2011 08:21 PM
Tekonsha P3 Electronic brake controller...Is it Good..?? Mr.Tacoma 2nd Gen. Tacomas 5 11-21-2010 03:31 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.