Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   Towing (http://www.tacomaworld.com/forum/towing/)
-   -   Tekonsha Voyager Brake control question (http://www.tacomaworld.com/forum/towing/267324-tekonsha-voyager-brake-control-question.html)

Hollywood218 03-09-2013 05:06 AM

Tekonsha Voyager Brake control question
 
2013 DCSB 4x4 Off-Road w/ factory tow pkg. I installed the Tekonsha Voyager brake controller (only has a multi-colored LED) and I am curious; when there is no trailer plugged in, there appears to be no indication that the unit is installed/plugged in/etc. Is this normal? Is the controller basically an open circuit until a trailer is connected/plugged in? I bought a TT and am getting everything set up to take delivery of it, so I don't have a trailer to plug in at the moment.:taco:

Hollywood218 03-09-2013 12:44 PM

TT is now at my house. No problems, everything works perfectly.:taco:

strutbuster10 03-11-2013 05:48 AM

Where did you mount the controller?

Hollywood218 03-11-2013 06:44 AM

Quote:

Originally Posted by strutbuster10 (Post 6569953)
Where did you mount the controller?

I mounted it in that little dish/pocket to the right of the steering column.

BB72 03-22-2014 03:08 PM

Hi, I realize this is a old thread, but maybe on the off chance you have a photo of your install?

I just bought the Tekonsha voyager as well. The instructions say to make sure that it's level, and I'm wondering just how level that has to be.

Any thoughts on that would be appreciated, thx.


All times are GMT -7. The time now is 05:01 PM.