Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > Toyota Trucks & SUVs

Notices

Truck won't start, fuel pump question.

Reply
 
Thread Tools Search this Thread
Old 07-20-2010, 01:40 PM   #1
luk8272 [OP] luk8272 is offline
Poodoo
luk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shed
 
luk8272's Avatar
Name: Lucas
Joined: Feb 2008, #4929
Location: Kaplan, Louisiana
Gender: Guy
Posts: 5,844
luk8272's Tacoma Gallery
Had fuel pump issue now others.

Got the fuel pump under control but have other questions in post 4.

1990 pickup 3.0, auto, 4wd.

Truck turns over fine, has fire, but I'm not getting fuel to the engine or to the filter. I'm assuming that the pump is bad.

Now there could be a mistake on my part and here is why. I pulled the plenum along with everything involved to replace the fuel injectors, while there also replaced the PCV valve and all lines that were looking iffy. Could I have left something unplugged that would affect the fuel pump, maybe a relay or something? I don't think so, but thought I would ask those that may know better than myself.

The follow up question if the pump is bad would be is it easier to drop the tank or remove the bed? I always here people talking about how the removed the bed to work on their tanks but have never done it myself. Any personal experience and advise?
  Reply With Quote
Old 07-20-2010, 07:07 PM   #2
luk8272 [OP] luk8272 is offline
Poodoo
luk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shed
 
luk8272's Avatar
Name: Lucas
Joined: Feb 2008, #4929
Location: Kaplan, Louisiana
Gender: Guy
Posts: 5,844
luk8272's Tacoma Gallery
I ran out of patients, here is what I have done. I went ahead and purchased a fuel pump and strainer/filter. Dropped my tank and installed new pump and strainer, reinstalled the fuel tank. Worked truck until it started. Was a short lived glory as the truck won't idle or stay running without a good bit of throttle. I also have what I would call a miss on the drivers side as well as a tick that I think is the speedo cable. I have quit with the physical work for the night and will continue trouble shooting this in the morning. Feel free to drop me some ideas.
  Reply With Quote
Old 07-25-2010, 01:43 PM   #4
luk8272 [OP] luk8272 is offline
Poodoo
luk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shed
 
luk8272's Avatar
Name: Lucas
Joined: Feb 2008, #4929
Location: Kaplan, Louisiana
Gender: Guy
Posts: 5,844
luk8272's Tacoma Gallery
Here is a small update along with more questions.
Have what seems to be a miss not sure where or what just yet. Could be that an injector isn't getting a signal, possible a different issue. First I have to get this thing to idle.

When the truck is started I try to keep the rpm at 1000, very difficult to get it on 1k it jumps around uncontrolably. It will sit on 1k for a short time then just jump up in RPM to 3 or 4k quickly without me even moving my foot. I can keep a steady rpm using my hand, manipulating the throttle under the hood with ease. I am speculating that with the pedal the signal is shit I must have the throttle depressed more than what the rpm's are registering and actually what I am calling a spike in rpm is the signal finally registering and the truck reacting. Can or does anyone have any thoughts?
  Reply With Quote
Old 07-25-2010, 01:47 PM   #5
Senior Member
YeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shedYeahYeah is one of the sharper tools in the shed
 
YeahYeah's Avatar
Coast Guard: Honor Guard-Now out of Honor Guard getting ready for MK "A" School
Name: Thomas
Joined: Apr 2010, #36062
Location: (My Home - Murrieta, CA) Now, Alexandria, VA
Gender: Dude
Posts: 305
YeahYeah's Tacoma Gallery
go back, re-do, and i mean re-do everything you did. usually you find what you missed or messed up on. make sure fittings are tight. make sure connections are tight. check fuel filter(s) and pump one more time. and double even triple check everything. the smallest little nick can fuck shit up badly.
  Reply With Quote
Old 07-25-2010, 04:54 PM   #6
4WD 4WD is offline
cRaZy oLdmAn
4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed
 
4WD's Avatar
Name: Doug
Joined: Jul 2009, #19185
Location: Lakeside,CA
Age: 56
Gender: Male
Posts: 22,054
4WD's Tacoma Gallery
Pretty sure you got a vacuum leak somewhere, they can cause a jump in RPM, A drop in RPM, erratic idling or no idle at all & the delayed reaction from applying acceleration & getting the RPM's up is also indicative of vacuum loss(or gain even).......just something else to consider......
  Reply With Quote
Old 07-29-2010, 09:11 AM   #10
luk8272 [OP] luk8272 is offline
Poodoo
luk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shedluk8272 is one of the sharper tools in the shed
 
luk8272's Avatar
Name: Lucas
Joined: Feb 2008, #4929
Location: Kaplan, Louisiana
Gender: Guy
Posts: 5,844
luk8272's Tacoma Gallery
Thats been done for a while now. Thanks though, all suggestions are welcome.
New: (less the 1k miles on all of it.)
MaF sensor, Air filter, Plugs, Wires, Oil, Oil fiter, PCV, Gas as of last week, Fuel pump, Fuel Filter, diff fluid front and rear, transmission fluid, T-case fluid, Drive shaft was americanized, also replaced vacuum lines when looked iffy as well as other hoses. I'm sure there is more but this is all that is relevent at this time.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump running with truck off 85GT 79FJ40 2nd Gen. Tacomas 7 12-20-2014 08:31 PM
question about fuel pump Silvert Technical Chat 5 06-29-2011 09:27 PM
Truck shakes and then shuts off. is this a bad fuel pump? sir1123 1st Gen. Tacomas 2 06-21-2011 09:27 PM
truck hesitating after fuel pump installation rawdog Toyota Trucks & SUVs 0 01-26-2010 06:24 PM
Fuel pump pressure question andyJ Technical Chat 0 11-11-2009 03:39 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.