Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > Toyota Trucks & SUVs

Notices

2003 Toyota Tacoma V6 hesitation

Reply
 
Thread Tools Search this Thread
Old 11-09-2012, 03:51 PM   #121
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 11-09-2012, 06:57 PM   #122
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 11-09-2012, 10:07 PM   #123
Member
bseant is on a distinguished road
Joined: Nov 2011, #66725
Location: central valley,cali
Gender: Male
Posts: 36
bseant's Tacoma Gallery
cool thanks man. Was the installation a pain or did it go relatively smooth?
  Reply With Quote
Old 11-10-2012, 05:06 AM   #124
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 11-17-2012, 08:37 PM   #125
Senior Member
joes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shed
Name: Joe
Joined: Jan 2010, #28588
Location: Central Coast, CA
Gender: Male
Posts: 3,077
joes06tacoma's Tacoma Gallery
Quote:
Originally Posted by Eriksen0108 View Post
I need some help. My '03 Toyota Tacoma 3.4L 5spd has been hesitating only during the summer months for the past 4 years. It now has 110,000 miles on it and it seems to happen on hot days after its rained. I'll go to take off from a stop and it seems like its starving for fuel/air/spark...whatever. I'll have the pedal floored and it will finally take off after like 5-10 seconds of lag. I won't let anybody else drive it because it's dangerous. Then when I shift to 2nd, it does it again. Of course it won't reproduce the hesitation in the presence of a mechanic. I've replaced the MAF sensor, fuel filter, air filter, spark plugs, wires, coils, cleaned throttle body and used Fuel Injector Cleaner. During the winter, no hesitation at all. It's more severe with the A/C, but still happens without. Toyota couldn't reproduce it either and it will not throw an engine code.
Has anybody experienced this? Any suggestions?
How old is the timing belt? Could it be a tensioner issue? Just thinking out loud here.

On older vehicles I have had, this has been plug wires, bad vacuum advance module/distributor, fuel pump......stuff you don't have or have eliminated. But the same principles apply. Bad spark timing, valve timing, or a lean condition would cause it. But I would expect you to have a fault code stored too.

Have you checked the compression? How does it idle? Never heard of a 3.4 having valve clearance issues at less than 150K, but it could happen.

Edit: Just thought of this. My boss had a 98 4Runner with 3.4 and it had a fuel injector go bad. I don't remember the exact symptoms he had, but it took awhile to track that down. Not sure how the mechanic finally figured it out.
  Reply With Quote
Old 11-21-2012, 07:28 AM   #126
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 11-22-2012, 12:54 PM   #127
Senior Member
Tenax is on a distinguished road
 
Tenax's Avatar
Name: Terry
Joined: Aug 2012, #84501
Location: Alberta
Gender: Male
Posts: 167
Tenax's Tacoma Gallery
Got mine today. Looks good, mark!
  Reply With Quote
Old 11-23-2012, 12:55 PM   #128
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 11-27-2012, 08:25 PM   #129
Junior Member
will33 is on a distinguished road
Name: will
Joined: Nov 2012, #91969
Location: colorado
Gender: Male
Posts: 9
will33's Tacoma Gallery
ok. First of all I have an 03 trd that I bought in 05 with 37000 miles. i have the same truck and have been up with all services including synthetic oil and diff fluid. I now have 123000 thousand on it. I have to say, I have never had this perplexing issue luckily. One year ago i bought a g-force computer chip which reprograms the trucks computer to make it more efficient and to correct some of the issues that occur within the program of the vehicle. It might be a worthwhile investment. Its only $80 and it has slightly improved fuel economy, and has made the idle alone noticeably smoother. I do think the problem is in the programing software and not the mechanical workings of the vehicle. Just note, they do say that it takes 100 miles to reprogram the trucks computer. I had a lag in the idle at about 25 miles so bear with it, and as I did, I think you might find some relief. Would be anxious to hear some results.
  Reply With Quote
Old 12-10-2012, 10:46 PM   #130
Junior Member
Redd is on a distinguished road
Joined: Dec 2012, #92842
Location: Seattle
Gender: Male
Posts: 3
Redd's Tacoma Gallery
I just registered to chime in about this problem since it seems like an issue a lot of Toyota owners have been frustrated with. I got my Tacoma (97 manual trans 5vz-fe) a year ago which was running great for a couple months but then developed the intermittent stumbling/hesitation problem everyone in here has described. I replaced the plugs, wires and all 3 coilpacks with no success.

After that didn't fix the stumble my next guess was a sensor since the truck ran great except for this narrow spot it would intermittently stumble on lighter acceleration (often at cruising speed). Roughly the last couple of weeks though the truck has been almost undrivable due to it stumbling constantly when at cruising speed. After reading this thread (and a few others) the tps seemed like the most likely culprit. I just got the new tps today and since the install it has not stumbled at all. Just wanted to let everyone know this fixed my issue as well. I think it is safe to say if you develop the strange intermittent stumble/hesitation during lighter acceleration but your truck otherwise runs good the tps sensor is probably worn out and failing.
  Reply With Quote
Old 04-24-2013, 07:41 AM   #131
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 04-24-2013, 02:53 PM   #132
Senior Member
FramerKat will become famous soon enough
 
FramerKat's Avatar
Name: kAt
Joined: Jun 2012, #80089
Location: Fort Lauderdale, Florida
Gender: Chick
Posts: 280
FramerKat's Tacoma Gallery
It's funny...I've been thinking about this problem recently...my truck hasn't done it since our "rainy season" ended last year. I have driven through a couple of fairly large puddles though...and it still hasn't happened (it had previously after I drove through a fairly large puddle). We'll see what happens when the real rainy season starts again...which should be in the next month or so.
  Reply With Quote
Old 05-04-2013, 05:44 PM   #133
Junior Member
budshupe is on a distinguished road
Name: bud
Joined: Oct 2012, #88479
Location: lakeside ca
Gender: Male
Posts: 8
budshupe's Tacoma Gallery
Quote:
Originally Posted by Markmmg View Post
I was able to get a few more of the 4-pin throttle position sensors if anybody else needs one. I have put some of them of them on Ebay. You can search for the part number 89452-35030.
I don't see them. maybe they're already gone. Are you going to get more?
  Reply With Quote
Old 05-05-2013, 05:15 AM   #134
Junior Member
Markmmg is on a distinguished road
Army: 6 years national guard
Name: Mark
Joined: Oct 2012, #89823
Location: Baton Rouge, LA
Gender: Male
Posts: 22
Markmmg's Tacoma Gallery
.
  Reply With Quote
Old 05-05-2013, 07:25 AM   #135
Junior Member
budshupe is on a distinguished road
Name: bud
Joined: Oct 2012, #88479
Location: lakeside ca
Gender: Male
Posts: 8
budshupe's Tacoma Gallery
has anyone opened up one of these sensors to see whats going on or if they could be repaired. Does anyone have a drawing or exploded view?
  Reply With Quote
Old 05-08-2013, 05:58 PM   #137
Junior Member
budshupe is on a distinguished road
Name: bud
Joined: Oct 2012, #88479
Location: lakeside ca
Gender: Male
Posts: 8
budshupe's Tacoma Gallery
Quote:
Originally Posted by DriverSound View Post
I have one from the first batch that I bought from Markmmg still unopened. PM me if you want it.
I sent you a PM.
  Reply With Quote
Old 06-24-2013, 12:02 PM   #139
Junior Member
tubbsj is on a distinguished road
Name: Johnny
Joined: Jun 2013, #106934
Location: Alabama
Gender: Male
Posts: 3
tubbsj's Tacoma Gallery
Do you have any TPS (89452-35030)?
  Reply With Quote
Old 07-19-2013, 11:54 AM   #140
Junior Member
Tyree is on a distinguished road
Joined: Jul 2013, #108370
Location: Washington State
Gender: Male
Posts: 8
Tyree's Tacoma Gallery
I just ordered five Tacoma TPS sensors part #89452-35030 from on overseas wholesale supplier. They should be here in five days or so. Let me know if you are still interested.
Ty
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
FOR SALE: 2003 Toyota Tacoma Double Cab PreRunner V6 ONLY 12K miles!!! 79cruiserfj40 Buy / Sell / Trade 4 11-25-2013 01:50 PM
2003 Tacoma ext. cab v6 5 spd parting out Tony 1st Gen. Tacomas 11 03-10-2011 09:39 AM
Just got my 2003 Tacoma V6 PreRunner - tire size? rolandol New Members 3 02-02-2010 03:53 AM
2003 Tacoma TRD V6 Purchase markveneris 1st Gen. Tacomas 16 02-01-2010 08:31 AM
rocketeer928 - My 2003 Tacoma SR5 V6 Manual 4WD rocketeer928 New Members 11 09-24-2009 06:20 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.