Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > Toyota Trucks & SUVs

Notices

2tr-fe Hilux poor acceleration on top

Reply
 
Thread Tools Search this Thread
Old 11-01-2013, 01:14 PM   #1
Flex [OP] Flex is offline
Junior Member
Flex is on a distinguished road
Joined: Nov 2013, #115673
Gender: Male
Posts: 4
Flex's Tacoma Gallery
2tr-fe Hilux poor acceleration on top

Hi, I'm from Trinidad in the Caribbean and I own a 2007 Hilux 4x2 auto 2tr-fe engine. I recently notice when i'm accelerating on the high end it feels like some sort of power loss.... The vehicle is just not able to go pass 140km my comrades could make 180-200km easy. However the car starts perfect, idles great (AC on), Transmission shifts great, Plugs, air filter, fuel filter changed, injector cleaned, Maf cleaned, K&N filter. The car is doing 55,000 km works fine; it feels like a speed cut but there's none... It's very frustrating any ideas???

Thanks in advance
Flex
  Reply With Quote
Old 11-01-2013, 01:19 PM   #2
The forgetful dumbass
Gaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shed
 
Gaunt596's Avatar
Name: Matthew
Joined: Jun 2013, #106627
Location: Central Maryland
Gender: Male
Posts: 1,837
Gaunt596's Tacoma Gallery
Quote:
Originally Posted by Flex View Post
Hi, I'm from Trinidad in the Caribbean and I own a 2007 Hilux 4x2 auto 2tr-fe engine. I recently notice when i'm accelerating on the high end it feels like some sort of power loss.... The vehicle is just not able to go pass 140km my comrades could make 180-200km easy. However the car starts perfect, idles great (AC on), Transmission shifts great, Plugs, air filter, fuel filter changed, injector cleaned, Maf cleaned, K&N filter. The car is doing 55,000 km works fine; it feels like a speed cut but there's none... It's very frustrating any ideas???

Thanks in advance
Flex
umm.... not sure where to even start.. the Hilux is a whole different animal compared to a Tacoma.

On a side note if you dont want to deal with it ill send you my taco and you send me your Hilux lol
  Reply With Quote
Old 11-01-2013, 01:46 PM   #3
Flex [OP] Flex is offline
Junior Member
Flex is on a distinguished road
Joined: Nov 2013, #115673
Gender: Male
Posts: 4
Flex's Tacoma Gallery
LOL... I'm aware it's a tacoma forum i'm on but isn't the 2tr-fe 2.7 vvti the same??? When ever i search online that's what i keep getting hmmmm!!!



Diagnostic code P0031 O2 sensor bank1 sensor1... The thing is the light came off before we checked it (Stayed on for half day). You think this could cause my problem or just a coincidence?
  Reply With Quote
Old 11-03-2013, 12:09 AM   #4
The forgetful dumbass
Gaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shedGaunt596 is one of the sharper tools in the shed
 
Gaunt596's Avatar
Name: Matthew
Joined: Jun 2013, #106627
Location: Central Maryland
Gender: Male
Posts: 1,837
Gaunt596's Tacoma Gallery
Quote:
Originally Posted by Flex View Post
LOL... I'm aware it's a tacoma forum i'm on but isn't the 2tr-fe 2.7 vvti the same??? When ever i search online that's what i keep getting hmmmm!!!



Diagnostic code P0031 O2 sensor bank1 sensor1... The thing is the light came off before we checked it (Stayed on for half day). You think this could cause my problem or just a coincidence?
I thought all the hilux came with is a diesel?
  Reply With Quote
Old 11-03-2013, 12:25 AM   #5
Out fer a Rip eh Bud
VanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shedVanCity4x is one of the sharper tools in the shed
 
VanCity4x's Avatar
Name: DJ
Joined: Aug 2011, #60970
Location: BC
Gender: Male
Posts: 1,419
VanCity4x's Tacoma Gallery
Yup the 2tr fe is the 4cyl in Tacoma's.

Bad o2 sensor or related problem def could effect your performance. I'd try replacing the passenger side top o2 sensor or check for shorts, bad/loose connection.
  Reply With Quote
Old 11-04-2013, 01:49 PM   #6
Flex [OP] Flex is offline
Junior Member
Flex is on a distinguished road
Joined: Nov 2013, #115673
Gender: Male
Posts: 4
Flex's Tacoma Gallery
Thanks yes guys they came gas as well .... changed but no improvement only thing now is the Maf or maybe a speed cut... The van works well and pulls hard up to 140km just won't go pass... Thanks guys!!!
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to change sparkplugs 2TR-FE YotaMan2007 4 Cylinder 85 07-07-2014 05:05 PM
2TR-FE Reliability bromagen25 2nd Gen. Tacomas 46 11-01-2013 08:47 AM
Turbocharged 2TR-FE Boring 4 Cylinder 3 02-04-2013 02:33 PM
5W30 in 2tr-fe? jspadaro 2nd Gen. Tacomas 2 04-02-2012 04:53 PM
Can '08 2TR FE 2.7 adapt to '98 3rz FE vehicle ? Dustrider 4 Cylinder 1 12-03-2011 03:57 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.