Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > Toyota Trucks & SUVs

Notices

Electrical issues

Reply
 
Thread Tools Search this Thread
Old 05-03-2014, 04:17 PM   #1
Kimberly [OP] Kimberly is offline
Junior Member
Kimberly is on a distinguished road
Joined: May 2014, #129037
Gender: Male
Posts: 1
Kimberly's Tacoma Gallery
Electrical issues

Hi my 2009 tacoma truck shorted out this week. It got stuck in park after I took it out of reverse because it had felt not right sounded like it was revving. After this the turn signals stopped working, a/c, temperature gauge and backup camera all ceased. I replaced the number 8 fuse twice. First fuse lasted 5 minutes. Second one lasted until mechanics. They'd cannot figure out if it is the backup cam that caused this short or not. They pulled the wiring assembly for now. The camera has been intermittent blue screen crossed w inaccurate fuzzy blurry pictures. Has anyone had this issue and if so have you narrowed it to the back up camera being the cause? Thanks for reading!
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard electrical issues bowhunter1994 Technical Chat 1 02-07-2014 04:32 AM
electrical issues Norcalkid 1st Gen. Tacomas 0 05-20-2012 08:43 PM
Electrical issues in an '06 Tacoma Secondarychaos 2nd Gen. Tacomas 10 03-30-2011 10:15 PM
Recent Electrical Issues... dlvad 1st Gen. Tacomas 0 11-27-2010 03:34 PM
my electrical issues, tails ect fireturk41 1st Gen. Tacomas 19 06-14-2010 08:19 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.