Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   ToyTec Lifts (http://www.tacomaworld.com/forum/toytec-lifts/)
-   -   HAPPY & SATISFIED CUSTOMER!!! (http://www.tacomaworld.com/forum/toytec-lifts/230898-happy-satisfied-customer.html)

Tactical Tacoma 07-23-2012 06:55 PM

HAPPY & SATISFIED CUSTOMER!!!
 
So after much debate between OME, ICON and The Toytec ULK, I finally pulled the trigger and bought the full OME Kit with the 885x coils and the Toytec/Deaver 1.5" TSB AAL. I felt this kit was most applicable to my current and long term need (light offroading and trailing on fire roads in the National Forests and BLM areas.) Maybe in the future when the truck is not so new and shinny, and I am ready to start beating her up a bit, I'll upgrade to a full Icon long travel kit. But for now, this kit did more then I needed. It looks great, rides amazing and was/is priced right. Of course, it helps that I know how to do the installs myself and can save some change in that area.

I installed the kit this Sunday (07/22/12) by myself. Install took me about 6 hours (that's with multiple breaks, since its like 100*+ here in Dallas). I LOVE THIS KIT! Thanks to Amber and Dylan, I got all the answers and info I needed. Not to mention I got plenty of info from this forum.

Thank you Toytec, for doing what you do, and doing it well. Also thanks for giving us TW members a discount. I will always point others in your direction. Your prices are good, service is amazing and the shipping was reasonable and fast. I look forward to doing more business with you in the future.

Kit arrived fast and well packed (this is unpacked of course)
http://www.tacomaworld.com/gallery/d...m/IMG_8497.JPG

After install stance
http://www.tacomaworld.com/gallery/d...ium/Side46.JPG
http://www.tacomaworld.com/gallery/d...um/Front93.JPG

Foihdzas 07-24-2012 04:23 PM

S**t yea! That's the setup I went with, and I am super happy with the results! Great on the pavement, and awesome on the washboard forest service roads

kodybradford 07-27-2012 01:16 PM

Quote:

Originally Posted by Tactical Tacoma (Post 5429199)
So after much debate between OME, ICON and The Toytec ULK, I finally pulled the trigger and bought the full OME Kit with the 885x coils and the Toytec/Deaver 1.5" TSB AAL. I felt this kit was most applicable to my current and long term need (light offroading and trailing on fire roads in the National Forests and BLM areas.) Maybe in the future when the truck is not so new and shinny, and I am ready to start beating her up a bit, I'll upgrade to a full Icon long travel kit. But for now, this kit did more then I needed. It looks great, rides amazing and was/is priced right. Of course, it helps that I know how to do the installs myself and can save some change in that area.

I installed the kit this Sunday (07/22/12) by myself. Install took me about 6 hours (that's with multiple breaks, since its like 100*+ here in Dallas). I LOVE THIS KIT! Thanks to Amber and Dylan, I got all the answers and info I needed. Not to mention I got plenty of info from this forum.

Thank you Toytec, for doing what you do, and doing it well. Also thanks for giving us TW members a discount. I will always point others in your direction. Your prices are good, service is amazing and the shipping was reasonable and fast. I look forward to doing more business with you in the future.

Kit arrived fast and well packed (this is unpacked of course)
http://www.tacomaworld.com/gallery/d...m/IMG_8497.JPG

After install stance
http://www.tacomaworld.com/gallery/d...ium/Side46.JPG
http://www.tacomaworld.com/gallery/d...um/Front93.JPG

Did you have to mess with replacing UCA's or did the alignment match up without the hassle of doing so?

NativeTaco 08-11-2012 11:12 PM

Quote:

Originally Posted by kodybradford (Post 5449102)
Did you have to mess with replacing UCA's or did the alignment match up without the hassle of doing so?

X2 I've heard both, but I'm not able to get UCAs right now so I won't worry. Oh and I had a question, did your LCAs hang all the way down when you disconnected your ball joint on the spindle? I just installed some trd OR shocks and springs on my sr5 and had a tough time getting them in there because even after disconnecting everything from my LCA, it still didnt want to hang low enough to get another shock/spring in. Now that I have the lift I'm afraid that I won't e able to get the longer assembly in. Guess in a long way I just want to know if your LCA hangs down, of if you have to apply some pressure to the LCA or shock or both to install them? Did you leave your sway bar connected with the 885s?


All times are GMT -7. The time now is 01:41 AM.