1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

01 tacoma ideas?

Discussion in '1st Gen. Tacomas' started by rbl1994, Apr 11, 2013.

  1. Apr 11, 2013 at 8:13 AM
    #1
    rbl1994

    rbl1994 [OP] Member

    Joined:
    Apr 10, 2013
    Member:
    #101810
    Messages:
    19
    Gender:
    Male
    Texas
    Vehicle:
    01 PreRunner, TRD, SR5, 4 dr V6
    None
    I bought a 2001 Toyota tocoma dbl cab SR5 and TRD off road packages with the rear wheel diff. lock. 138k miles well when I get on it like to get up on the interstate it sounds like my engine is gonna blow up but it drives and runs well . when it idles it sounds like its missing but whn I turn the air conditioner on it revs up a little bit and doesn't sound like its missing anymore. any ideas of what this might be?? thank you
     
  2. Apr 11, 2013 at 8:18 AM
    #2
    zbaldo

    zbaldo Well-Known Member

    Joined:
    Feb 10, 2012
    Member:
    #72550
    Messages:
    433
    Gender:
    Male
    First Name:
    Ozzy
    Torrance, Ca
    Vehicle:
    99 4Runner SR5 4X4
    Stock as Stock can be with duratracs and a roof rack
    Welcome to TW, see if you could find a place that has an OBDII reader and have them scan your truck to see if it has any codes displaying. Is the check engine light on?
     
  3. Apr 11, 2013 at 8:56 AM
    #3
    rbl1994

    rbl1994 [OP] Member

    Joined:
    Apr 10, 2013
    Member:
    #101810
    Messages:
    19
    Gender:
    Male
    Texas
    Vehicle:
    01 PreRunner, TRD, SR5, 4 dr V6
    None
    No light is on . I had them check at oriellys. No codes . What else u think it could be ?
     
  4. Apr 11, 2013 at 8:57 AM
    #4
    saundern

    saundern Swerve for nothing

    Joined:
    Dec 10, 2009
    Member:
    #27342
    Messages:
    2,682
    Gender:
    Male
    First Name:
    Nick
    Upstate, SC
    Vehicle:
    2002 SR5 4x4
    have you checked all the minor things (e.g. plugs, plug wires, cleaned TB etc.)?
     
  5. Apr 11, 2013 at 10:05 AM
    #5
    CUtacomaTIGER

    CUtacomaTIGER Unprofessional Driver

    Joined:
    Jul 23, 2011
    Member:
    #60412
    Messages:
    380
    Gender:
    Male
    Clemson
    Vehicle:
    '01 4X4 SR5 Chrome Stepside
    Black Wheels Window Rain Guards Bed Liner Tow Hitch w/4 Pin Weathertech Floor Mats Flowmaster Deck Plate Mod Window Tint Rear Diff Breather Mod Blacked out Badges
    maybe your timing is off? what rpm does it sound bad. at 138k the truck should have had belt replaced so maybe its stretched so it only causes issues at certain rpm
     
  6. Apr 11, 2013 at 10:16 AM
    #6
    Yamaha Dave

    Yamaha Dave Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34080
    Messages:
    2,662
    Gender:
    Male
    Honestly I don't think there is anything wrong with the truck. The Tacoma is geared from the factory for low end torque/power for things like towing, and off road use. I believe the truck is a 4-speed automatic, but in my opinion though they should have made it a 5 or 6 speed for fuel economy on highway commutes.
     
  7. Apr 11, 2013 at 10:21 AM
    #7
    saundern

    saundern Swerve for nothing

    Joined:
    Dec 10, 2009
    Member:
    #27342
    Messages:
    2,682
    Gender:
    Male
    First Name:
    Nick
    Upstate, SC
    Vehicle:
    2002 SR5 4x4
    x2 wish they would have added at least one more gear. I have the 4 cylinder 2.7 liter and would love to have 5 gears instead of 4. OP has a V6, do they have 4 gears also?
     
  8. Apr 11, 2013 at 10:45 AM
    #8
    rbl1994

    rbl1994 [OP] Member

    Joined:
    Apr 10, 2013
    Member:
    #101810
    Messages:
    19
    Gender:
    Male
    Texas
    Vehicle:
    01 PreRunner, TRD, SR5, 4 dr V6
    None
    Plugs wires timing was all replaced . All new but when i put the pedal all the way down it has no power and sounds like its fixing to blow
     
  9. Apr 11, 2013 at 10:53 AM
    #9
    rbl1994

    rbl1994 [OP] Member

    Joined:
    Apr 10, 2013
    Member:
    #101810
    Messages:
    19
    Gender:
    Male
    Texas
    Vehicle:
    01 PreRunner, TRD, SR5, 4 dr V6
    None
    I can't seem to find the timing belt ?
     
  10. Apr 11, 2013 at 12:44 PM
    #10
    Yamaha Dave

    Yamaha Dave Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34080
    Messages:
    2,662
    Gender:
    Male
    And underpowered high revving truck? Stills sounds like a normal everyday Tacoma lol.
     
  11. Apr 11, 2013 at 2:27 PM
    #11
    CUtacomaTIGER

    CUtacomaTIGER Unprofessional Driver

    Joined:
    Jul 23, 2011
    Member:
    #60412
    Messages:
    380
    Gender:
    Male
    Clemson
    Vehicle:
    '01 4X4 SR5 Chrome Stepside
    Black Wheels Window Rain Guards Bed Liner Tow Hitch w/4 Pin Weathertech Floor Mats Flowmaster Deck Plate Mod Window Tint Rear Diff Breather Mod Blacked out Badges
    i don't think you can see the timing belt, its covered up. but i'm a 2.7 so not 100% sure
     
  12. Apr 11, 2013 at 2:32 PM
    #12
    rbl1994

    rbl1994 [OP] Member

    Joined:
    Apr 10, 2013
    Member:
    #101810
    Messages:
    19
    Gender:
    Male
    Texas
    Vehicle:
    01 PreRunner, TRD, SR5, 4 dr V6
    None
    see I have the v6 3.4 or 3.8. I have drivin other tacomas like mine and it seems hey have more power. what ways could I get more power? programmer , exhaust etx. I want it to look good and sound good . and hopefully be able to hit 70 in less than 15 sec. thanks for the advise yall have really givin me
     
To Top