1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

04 SR5 V6 4x4 stalling at 60mph+!!! HELP!!!!!

Discussion in '1st Gen. Tacomas (1995-2004)' started by cruiser, Nov 28, 2011.

  1. Nov 28, 2011 at 5:10 PM
    #1
    cruiser

    cruiser [OP] New Member

    Joined:
    Nov 28, 2011
    Member:
    #67832
    Messages:
    2
    Gender:
    Male
    First Name:
    Myles
    mechanicsburg pa
    Vehicle:
    2004 tacoma SR5 V6 4x4 trd off road
    i no its not gas. when it stalls out, my temp gauge spikes. i always keep an eye on my temp because i used to live in florida. ill be driving down the road, temperature is normal, it doesnt spike until it stalls. when it stalls i wait a few minutes and turns over like nothing happened. i havent seen smoke, steam, nothing! so i no its not overheating. i took it to auto zone so they could read the code to me, but nothing came up. the check engine light comes on when its stalled out but it goes away when you start the truck again. it seems like it might have something to do with my exhaust because when you rev the motor its louder under the front passenger seat, as if the exhaust tubing ended right there. i know its not o2 sensors because i replaced both when i bought it. i just put on: new timing belt, pulleys (timing related), thermostat, water pump, drive belt, belt tensioners. basically that whole kit. its got 123,447miles on it. my dad and i have owned several LAND CRUISERS and its normal to this at 100,000miles.
    any help/suggestions would be greatly appreciated!
    thanks
    myles
     
  2. Nov 28, 2011 at 5:24 PM
    #2
    Alderleet

    Alderleet Ace of Spades

    Joined:
    Oct 16, 2011
    Member:
    #65324
    Messages:
    1,128
    Gender:
    Male
    First Name:
    Nick
    Salty Hell
    Vehicle:
    '00 Acc Cab TRD 4x4
    Just for shits/grins, replace your fuel filter.
     
  3. Nov 28, 2011 at 5:50 PM
    #3
    tacomacntry

    tacomacntry Joe's Auto Detail

    Joined:
    Aug 17, 2010
    Member:
    #41818
    Messages:
    314
    Gender:
    Male
    North East Florida
    Vehicle:
    Blacked out SR5 4x4
    K&N Cold air Cat back custom dual exhaust
    your check engine light will always come on when your truck shuts off...it comes on when you turn the truck to the on position...but will go off when you crank the motor. you could have an exhaust leak but that wouldnt make the truck shutoff...how recent is the tune up..spark plugs wires...
     
  4. Nov 28, 2011 at 5:52 PM
    #4
    Taco me elmo

    Taco me elmo Here, Eat some paint. Drink some Bleach.

    Joined:
    Sep 17, 2010
    Member:
    #43412
    Messages:
    4,655
    First Name:
    Tophat bobcat
    North of South, East of West
    Vehicle:
    Slow polished TuRD
    Anti theft 5-Speed
    Check the timing belt and or water pump.
     
  5. Nov 29, 2011 at 7:06 AM
    #5
    cruiser

    cruiser [OP] New Member

    Joined:
    Nov 28, 2011
    Member:
    #67832
    Messages:
    2
    Gender:
    Male
    First Name:
    Myles
    mechanicsburg pa
    Vehicle:
    2004 tacoma SR5 V6 4x4 trd off road
    i changed spark plugs when i did the timing belt kit
    about 3-4 months ago.
     
  6. Nov 29, 2011 at 7:28 AM
    #6
    KenpachiZaraki

    KenpachiZaraki Its Wicked Flow BITCHES!!

    Joined:
    May 24, 2009
    Member:
    #17581
    Messages:
    3,815
    Gender:
    Male
    First Name:
    Alex •﹏•
    Lubbock
    Vehicle:
    05 TRD OffRoad Poser ψ(`∇´)ψ
    ALL POSER- Afe Pro Dry S drop in filter, 3" AP leaf pack, Eibach w/5100's up front, 5100's rear, Fog Light Mod, ABS off mod, Dash Light MOD, Doug Thorley Long Tube Headers, Wicked Flow Bitches MAX Muffler, 4" floods, 20", 43" light bars, 265/75/16 Hankook Dynapro ATm, oil catch can, rear diff breather relocate, Custome Sliders, SOS concepts Front bumper, Demon Eye Mod, backlit TRD emblem on bumper, Morimoto D2S projectors,
    It could be them temp sensor going bad, if that thing doesn't read right, the computer would shut the truck off to prevent itself from doing more damage. It could also be crank or cam position sensor which have to do with timing and would also cause it to turn off while driving.
     
  7. Nov 29, 2011 at 5:05 PM
    #7
    MacGyvR

    MacGyvR Well-Known Member

    Joined:
    Jul 21, 2010
    Member:
    #40533
    Messages:
    241
    Gender:
    Male
    First Name:
    Tom
    Arizona
    Vehicle:
    03 Prerunner SR5 2wd
    check all of your fluids. Also, have someone rev the engine while you take a look under the truck, see if you can find exactly where that noise is coming from.

    Is the truck reving pretty high/low at any other point while you're driving? When you get around 6, how many rpms are you doing? How does the truck perform at other speeds?
     
To Top