1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

07 clutch issues

Discussion in '2nd Gen. Tacomas (2005-2015)' started by henso12, Nov 23, 2010.

  1. Nov 23, 2010 at 8:06 AM
    #1
    henso12

    henso12 [OP] Member

    Joined:
    Jul 28, 2010
    Member:
    #40899
    Messages:
    6
    Gender:
    Male
    Got an 07 6speed with 31K miles, this morning on the way to work when I would let the clutch out in 1st the truck would shake. This is my first Tacoma cought it about 3 months ago. Any body know what's going on?? I'd apreciate the help. Thanks

    Ben
     
  2. Nov 23, 2010 at 10:14 AM
    #2
    Herculean

    Herculean Active Member

    Joined:
    Sep 15, 2009
    Member:
    #22795
    Messages:
    44
    Gender:
    Male
    First Name:
    Brandon
    Vehicle:
    SoCal
    A/R Chambers, BFG KM2's, Donahoes, Fox 2.0, Sliders, flowmaster, some little stuff.
    Don't sweat it. My 05 did it and my current 07 does it. Particularly when it is cold/moist in the morning. There have many many threads on it and the consensus is that the clutch on these trucks is pretty weak. I just try to baby it a bit until it quits slipping and I haven't had any issues. Agree it is annoying though.
     
  3. Nov 23, 2010 at 2:44 PM
    #3
    henso12

    henso12 [OP] Member

    Joined:
    Jul 28, 2010
    Member:
    #40899
    Messages:
    6
    Gender:
    Male
    good news thanks
     
  4. Nov 23, 2010 at 4:28 PM
    #4
    DriverSound

    DriverSound Señor Member

    Joined:
    Mar 29, 2009
    Member:
    #15329
    Messages:
    2,484
    Gender:
    Male
    SoCal
    Vehicle:
    15 TRD-OR DCSB
    Just enough! Other vehicles: 2015 Mustang GTPP 2014 Prius 2010 4runner SR5 4x4 2009 TRD-OR AC
    Hmmm... my 09 didn't do any shake but it did seem to have a clutch lag when cold.
     
To Top