1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1995.5 Tacoma, Any problems?

Discussion in '1st Gen. Tacomas (1995-2004)' started by NJTacoV6, Jan 25, 2013.

  1. Jan 25, 2013 at 10:25 AM
    #1
    NJTacoV6

    NJTacoV6 [OP] Member

    Joined:
    Jan 25, 2013
    Member:
    #96061
    Messages:
    5
    Gender:
    Male
    NJ
    Vehicle:
    95 Tacoma
    Hi everyone, I'm looking to buy a 1995 Tacoma. It is a XtraCab 3400 Four Cam 24 V6. The truck has less than 58k miles and is in alright shape but needs some TLC. Rust is minimal on frame, just surface rust. I wanted to know if anyone had any engine problems with this motor, like head gasket, fuel pump, water pump, timing belt, etc. If so please let me know how many miles were on your truck when it happened. If there is anything that you guys recommend me looking for when viewing the truck please let me know. Thanks for the help!
     
  2. Jan 25, 2013 at 12:42 PM
    #2
    n0ms

    n0ms Well-Known Member

    Joined:
    Oct 8, 2011
    Member:
    #64844
    Messages:
    678
    Gender:
    Male
    First Name:
    Angel
    San Diego
    Vehicle:
    1st gen i4 single cab 4x4
    Celica seats, Icon in rear and front with icon ucas, omd leaf springs, deckplate mod, lce header, Tundra brake swap.
    First I will start by saying that you can find tons of post similar to your post. Just have to look around.

    Damn that truck has some low miles, if it's been sitting rubber/plastic stuff might have dry rotted.
    My truck was bought with 138k so I don't know everything that has before broken nor when. However
    radiator and hoses had been replaced, maf, and looks like a few bands. Around 142k the original starter went out. Replaced the contacts and it still works. Only real problem I have encountered was the headers cracking and leaking. Replaced with lce headers.
     
  3. Jan 25, 2013 at 1:43 PM
    #3
    Trifenix

    Trifenix Well-Known Member

    Joined:
    Jan 11, 2011
    Member:
    #49090
    Messages:
    1,231
    Gender:
    Male
    so cal
    Vehicle:
    99 Tacoma LT Prerunner
    Anything rubber related should be replaced. Swap all fluids filters and you should be good to 200k+
     
  4. Jan 25, 2013 at 4:03 PM
    #4
    Blackdawg

    Blackdawg Dr. Frankenstein

    Joined:
    Dec 31, 2010
    Member:
    #48500
    Messages:
    50,813
    Gender:
    Male
    First Name:
    Monte
    Wyoming/St. Louis
    Vehicle:
    96.5 FrankenTaco & 03 Stock dbl cab
    BFG KM2 33x12.5 tires, Wheelers Type B rims, Allpro 1.5'' Wheel spacers w/extended thread lug nuts 2 Alpine 10'' Type Xs 2 Kicker 6X9s 4 Sony 5 1/4s Pioneer 4100 HU Sway bar removed 4 Hella 500 HIDs Frankenstein Leaf packs 1'' lift shackles Eibach coils 5100s front 10'' 5150s rear BAMF BPV bracket Deckplate mod Elite Front bumper Magnaflow 14'' muffler Elite Off Road Rear bumper with Tire gate with jerry can and fold down table, BAMF sliders, Custom Homemade Bed, rack/roof rack, CVT Mt. Shasta Roof Top Tent, 20lb CO2 tank, BAMF diff skid custom front skid, GM CS144 140 amp alternator Blitzpro 21s HAWK side LEDs Blitzpro Custom made side mirror lights, LightForce 240 Blitz llights, Piaa 510 ION fogs, XRC8 Winch w/in cab controls,
    It's a Toyota. 58k is nothing.

    Flush the fluids, check the hoses and seals and bushings if its been outside.

    Do just a normal tune up..should be solid.

    100k is when the water pump might tend to go but could last as long as 180k


    Head gaskets go rarely. Or really anything else for that matter
     
  5. Jan 25, 2013 at 7:59 PM
    #5
    NJTacoV6

    NJTacoV6 [OP] Member

    Joined:
    Jan 25, 2013
    Member:
    #96061
    Messages:
    5
    Gender:
    Male
    NJ
    Vehicle:
    95 Tacoma
    Thanks guys, I hope it checks out great. I have many ideas on how I want to build up my DD/ Rig haha
     
  6. Jan 25, 2013 at 8:01 PM
    #6
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,310
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    58k is literally nothing. I have a 96 no problems and im at 145k
     
  7. Jan 25, 2013 at 11:21 PM
    #7
    RyanC

    RyanC Well-Known Member

    Joined:
    Oct 27, 2012
    Member:
    #89914
    Messages:
    118
    Gender:
    Male
    First Name:
    Ryan
    Puyallup WA
    Vehicle:
    95 Tacoma 4x4
    Lifted, 33/1250/15's, canopy.
    I have a 95.5 with the 2.7 and its got 220,000 on it... and its runs like a dream. youll be fine.
     
  8. Jan 25, 2013 at 11:23 PM
    #8
    MightyMouse-SCT

    MightyMouse-SCT Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44862
    Messages:
    15,696
    Gender:
    Male
    First Name:
    Gabriel
    O'SIDE CA
    Vehicle:
    MightyMouse-SCT - 2011 LT 4x4 Desert Runner
    Long Travel Total chaos kit, fox shocks, smp fab , dmz sua, glassworks, method wheels.
    Spedo I'm pretty sure went out at some point with that milage . Buddy had 2 1995's both spedos were broken .
     
  9. Jan 25, 2013 at 11:31 PM
    #9
    2010Tacoma4x4

    2010Tacoma4x4 "Man Ho"

    Joined:
    Jan 19, 2011
    Member:
    #49556
    Messages:
    644
    Gender:
    Male
    First Name:
    Dave
    Jacksonville, Fl
    Vehicle:
    2010 4x4 SR5
    Tinted windows, Bug deflector, Rain guards, Bed mat, Rear leaf TSB, Bilsteins front & rear (front set @ 1.75), 16x8 chrome Helo wheels, Toyo open country AT P265/75/R16 tires. CBI bolt on sliders. BSP color matched M1 Satoshi grill. BHLM. UWS low profile black powder coat crosover truckbox. Pioneer DVD/CD head unit - 4 channel amp - front mids & highs - 8" sub box.
    One word of caution before you buy the 95.5. There were some built that had problems with the head gaskets. Depending on the VIN# there was a recall for the issue. I know this because I had one.

    If I were you before making the purchase I would research the VIN# and see if it was part of the recall and if so was the repair ever done. A carfax may tell you but I would check with your local Toyota dealer.

    Other than that it's a great find with such low miles...I would jump on that if the price is right.
     
  10. Jan 25, 2013 at 11:47 PM
    #10
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    You SURE its 58K ?? Anyway is it manual or auto ?? If auto. I'd def. get it serviced just so ya know its been done, they are pricey as hell if they go out...
     
  11. Jan 26, 2013 at 4:37 AM
    #11
    NJTacoV6

    NJTacoV6 [OP] Member

    Joined:
    Jan 25, 2013
    Member:
    #96061
    Messages:
    5
    Gender:
    Male
    NJ
    Vehicle:
    95 Tacoma


    Thanks for letting me know! Yeah I'm going to Carfax. My friend has a '07 FJ Cruiser which is covered under Toyota's 2-year Warranty and he always brings it there when something goes wrong with it after he offroads with it haha. He says they keep record of everything from he's complaints, what they find, and what they replace. But, in order to find out that information, you must go to a Toyota Dealer with a vin# to find that out, carfax probably won't tell you what Toyota knows
     
  12. Jan 26, 2013 at 4:38 AM
    #12
    NJTacoV6

    NJTacoV6 [OP] Member

    Joined:
    Jan 25, 2013
    Member:
    #96061
    Messages:
    5
    Gender:
    Male
    NJ
    Vehicle:
    95 Tacoma

    Going to run a Carfax today to make sure about that miles. And it's 5-speed manual!
     
  13. Jan 26, 2013 at 7:03 AM
    #13
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    Also, I think it was the 3.0 that had the over heating/head gasket thing going on but not a 100% , you need to find that out for sure tho' thats a pretty big factor in buying it or not buying it (least thats how I'd look at it)
     
  14. May 6, 2014 at 10:10 AM
    #14
    austynstaco

    austynstaco Member

    Joined:
    Apr 16, 2014
    Member:
    #127802
    Messages:
    18
    Gender:
    Male
    Tucson Az
    Vehicle:
    95.5 Sr5 4x4
    K&N air filter glass pack muffler.
    Have had mine for 14 years 270,000 miles sat for 5 years in AZ no mechanical issues at all replaced the clutch at 260,000 ORIGINAL CLUTCH. Amazing truck only engine problem was the coil packs and spark plug wires which were all original. Only real problems were the rear main seal and other seals but that's only from sitting for 5 years with out being started. Started on first turn just by the way.
     
  15. May 6, 2014 at 10:13 AM
    #15
    austynstaco

    austynstaco Member

    Joined:
    Apr 16, 2014
    Member:
    #127802
    Messages:
    18
    Gender:
    Male
    Tucson Az
    Vehicle:
    95.5 Sr5 4x4
    K&N air filter glass pack muffler.
    Also would check the ball joints but they should be fine at that mileage.
     
  16. May 6, 2014 at 2:22 PM
    #16
    Lumpskie

    Lumpskie Independent Thinker

    Joined:
    Apr 20, 2013
    Member:
    #102450
    Messages:
    1,863
    Gender:
    Male
    Colorado
    Vehicle:
    '96, 4x4, v6, manual hub
    Toytec 16" coilovers with Tundra Bilstein 5100s, Light Racing UCAs, Alcan Leafs with Orbit Eyes, 12" Bilstein 7100 short Bodies, ARB rear locker, 33x12.5 Duratracs, CBI sliders, Bushwacker fender flares, self made front bumper, M8000, Vision X 6.7" Hi/Lo Beam HIDs, full skids, Inchworm dual case setup - 15º clocking
    I agree with Blackdawg. I have an indicated 225,000 on mine (because of the 33s I'm closer to 250k) and haven't had a problem. I replace the original water pump at 160,000 and the original clutch at 180,000 miles. The truck drives great and it's still my daily driver. I usually put 10k-12k on it a year without any issues.
     
To Top