1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1997 Manual 4x4 2.7L Troubleshooting

Discussion in '4 Cylinder' started by rlhnick, Sep 6, 2011.

  1. rlhnick

    rlhnick [OP] New Member

    Joined:
    Aug 31, 2011
    Member:
    #62691
    Messages:
    2
    Gender:
    Male
    First Name:
    Nick
    Atlanta, Ga
    Vehicle:
    97 2.7L 4x4
    Hey guys, I don't know if these problems have anything to do with each other or not, but any advise would help.

    1. My truck idles high. Instead of staying around 700 RPMs, it has been getting up to 1500 when I press the clutch, or put it into neutral.

    2. It "stutters" when I let off the gas. When I am on the interstate and going at a high rate of speed (60-70 mph), and let off of the gas, the truck acts like I'm in too low of a gear and slows down.

    3. Grinds when I put it into certain gears. When I put it to 1st, 2nd, or 3rd, there was a grinding noise when I moved the shifter into place. Sometimes it happens, and sometimes it doesn't.

    Like I said, anything would help!
    Thanks!
     
  2. slmgt

    slmgt Well-Known Member

    Joined:
    Oct 19, 2010
    Member:
    #44921
    Messages:
    661
    Gender:
    Male
    San Francisco Bay Area
    Vehicle:
    11 TRD Sport w/ JBL DCLB V6 AT
    Husky floor mats (Fr and Rr) Hose clamp securing tailgate
    Any recent modifications?

    Also, do you have the same stuttering problem when you take off as well or only at a high constant speed?
     
  3. rlhnick

    rlhnick [OP] New Member

    Joined:
    Aug 31, 2011
    Member:
    #62691
    Messages:
    2
    Gender:
    Male
    First Name:
    Nick
    Atlanta, Ga
    Vehicle:
    97 2.7L 4x4
    No, I haven't done any mods to it.

    Also, it seems that it is only when I am at a high speed.

    What do you think?
     
  4. skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,221
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    Check your throttle position sensor for smooth operation/resistance. Clean your MAF.
     
To Top