1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1998 tacoma p/u won't start after getting hot

Discussion in 'Toyota Trucks & SUVs' started by Gunboat, Sep 23, 2013.

  1. Sep 23, 2013 at 9:05 AM
    #1
    Gunboat

    Gunboat [OP] New Member

    Joined:
    Sep 23, 2013
    Member:
    #113080
    Messages:
    2
    Gender:
    Male
    First Name:
    mickey
    usa
    Vehicle:
    tacoma
    My friend has a 98 tacoms p/c 16 valve,4 cylinder 4 wheel drive.After driving it and it gets to operating temp,and he turns it off,it refuses to start back up until it cools back down...then it starts and runs fine...anyone have any suggestions on what to look for? Also,plugged in the reader to the OBD and it said that the engine was running lean,no other trouble codes came out...the engine cranks over just fine it's getting fire and fuel,new plugs..
     
    Last edited: Sep 23, 2013
  2. Oct 9, 2013 at 7:56 AM
    #2
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    1,844
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, stock gears, stock-size tires, Michelin LTX AT2, Tranny skidplate, sliders, UltraGauge, PowerTank, CB
    Plenty of suspects to check out.
    O2 sensors
    temp sensors
    fuel pressure reg
     
  3. Oct 10, 2013 at 4:16 AM
    #3
    Gunboat

    Gunboat [OP] New Member

    Joined:
    Sep 23, 2013
    Member:
    #113080
    Messages:
    2
    Gender:
    Male
    First Name:
    mickey
    usa
    Vehicle:
    tacoma
    thanks for the reply...I have read numerous posts on this and they say just about the same thing that you have mentioned,thanks again for the reply..
     
  4. Oct 31, 2013 at 1:45 PM
    #4
    Konvict KROG

    Konvict KROG Well-Known Member

    Joined:
    Aug 9, 2013
    Member:
    #110115
    Messages:
    2,453
    Gender:
    Male
    First Name:
    Landry
    North Carolina :/
    Vehicle:
    13 4x4 cab off road 6spd super white
    TRD BAJA suspension added, trd short shifter, plastiderp, fj cruiser trailteam wheels, 265/75/16 tires, 30 inch rigid industry e series, beltronics rx75 plus ultimate custom install. Scangauge 2, wheelers offroad preload pack
    fuel delivery issue, like mentioned above

    or possibly only enough fuel to run while still on cold start injector? if there was crud in the fuel system the filter does not always get it and it can still plug up your injector's
     
  5. Oct 31, 2013 at 4:27 PM
    #5
    3RZ Taco

    3RZ Taco Well-Known Member

    Joined:
    Aug 23, 2012
    Member:
    #85394
    Messages:
    613
    Gender:
    Male
    First Name:
    Austin
    Oregon
    Vehicle:
    96 3RZ Stock
    K&N air filter, Toolbox, Window Deflectors, Bug Deflector, BFGoodrich A/T's
    Try replacing the fuel cap, my 96 would run fine all day until night time and wouldnt not start unless i fulled the cap off and let the air pressure out of the tank. Searched and searched for what could be the problem, spent 15$ on a new locking gas cap and havnt had the problem since.
     
  6. Oct 31, 2013 at 6:35 PM
    #6
    92yotapu

    92yotapu Well-Known Member

    Joined:
    Feb 7, 2013
    Member:
    #97034
    Messages:
    61
    Gender:
    Male
    First Name:
    Joseph
    Ontario
    Vehicle:
    92 toyota pickup 4x4
    32in tires, blacked out rims grill and door handles
    For your issue check the vent solenoid on your evap canister it night be plugged
     
  7. Oct 31, 2013 at 6:41 PM
    #7
    92yotapu

    92yotapu Well-Known Member

    Joined:
    Feb 7, 2013
    Member:
    #97034
    Messages:
    61
    Gender:
    Male
    First Name:
    Joseph
    Ontario
    Vehicle:
    92 toyota pickup 4x4
    32in tires, blacked out rims grill and door handles
    Check fuel pressure at cold start and while running warm shouldn't be a major difference and while its running hot pull fuel cap if it hisses like is sucking in air you have a bad tank vent
     
To Top