1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2000 tacoma misfire!?!?!

Discussion in '4 Cylinder' started by 2000tacoma, Jan 17, 2010.

  1. Jan 17, 2010 at 7:09 PM
    #1
    2000tacoma

    2000tacoma [OP] New Member

    Joined:
    Jan 17, 2010
    Member:
    #29528
    Messages:
    1
    Gender:
    Male
    Vehicle:
    2000 tacoma prerunner
    hey
    ive got a 2000 tacoma and for the last few months the rpm has been going up and down while idling.ive changed the filters, done an oil change and change the spark plugs.from what the mechanic has told me is its a problem with the fuel injectors and thats not something that should be messed around with.he says that the best thing to do would be to sell it and get whatever i get.no i dont want to sell it because im the second owner and its only got 120,000km on it.i love the truck but i dont want it giving me a lot of problems though.what else could it be that i could check out and what might be some better options?
    thanks in advance
     
  2. Jan 31, 2010 at 3:12 PM
    #2
    sticky

    sticky Sticky

    Joined:
    Jan 31, 2010
    Member:
    #30414
    Messages:
    13
    Gender:
    Male
    I'm having the same problem with mine.Runs fine out on the road then at idle it idle's really low then idle's up on it's on...
     
  3. Feb 26, 2010 at 1:49 PM
    #3
    jwa1028

    jwa1028 Active Member

    Joined:
    Nov 23, 2009
    Member:
    #26391
    Messages:
    31
    Gender:
    Male
    Vehicle:
    '01 4 cyl Tacoma
    check your coil packs, i changed one and it runs fine now. does your check engine light come on?
     
  4. Feb 27, 2010 at 2:29 PM
    #4
    sticky

    sticky Sticky

    Joined:
    Jan 31, 2010
    Member:
    #30414
    Messages:
    13
    Gender:
    Male
    No my check engine light does not come on..i ran the computer on it at work and it said #2 cylinder miss fire
     
  5. Feb 27, 2010 at 3:55 PM
    #5
    jfr02

    jfr02 Well-Known Member

    Joined:
    Apr 4, 2009
    Member:
    #15567
    Messages:
    233
    Gender:
    Male
    Vehicle:
    2012 dcsb 6spd sport
    check for vacuum leaks.also why would someone say that you don't want to mess with your fuel injector's.there's not much to them unbolt the mounting bolts on the fuel rail and pull up the rail.then there is a clip that holds the injector to the fuel rail.you may have to replace the O-rings.before doing that i would try some sort of fuel system cleaner
     
  6. Jul 9, 2010 at 6:24 PM
    #6
    toyotadan

    toyotadan Member

    Joined:
    May 2, 2010
    Member:
    #36418
    Messages:
    24
    Gender:
    Male
    washington
    Vehicle:
    98 4x4
    jwa1028, when you changed the coil pack what was your motor acting like
     
  7. Jul 9, 2010 at 6:26 PM
    #7
    toyotadan

    toyotadan Member

    Joined:
    May 2, 2010
    Member:
    #36418
    Messages:
    24
    Gender:
    Male
    washington
    Vehicle:
    98 4x4
    jwa1028,when you changed your coil pack what was your motor acting like?? my truck has a misfire code for cylinder #1 and motor lopes and when i undo the plug wire there is a slight diference in the way it runs. when i unplug the #1 fuel injector there is no diference in the way it runs,when i unplug the one on #2 it really runs crapy.i put in new plugs and it didn't help.so i bought a new injector to see if that will work, i just hope im not wasting my money.
     
To Top