1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2000 tacoma tranny problems

Discussion in '1st Gen. Tacomas' started by Muttler, Dec 4, 2010.

  1. Muttler

    Muttler [OP] Member

    Joined:
    Jun 4, 2009
    Member:
    #18024
    Messages:
    6
    Gender:
    Male
    Oceanside
    Vehicle:
    PreRunner SR5 TRD
    hitch
    My 2000 tacoma prerunner 2.7L auto ext cab; had check engine light coming on often, bought OBD II code reader, indicating shift solenoid problem(s), (yes, plural), wound up replacing ALL solenoids in tranny (seals, too), torque converter and SL solenoid and switch (work done by shop). problem code is back (after deleting codes, etc) after three days. What are we missing.......???? Wiring, ECM, Gremlins....what??
     
  2. Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,684
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    I just went through just about the same thing with a 93 pickup. The problem turned out to be the ECM. We replaced the solenoids and they didn't do anything except make me 200 bucks lighter. But the ECM was only like 38 bucks at the junkyard. Works great now.
     
  3. Muttler

    Muttler [OP] Member

    Joined:
    Jun 4, 2009
    Member:
    #18024
    Messages:
    6
    Gender:
    Male
    Oceanside
    Vehicle:
    PreRunner SR5 TRD
    hitch
    Will try that:p
     
To Top