1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2001 Mercedes ML430 "start error" in odometer

Discussion in 'General Automotive' started by 07TacoRidah, Mar 21, 2010.

  1. Mar 21, 2010 at 2:38 PM
    #1
    07TacoRidah

    07TacoRidah [OP] SHHHH, this is interesting

    Joined:
    Dec 3, 2009
    Member:
    #26923
    Messages:
    2,896
    Gender:
    Male
    Pasadena CA
    Vehicle:
    2007 Base Model Access Cab
    Engine bay: aFe Pro Dry filter Secondary air filter deleted Sokie Tech hood damper kit Xscorpion dual 0g wire ring terminal (3) Big 3 upgrade (0g wiring) HID kit (headlights - 3k) Bullz Audio 0g wire Exterior: Blacked out OEM headlight housing Front grille swap (to chrome, dipped red) XR front bumper valance (dipped red) Aftermarket fog light kit w/OEM switch Rear bumper swap (to chrome) 99 Cents Store tailgate lock Suspension: 1" spindle spacer kit (Addional nuts and longer bolts added) 4x4 leaf pack swap (middle leaf removed) 1" Drop Blocks Air Lift rear helper springs Rims: 18x9.5 Asuka ST 15-2 rims et26 all around 5mm billet aluminum wheel spacers 225/40/18 tires all around Neochrome lock nuts Pepboys valve stem caps Interior: Wink Mirror rear view Center console lid fabric Metra Dash kit Pioneer DEH 5000ub Hifonics Zeus ZXi 6410 PB 6 1/2" component speakers up front 10" JBL GTO 1014 (2) 4 ohm svc in dual ported box JDM Fuchsia shift knob (old Dickies pants shift boot)
    I just put in a new battery in my dads ML 430, it cranked and almost started twice but it's like it was lacking something. It cranked and sounded like it was going to start both times, now the engine won't do anything. Everything else works fine, a/c, door locks etc. it's just the engine won't start. This is a brand new battery. I installed it like 10 minutes ago. Anyone know hoe to get this thing started?
     
  2. Mar 21, 2010 at 2:39 PM
    #2
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,104
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    pump the gas, how old is it?
     
  3. Mar 21, 2010 at 2:41 PM
    #3
    07TacoRidah

    07TacoRidah [OP] SHHHH, this is interesting

    Joined:
    Dec 3, 2009
    Member:
    #26923
    Messages:
    2,896
    Gender:
    Male
    Pasadena CA
    Vehicle:
    2007 Base Model Access Cab
    Engine bay: aFe Pro Dry filter Secondary air filter deleted Sokie Tech hood damper kit Xscorpion dual 0g wire ring terminal (3) Big 3 upgrade (0g wiring) HID kit (headlights - 3k) Bullz Audio 0g wire Exterior: Blacked out OEM headlight housing Front grille swap (to chrome, dipped red) XR front bumper valance (dipped red) Aftermarket fog light kit w/OEM switch Rear bumper swap (to chrome) 99 Cents Store tailgate lock Suspension: 1" spindle spacer kit (Addional nuts and longer bolts added) 4x4 leaf pack swap (middle leaf removed) 1" Drop Blocks Air Lift rear helper springs Rims: 18x9.5 Asuka ST 15-2 rims et26 all around 5mm billet aluminum wheel spacers 225/40/18 tires all around Neochrome lock nuts Pepboys valve stem caps Interior: Wink Mirror rear view Center console lid fabric Metra Dash kit Pioneer DEH 5000ub Hifonics Zeus ZXi 6410 PB 6 1/2" component speakers up front 10" JBL GTO 1014 (2) 4 ohm svc in dual ported box JDM Fuchsia shift knob (old Dickies pants shift boot)
    not sure when he got it, can't be too long ago, I think he's still paying it off. I'm going to try pumping the gas right now.
     
  4. Mar 21, 2010 at 2:46 PM
    #4
    07TacoRidah

    07TacoRidah [OP] SHHHH, this is interesting

    Joined:
    Dec 3, 2009
    Member:
    #26923
    Messages:
    2,896
    Gender:
    Male
    Pasadena CA
    Vehicle:
    2007 Base Model Access Cab
    Engine bay: aFe Pro Dry filter Secondary air filter deleted Sokie Tech hood damper kit Xscorpion dual 0g wire ring terminal (3) Big 3 upgrade (0g wiring) HID kit (headlights - 3k) Bullz Audio 0g wire Exterior: Blacked out OEM headlight housing Front grille swap (to chrome, dipped red) XR front bumper valance (dipped red) Aftermarket fog light kit w/OEM switch Rear bumper swap (to chrome) 99 Cents Store tailgate lock Suspension: 1" spindle spacer kit (Addional nuts and longer bolts added) 4x4 leaf pack swap (middle leaf removed) 1" Drop Blocks Air Lift rear helper springs Rims: 18x9.5 Asuka ST 15-2 rims et26 all around 5mm billet aluminum wheel spacers 225/40/18 tires all around Neochrome lock nuts Pepboys valve stem caps Interior: Wink Mirror rear view Center console lid fabric Metra Dash kit Pioneer DEH 5000ub Hifonics Zeus ZXi 6410 PB 6 1/2" component speakers up front 10" JBL GTO 1014 (2) 4 ohm svc in dual ported box JDM Fuchsia shift knob (old Dickies pants shift boot)
    YUP that did it. thanks. The engine seems to sound funny though, like something is wrong maybe internally. Have to have him bring it to the dealer for a check up bad! It starts sounding fine on start up but then when you kind of push the gas a little more, it sounds like the engine can't take it.

    Thanks again man, :cool:
     
  5. Mar 21, 2010 at 3:01 PM
    #5
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,104
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    sure, and the battery shouldnt have any effect on the rest of the engine, maybe the airfilter is dirty.
     
  6. Mar 21, 2010 at 3:05 PM
    #6
    Juggernaut

    Juggernaut Captain

    Joined:
    Sep 21, 2009
    Member:
    #23111
    Messages:
    1,403
    Gender:
    Male
    Sacramento
    Vehicle:
    10 PreRunner AC Sport Rally 5 Spd
    Tail gate hose clamp, Front Windows 50% tint, fog lights, 894 backup light mod, LED license & interior.
    or fuel filter
     
  7. Mar 21, 2010 at 3:30 PM
    #7
    07TacoRidah

    07TacoRidah [OP] SHHHH, this is interesting

    Joined:
    Dec 3, 2009
    Member:
    #26923
    Messages:
    2,896
    Gender:
    Male
    Pasadena CA
    Vehicle:
    2007 Base Model Access Cab
    Engine bay: aFe Pro Dry filter Secondary air filter deleted Sokie Tech hood damper kit Xscorpion dual 0g wire ring terminal (3) Big 3 upgrade (0g wiring) HID kit (headlights - 3k) Bullz Audio 0g wire Exterior: Blacked out OEM headlight housing Front grille swap (to chrome, dipped red) XR front bumper valance (dipped red) Aftermarket fog light kit w/OEM switch Rear bumper swap (to chrome) 99 Cents Store tailgate lock Suspension: 1" spindle spacer kit (Addional nuts and longer bolts added) 4x4 leaf pack swap (middle leaf removed) 1" Drop Blocks Air Lift rear helper springs Rims: 18x9.5 Asuka ST 15-2 rims et26 all around 5mm billet aluminum wheel spacers 225/40/18 tires all around Neochrome lock nuts Pepboys valve stem caps Interior: Wink Mirror rear view Center console lid fabric Metra Dash kit Pioneer DEH 5000ub Hifonics Zeus ZXi 6410 PB 6 1/2" component speakers up front 10" JBL GTO 1014 (2) 4 ohm svc in dual ported box JDM Fuchsia shift knob (old Dickies pants shift boot)
    hell if I'm going into that damn thing. it was a headache just changing the battery. :mad:
     
To Top