1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2002 Tacoma Codes P0440, P0441, P0446

Discussion in '1st Gen. Tacomas (1995-2004)' started by skkzhg, Oct 1, 2019.

  1. Oct 1, 2019 at 6:22 AM
    #1
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    I’m trying to resolve CEL with the P0440, P0441, and P0446 being set. My mechanic replaced the purge solenoid and I’ve replaced the charcoal canister and the gas cap to no avail.

    Backstory - it’s a prerunner, 3.4 V6, auto, with 80,000 miles. My daughter had an accident in June and hit a guardrail with the passenger side of the truck. The right front fender, right bedside, and both bumpers were replaced. The cab and passenger door were repaired. We had the entire truck repainted. Also, while in the shop we had the timing belt and water pump replaced (Toyota kit). The bed was removed from the truck to repaint it and then when we got the truck back the CEL came on. So I think it’s probably related to removing the bed. Possibly a cracked or cut line or maybe even a leaking gasket under the fuel pump.

    Any ideas? I’m thinking about removing the bed and replacing the 4 rubber hoses connected to the charcoal canister. Does anyone know the part numbers for these? I’ve searched everywhere I can think and cannot seem to locate information about these hoses. I did find a number for the hoses with the plastic connector ends but I’m not sure it’s the correct one.

    I would like to remove the bed once, replace whatever might be bad and be done with it. Should I replace the fuel pump too?

    Any help is greatly appreciated.
     
    CS_AR likes this.
  2. Oct 1, 2019 at 6:26 AM
    #2
    0xDEADBEEF

    0xDEADBEEF This statement is false.

    Joined:
    Mar 2, 2019
    Member:
    #285037
    Messages:
    5,504
    Kansas City
    Vehicle:
    2000 4WD MT Single Cab
    Rust, dents, miles, extra metal.
    Check over all the fuel tank apparatus while you've got the bed off. It's possible that the filler neck may have been damaged.
     
    skkzhg [OP] likes this.
  3. Oct 1, 2019 at 7:20 AM
    #3
    Black DOG Lila

    Black DOG Lila Well-Known Member

    Joined:
    Jun 14, 2019
    Member:
    #296344
    Messages:
    4,410
    Virginia
    Vehicle:
    2003 Tacoma SR5 2.7 5 speed 4WD
    Stock. EZ pass.Dump pass.Inspection sticker.Convict printed lic.plates.FG cap.
    The hoses no longer available are vacuum hose not fuel lines
     
    skkzhg [OP] likes this.
  4. Oct 1, 2019 at 12:09 PM
    #4
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    Anyone know the sizes?
     
  5. Oct 1, 2019 at 12:21 PM
    #5
    Black DOG Lila

    Black DOG Lila Well-Known Member

    Joined:
    Jun 14, 2019
    Member:
    #296344
    Messages:
    4,410
    Virginia
    Vehicle:
    2003 Tacoma SR5 2.7 5 speed 4WD
    Stock. EZ pass.Dump pass.Inspection sticker.Convict printed lic.plates.FG cap.
    Gen 1 is 8mm. Hose size on fuel tank is same as other end in engine compartment.
     
  6. Oct 1, 2019 at 12:34 PM
    #6
    Black DOG Lila

    Black DOG Lila Well-Known Member

    Joined:
    Jun 14, 2019
    Member:
    #296344
    Messages:
    4,410
    Virginia
    Vehicle:
    2003 Tacoma SR5 2.7 5 speed 4WD
    Stock. EZ pass.Dump pass.Inspection sticker.Convict printed lic.plates.FG cap.
    Is the seat where the gas cap O ring seals smooth and clean or pitted and dirty?
     
  7. Oct 1, 2019 at 6:13 PM
    #7
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    IDK. I’ll have to check. Thanks for the tip. I also purchased a gas cap from Advance Auto, not an OEM Toyota cap. Anyone had issues with these?
     
  8. Oct 1, 2019 at 7:41 PM
    #8
    Black DOG Lila

    Black DOG Lila Well-Known Member

    Joined:
    Jun 14, 2019
    Member:
    #296344
    Messages:
    4,410
    Virginia
    Vehicle:
    2003 Tacoma SR5 2.7 5 speed 4WD
    Stock. EZ pass.Dump pass.Inspection sticker.Convict printed lic.plates.FG cap.
    OEM ONLY WORKS
     
  9. Oct 2, 2019 at 11:06 PM
    #9
    Glamisman

    Glamisman Well-Known Member

    Joined:
    Oct 22, 2016
    Member:
    #200436
    Messages:
    2,841
    Gender:
    Male
    skkzhg [OP] likes this.
  10. Oct 15, 2019 at 12:39 PM
    #10
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    So... I was making plans to pull the bed off. I changed the oil Saturday before last and found a vacuum line off going to the VSV under the hood. I connected it. My daughter took the truck by Autozone and they cleared the codes but the CEL would not go off. She took to my mechanic a few days later and he was able to turn off the CEL.

    Now the CEL will illuminate when the truck is cold and will stay on for a few miles, maybe 7-8, and then will turn itself off.

    Any ideas??? I’ve ordered an OEM gas cap but am at a loss beyond that.
     
  11. Oct 15, 2019 at 1:56 PM
    #11
    Black DOG Lila

    Black DOG Lila Well-Known Member

    Joined:
    Jun 14, 2019
    Member:
    #296344
    Messages:
    4,410
    Virginia
    Vehicle:
    2003 Tacoma SR5 2.7 5 speed 4WD
    Stock. EZ pass.Dump pass.Inspection sticker.Convict printed lic.plates.FG cap.
    CEL will turn itself off when repairs have remidied the prob. Takes numerous drive cycles on different occasions/conditions especially EVAP codes.
     
  12. Oct 15, 2019 at 2:00 PM
    #12
    eon_blue

    eon_blue 8" third member

    Joined:
    Mar 4, 2016
    Member:
    #180213
    Messages:
    40,997
    Gender:
    Male
    First Name:
    Ryan
    Monrovia, CA
    Vehicle:
    Supercharged 2004 3.4l TRD 4x4 Tacoma XtraCab w/5 speed
    Did you get the code from AutoZone when they tried to clear it? Without knowing the code there hundreds of possibilities as to what the problem could be.

    The code will point you in the right direction of what's wrong, or at least some things to check

    If it's any of the codes listed in the original post then I'd take it back to the mechanic that worked on it before to try and resolve the issue again
     
  13. Oct 15, 2019 at 2:02 PM
    #13
    eon_blue

    eon_blue 8" third member

    Joined:
    Mar 4, 2016
    Member:
    #180213
    Messages:
    40,997
    Gender:
    Male
    First Name:
    Ryan
    Monrovia, CA
    Vehicle:
    Supercharged 2004 3.4l TRD 4x4 Tacoma XtraCab w/5 speed
    Probably something to do with that gas cap, aftermarket gas caps almost always throw codes/check engine lights on Toyotas. Gotta get an OEM one
     
    skkzhg [OP] likes this.
  14. Oct 16, 2019 at 4:15 AM
    #14
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    So you are saying the CEL coming on going off is "normal" and may (will) eventually turn itself off "IF" what I've done has remedied the problem???

    I did not because the codes P0440, P0441, P0446 were still stored from the last reading. I'm curious why the CEL did not go off when the codes were cleared.

    I'm going to replace the cap with OEM, get the codes read/cleared and go from there... Thanks for the help!
     
  15. Dec 5, 2019 at 4:05 PM
    #15
    loudboy

    loudboy Well-Known Member

    Joined:
    Oct 17, 2008
    Member:
    #10028
    Messages:
    153
    Gender:
    Male
    Portland, OR
    Vehicle:
    '04 4x4 TRD Off-Road Limited
    All-Pro lift, Addicted tube bumper, Revenge sliders, stuff and crap
    @skkzhg , did you resolve this issue? I'm having similar problems. Thanks.
     
  16. Dec 5, 2019 at 4:26 PM
    #16
    skkzhg

    skkzhg [OP] Well-Known Member

    Joined:
    Mar 30, 2016
    Member:
    #182860
    Messages:
    182
    Gender:
    Male
    First Name:
    Stephen
    North Georgia
    Vehicle:
    2015 Tacoma PreRunner TRD
    Husky WeatherBeater floor liners Toyota bed mat Trimmed mud flaps ADD Oil Catch Can Diff Breather Relocate
    Crossing my fingers that I’ve fixed it. The CEL has been off for over 2 weeks now.

    I found a cut vacuum line going to the vent on top of the tank. I had to unbolt the bed and raise it up to get to everything. You can inspect the top of the tank and hoses with a flashlight looking through the drivers rear fender well.
     
    loudboy and Black DOG Lila like this.

Products Discussed in

To Top