1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2003 4Runner V6 Check oil light problem! Need some help!

Discussion in '4Runners' started by Bamahoyt, Mar 7, 2012.

  1. Mar 7, 2012 at 6:57 AM
    #1
    Bamahoyt

    Bamahoyt [OP] Well-Known Member

    Joined:
    Apr 26, 2010
    Member:
    #36006
    Messages:
    513
    Gender:
    Male
    First Name:
    Ted
    NorCal
    Vehicle:
    2001 TRD 4x4 Xtra Cab
    -Camper top
    I drove on a 600 mile round trip to oklahoma this weekend but on the way there I passed a guy and then as I was slowing back down from passing him my check oil light came on. I pulled over and then checked my oil and the level was perfect. I turned my T4R back on and... no check oil light so I headed on my way. About 25miles down the road I came to a town and the speed limit went from 65 to 35 and as I was slowing down, my check oil light came on again. I pulled over and checked once again and it was still good. I proceeded to buy a quart of oil and I put 1/2 a quart in and started it back up and.. no oil light. I went the next 300 miles and no check oil light and it was fine. My truck sat for 3 days then I came home and I never saw the light come on again until about 30 miles from home when I passed a guy and started slowing down again and my light came on again and my oil was still good. It stayed on the rest of my way home and when I pulled in the drive way I heard a slight knock so I shut it down right away and I started it back up and my oil light was off and no knocking at all. What the heck is going on? My first guess would be my oil pump going bad but I really have no clue. Any help would be awesome because I don't want to put one more mile on it and risk damaging something. My T4R is an 2003 limited with 113k miles with the V6 if that helps any. Thank you for your help!
     
  2. Mar 8, 2012 at 7:09 PM
    #2
    05RedTaco

    05RedTaco Nom Nom Nom

    Joined:
    Sep 20, 2010
    Member:
    #43521
    Messages:
    1,658
    Gender:
    Male
    First Name:
    Tony
    Phoenix
    Vehicle:
    2005 Tacoma 4.0L Acces Cab PreRunner
    Shortened antenna, ebay Intake, JBA long tube headers, 2nd set of cats cut out and straight piped, 14" Magnaflow muffler dumped before axle, relocated rear diff breather, Avid off road front bumper. Bilstein 5100's front and rear, OME 885x coils, Light Racing UCA's, 2" Toytec AAL, Hella 700ff lights, Falken Rocky Mountain AT/S 265/75/16 Load E 10ply, Blu Logic handsfree
    oil pump!!!

    DO NOT drive it until you replace it.
     
  3. Mar 8, 2012 at 7:27 PM
    #3
    lotsoftoys

    lotsoftoys pavement is boring....

    Joined:
    Apr 22, 2010
    Member:
    #35790
    Messages:
    6,790
    Gender:
    Male
    First Name:
    Jace
    Denver
    Vehicle:
    98 lifted panda taco
    bunch of crap
    u need to put anoil pdessure gauge on it......
     
To Top