1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2004 Tacoma - Inside Light upgrade??

Discussion in '1st Gen. Tacomas (1995-2004)' started by My_2004_Toy, Mar 10, 2016.

  1. Mar 10, 2016 at 7:26 AM
    #1
    My_2004_Toy

    My_2004_Toy [OP] New Member

    Joined:
    Mar 10, 2016
    Member:
    #180816
    Messages:
    4
    Gender:
    Male
    First Name:
    Brian
    Vehicle:
    2004 Toyota Tacoma
    Hello everyone - first time post - just bought a 2004 Tacoma (picts to come) and doing lots of mods - I went to upgrade the interior lights (map and dome) with lights from Superbright LED site - installed them (like i have with all my other cars/trucks) - HOWEVER, they do not come on bright unless the car is on - this defeats the purpose, especially for the dome light. Has anyone run into this before? Do I need to order specific type of bulb that will work? Do I have to change a fuse or add something else? When I put the dome light bulb in, (DE3175) - it just flickers with a low light - turned it around, and everything. Even went to auto store and bought different ones, same thing. The only way this comes on bright is with the original incandescent light that sucks. PLEASE help! Not getting anywhere and fast at that! Thanks all - glad I found you guys!!!
     
  2. Mar 10, 2016 at 7:50 AM
    #2
    jrallan26

    jrallan26 Well-Known Member

    Joined:
    Sep 10, 2006
    Member:
    #32
    Messages:
    1,207
    Gender:
    Male
    Iowa
    Vehicle:
    2004 White D-Cab TRD
    i converted my interior to LED (domelight, map light). I get all of my LEDs through a member on this board. Contact csjumper for your LED needs. He will take care of you.
     
  3. Mar 10, 2016 at 7:50 AM
    #3
    jrallan26

    jrallan26 Well-Known Member

    Joined:
    Sep 10, 2006
    Member:
    #32
    Messages:
    1,207
    Gender:
    Male
    Iowa
    Vehicle:
    2004 White D-Cab TRD
    csjumper2003
     
  4. Mar 10, 2016 at 7:52 AM
    #4
    My_2004_Toy

    My_2004_Toy [OP] New Member

    Joined:
    Mar 10, 2016
    Member:
    #180816
    Messages:
    4
    Gender:
    Male
    First Name:
    Brian
    Vehicle:
    2004 Toyota Tacoma
    Kind of a newbie here - how do I get hold of him? does he have a website? did you experience the same thing I did with the dome and map - only working if the truck is on?
     
  5. Mar 10, 2016 at 7:53 AM
    #5
    AdeptFox

    AdeptFox Active Member

    Joined:
    Aug 3, 2015
    Member:
    #160933
    Messages:
    35
    Gender:
    Male
    First Name:
    Jake
    Vermont
    Vehicle:
    2015 Access Cab 4x4
    What I did to fix this was solder in some 1 watt 100 ohm resistors. 1 for each map light and 2 for the dome light.
     
  6. Mar 10, 2016 at 7:55 AM
    #6
    My_2004_Toy

    My_2004_Toy [OP] New Member

    Joined:
    Mar 10, 2016
    Member:
    #180816
    Messages:
    4
    Gender:
    Male
    First Name:
    Brian
    Vehicle:
    2004 Toyota Tacoma
    is there anything like that I can buy as is?
     
  7. Mar 10, 2016 at 7:57 AM
    #7
    jrallan26

    jrallan26 Well-Known Member

    Joined:
    Sep 10, 2006
    Member:
    #32
    Messages:
    1,207
    Gender:
    Male
    Iowa
    Vehicle:
    2004 White D-Cab TRD
    Send csjumper2003 a private message. Tell him what you want.
     
  8. Mar 10, 2016 at 7:58 AM
    #8
    -Razr-

    -Razr- Active Member

    Joined:
    Jan 14, 2016
    Member:
    #174981
    Messages:
    29
    Gender:
    Male
    First Name:
    CJ
    Vehicle:
    '03 DC Prerunner
    Csjumper2003 has what you need. His lights worked for my 03. I had the same problem you did. He has a thread on here somewhere.
     
    jrallan26 likes this.
  9. Mar 10, 2016 at 7:59 AM
    #9
    -Razr-

    -Razr- Active Member

    Joined:
    Jan 14, 2016
    Member:
    #174981
    Messages:
    29
    Gender:
    Male
    First Name:
    CJ
    Vehicle:
    '03 DC Prerunner
  10. Mar 10, 2016 at 8:14 AM
    #10
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    3,807
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, Tundra brake swap, Michelin LTX AT2, Tranny skidplate, TC skidplate, CBI rear bumper, TG sliders, UltraGauge, PowerTank, Reverse Camera
    I used this part for mine dome/map lights, no issues:
    Superbrightleds part# 3022-NW4 natural white light
     
  11. Mar 10, 2016 at 8:20 AM
    #11
    frizzman

    frizzman Well-Known Member

    Joined:
    Sep 25, 2013
    Member:
    #113212
    Messages:
    5,323
    Gender:
    Male
    Pittsburgh, PA
    Vehicle:
    04 XCab 4x4 TRD/OR
    OME 2.5,Tundra 17s,Falken Wildpeak AT3W hitch w/ 7-pin, ARE cap, JVC HU w/BT, HID/LED lights
    @My_2004_Toy

    first, welcome to TW!

    second, (and i have to play the ass here, sorry) search is your friend, countless threads and probably within the first two pages on the 1st Gen forums.

    the 01-04 require resistors to make LEDs work in the map/dome lights. If you turn the key to "on" they will work or like you saw the incandescent will pull enough juice to power the rest.
     
  12. Mar 10, 2016 at 8:26 AM
    #12
    My_2004_Toy

    My_2004_Toy [OP] New Member

    Joined:
    Mar 10, 2016
    Member:
    #180816
    Messages:
    4
    Gender:
    Male
    First Name:
    Brian
    Vehicle:
    2004 Toyota Tacoma

    I understand the search - but with so many threads - it was hard to look and find. I sent a message to Jumper and see if he has them already with the resistors... if not him - do you know where I can get them as is? and don't worry - no hard feelings... ;-)
     
  13. Mar 10, 2016 at 8:51 AM
    #13
    frizzman

    frizzman Well-Known Member

    Joined:
    Sep 25, 2013
    Member:
    #113212
    Messages:
    5,323
    Gender:
    Male
    Pittsburgh, PA
    Vehicle:
    04 XCab 4x4 TRD/OR
    OME 2.5,Tundra 17s,Falken Wildpeak AT3W hitch w/ 7-pin, ARE cap, JVC HU w/BT, HID/LED lights
    sometimes the search can be finicky but make sure to choose the advanced and only the 1st Gen forum, "keywords", etc and it will help narrow down. you may still have to do some reading but that's the best thing so you don't jump right in and empty the wallet too fast :)

    and for some reason the '00 and lower got lucky and the LEDS just work no mods necessary, not sure what they changed in the '01 to make this not work :notsure:

    I have two LED in my dome/map but rarely use them anyway
     
  14. Mar 10, 2016 at 5:14 PM
    #14
    BenCO

    BenCO Well-Known Member

    Joined:
    Dec 9, 2011
    Member:
    #68474
    Messages:
    160
    Gender:
    Male
    CO
    Vehicle:
    04 Tacoma DC 4x4
    [QUOTE="frizzman, post: 12004978, member: 113212]

    and for some reason the '00 and lower got lucky and the LEDS just work no mods necessary, not sure what they changed in the '01 to make this not work :notsure:
    [/QUOTE]

    It's because for 01 and up the dome light dims down about 10 seconds after the door is shut. Somehow that reads the resistance this way. If your dome light is on or set to door and the door open, the map lights with shine full bright until it dims off and no longer reads that resistance.

    With the resisters in place I believe they will also run hot and potentially melt I've seen others post. I also believe adding the resisters negates the power savings from using LED. So it really is just a color tone you're upgrading.

    I'm sure I'm not using the correct terms here, but this is what I found and saw posted from csujumper in the past.
     

Products Discussed in

To Top