1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2006 Tacoma compass repair

Discussion in 'New Members' started by bugdiver, Jul 7, 2009.

  1. Jul 7, 2009 at 3:31 PM
    #1
    bugdiver

    bugdiver [OP] New Member

    Joined:
    Jul 6, 2009
    Member:
    #19335
    Messages:
    1
    Gender:
    Male
    Arizona
    Vehicle:
    06 Tacoma 4x4
    AFE CAD intake
    I read on this forum about correcting a broken solder joint on one of the 510 caps on the overhead console PCBA. That was exactly my problem. Compass and temp gauge now working fine. Thank you all very very much.
    My check engine light came on for about 5 miles after the repair but went out on it's own. May only be coincidence.
     
  2. Jul 7, 2009 at 3:47 PM
    #2
    Bearskill

    Bearskill Well-Known Member

    Joined:
    Sep 7, 2008
    Member:
    #9064
    Messages:
    793
    Gender:
    Male
    Sac
    Vehicle:
    06 Access cab PreRunner Sport
    FlowMaster 40 duals out the back, T-Rex grill, Color matched TRD Nerf bars, Icon coilovers set at 2'', 2.75" OME Dakars spring packs, OME Nitro-Charger extended rear shocks, Carrier bearing drop kit, Wheeler's Extended break Lines, Total Chaos UCAs, Mojave Teflons and 31 1/2" Toyo Open Country A/Ts, Pioneer single din unit, Yakima roof rack, Malone roof basket with X2 KC 130w long range Slimmlights mounted to it, Garmin 255w nav, Fire bottle mod, Air Force standard First Aid kit mod, Hidden Muchette mod (don't ask), and 1 huge OCD about my truck.
    Ya, I did the same fix! Works great! Who ever had the balls to tear the board apart and found the 510s is a bad ass!
     
  3. Nov 13, 2009 at 1:08 PM
    #3
    coolreed

    coolreed Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22501
    Messages:
    207
    Gender:
    Male
    OKC
    Vehicle:
    06 PreRunner TRD Off Road
    20's, Chrome Grill,Handles,Mirrors. Sat Radio, Dynomax Exhaust K&N Air Filter, Bilstein 5100's, Cross Drilled Slotted Rotors
    Secret Squirrel! You da man!

    Great Posy and Easy Fix.

    Thank You So Much.:)
     
  4. Nov 13, 2009 at 1:10 PM
    #4
    ColtsTRD

    ColtsTRD .....

    Joined:
    May 13, 2009
    Member:
    #17177
    Messages:
    17,838
    Gender:
    Male
    First Name:
    Scott
    AZ
    Vehicle:
    2005 TRD DCSB
    x2 lol I'd rather pay 20 bucks than 900 lol :D
     
  5. Nov 14, 2009 at 7:16 PM
    #5
    neslerrah

    neslerrah Who needs 4WD?

    Joined:
    Feb 18, 2008
    Member:
    #4803
    Messages:
    6,723
    Gender:
    Male
    First Name:
    Harrelsen
    Tucson
    Vehicle:
    5 lug BEAST!
    Secondary air filter removed, elbow mod, BFG KM2 (33x10.5R15), American Racing Mojaves, Debadged, BHLM, Dome Light MOD (Blue), Hella 500 behind recessed Satoshi Grille, Kenwood headunit, Sockmonkey 'TACOMA' Decals, Readylift 5-lug SST, Rear Shocks - Bilstein TRD, Dynomax Super Turbo #17748, DDM Slim Ballast HID Kit H4 Hi/Lo -35W 6000K in headlights, Apexcone Raptor HID Kit H3 - 35W 6000K in Hella 500s, aFe CAI #51-10762, WeatherTech Floorliner, 200W Smart AC Inverter
    Welcome to TW.
     
To Top