1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2009 Factory radio problems....

Discussion in 'Audio & Video' started by Robocop, Apr 26, 2009.

  1. Robocop

    Robocop [OP] Well-Known Member

    Joined:
    Apr 2, 2009
    Member:
    #15485
    Messages:
    199
    Gender:
    Male
    Alabama
    Vehicle:
    09 4x4 Access Cab Gray Manual
    I searched several old threads and found many had similiar issues with their 07 and 08 models and a few who had problems with their 09 models as well. My factory JBL system (with that horrible ugly sub box) is giving me fits. I have noticed the panel lights shut off at random, volume controls are sketchy, and the FM reception is horrible most of the time.

    The ugly sub box can be turned on and off with a little switch on the box and when it is off it sounds a little better however still is not very good. When the sub is powered on I have to back the bass controls way down to avoid horrible distortion and can not find a sweet spot on the settings to actually enjoy listening to any station.

    From what I read in old threads Toyota is well aware of issues and I found many members had to wait months for a replacement due to back orders. I have not seen any recent threads on this and wonder if anyone can tell me the status on repairs currently or maybe even if the actual source of the problem has been found.

    I know nothing of stereo components nor how it all works however I do know that for a 28k vehicle the stereo system is simply crap. I am visiting the dealer this week and hope they may be able to resolve this for me.

    My question is will simply replacing the stereo solve the issues or is the problem somewhere in the sub or factory amp? I read old threads where some had better results by simply swapping out with a second factory unit however for some this did not help. Others got better results by changing the amp so I am a little confused. I would hate to wait months for a replacement head unit only to find they replaced a defective unit with the same defective unit.

    So has anyone here actually resolved the problem on a 2009 model while using factory parts and if so what did they actually replace? Did the dealer give you a hard time or was it a simple process involving a known defect?
     
  2. Robocop

    Robocop [OP] Well-Known Member

    Joined:
    Apr 2, 2009
    Member:
    #15485
    Messages:
    199
    Gender:
    Male
    Alabama
    Vehicle:
    09 4x4 Access Cab Gray Manual
    I read further and found some thought the problem was with the receiver while others found the factory amp to be the issue. Is there any way I can check myself and see which of the two components is acting up? With one of my symptoms being the dash lights going out at random it seems as if one of my problems is a ground or short of some type.

    I am considering buying an aftermarket stereo however know zero of whats available. If I do decide to go with a different receiver could I use the factory amp and simply plug and play a new unit? I assume if the problem is with the factory amp this would not be an option anyway....maybe the trip to the dealer will help me know exactly where the problem is.
     
  3. Johnny Kanuck

    Johnny Kanuck Canadian Tacoma

    Joined:
    May 30, 2010
    Member:
    #38075
    Messages:
    6
    Gender:
    Male
    First Name:
    Johnny
    British Columbia, Canada
    Vehicle:
    09 2.7 liter (white)
    I don't know if it's the same in the states, as in Canada, but I'm on my third radio, and still having the same problems. I found that when the stereo f*#ks up, I wack it about an inch above the CD slot. It seems to work for now. I'm considering having a custom unit installed. I love my toyota more than anything, but it's becoming annoying. My wife drives a 2005 Matrix, and apparently has the same problem with hers.
     
  4. Robocop

    Robocop [OP] Well-Known Member

    Joined:
    Apr 2, 2009
    Member:
    #15485
    Messages:
    199
    Gender:
    Male
    Alabama
    Vehicle:
    09 4x4 Access Cab Gray Manual
    I must say that my number one complaint from my new Tacoma is this simply horrible stereo system. It crackles and pops and the factory sub box is useless. I am now also on my 3rd stereo relaced by the factory and was told this latest replacement is something called the "gold line" version.

    The dealer said they had so many problems Toyota decided to replace all the future warranty issues with their higher class systems. Not sure if it was a scam or what however this newest replacement has been working just fine.....well as far as the buttons actually working but it still has crappy reception.

    The first chance I get I plan to remove that weird sub box and just go to a local shop and tell them to change it ALL out for something new.
     
  5. mtmtx

    mtmtx Member

    Joined:
    Oct 25, 2009
    Member:
    #24879
    Messages:
    12
    Gender:
    Male
    Austin, TX
    Vehicle:
    PreRunner Sport...in progress
    factory ipod, factory Borla intake and exhaust, factory bluetooth, JBL w/sub, infinity kappa 6x9's in the front, 6.5's in the back, AAL TSB, hard-wired radar
    @ Kanuck...I can't believe a brogan adjustment actually works...thanks for the tip!
     
  6. Johns Taco

    Johns Taco I'm not 4x4, and have an open diff. So i'm 4x1

    Joined:
    Dec 6, 2010
    Member:
    #47253
    Messages:
    2,097
    Gender:
    Male
    First Name:
    John
    Albuquerque, NM
    Vehicle:
    05 DSM Base SR5 Slug Taco
    Full custom stereo, onboard air compressor, train horns, spacer lift, 30" tires, optima yellow top, rear slider window & tailgate anti-theft mod, pop & lock, class 3 tow hitch, lights in bed, Ultra Gauge, Weather Tech mats, yellow fog lights, camper top, air lift rear airbags, rear diff breather mod, soon to be more...
    An aftermaket stereo was my first mod, people spend so much time in there cars it only makes sense to have a really good sounding radio.
     
  7. fbconvert

    fbconvert It works if you work it.

    Joined:
    Apr 25, 2011
    Member:
    #55535
    Messages:
    358
    Gender:
    Male
    First Name:
    Brian
    Portland, OR
    Vehicle:
    2005 Tacoma Double Cab TRD Sport
    Bought as a wrecked vehicle almost done repairing it. It is my daily driver
    Here is another thread you might find interesting. This guy had an issue with with his amp causing popping and cracking sounds. I think Toyota eventually replaced it for him. A few others with the same issue got theirs replaced also. In 2009 toyota updated the amp and apparently it was pretty bad. I think they have a new one now but it has the same part number.
     
To Top