1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2009 Stalling after start

Discussion in '2nd Gen. Tacomas' started by Eternal24k, Apr 20, 2013.

  1. Apr 20, 2013 at 1:05 PM
    #1
    Eternal24k

    Eternal24k [OP] Well-Known Member

    Joined:
    Jan 27, 2012
    Member:
    #71567
    Messages:
    193
    Gender:
    Male
    Vermont
    Vehicle:
    2009 SR5 V6 4x4
    I have a 2009 SR5 with 45k miles that just started acting up on me yesterday. It stalled several times on me in the morning, I would turn it over, it would fire right up, and then it would just die. This happened 3 times in the morning and then about 9 times in the afternoon. Ultimately I would leave the key on for a few seconds before starting and that seemed to have helped. I also plugged in a diagnostic tool and it was not flashing any codes.


    It is spring here and warming up, not sure why it made it all winter without any issues, seems to be computer related though. It almost feels like the fuel pump just stops after it starts.
    Today I disconnected the battery to reset and see if that would help and it did it again immediately after, once, and I did the turn key on and wait right after.

    Any ideas? Any TSBs for such a problem? It is certified, but i know it probably won't do it at the dealership :facepalm:
     
  2. Apr 20, 2013 at 1:10 PM
    #2
    blakes09

    blakes09 Toyota Tech..when im not Fishing

    Joined:
    Apr 18, 2012
    Member:
    #77164
    Messages:
    822
    Gender:
    Male
    First Name:
    Blake
    Deep South
    Vehicle:
    4x4
    search....2009 Taco won't start, no codes, cranks
     
  3. Apr 20, 2013 at 1:41 PM
    #3
    Eternal24k

    Eternal24k [OP] Well-Known Member

    Joined:
    Jan 27, 2012
    Member:
    #71567
    Messages:
    193
    Gender:
    Male
    Vermont
    Vehicle:
    2009 SR5 V6 4x4
    awesome,
    Well, maybe I should call my dealership and tell them I need a new Transponder Key ECU assembly
     
To Top