1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2009 taco problems

Discussion in '2nd Gen. Tacomas (2005-2015)' started by timbo805, May 2, 2009.

  1. May 2, 2009 at 11:53 AM
    #1
    timbo805

    timbo805 [OP] Well-Known Member

    Joined:
    Mar 8, 2009
    Member:
    #14483
    Messages:
    355
    Gender:
    Male
    SanDiego
    Vehicle:
    09 tacoma trd sport pre-runner
    hey buds im going to take my truck to the dealer on friday would like to know what problem you 2000niners are having so far so i can tell them to start changing some stuff already my stereo is failing (volume and lights go out) my transmission is geting kind of jumpy any thing else???? to bring it up during my trip to the dealer any tsb ???or what ever there called
     
  2. May 2, 2009 at 1:55 PM
    #2
    Okkine

    Okkine Well-Known Member

    Joined:
    Jun 26, 2008
    Member:
    #7590
    Messages:
    771
    Gender:
    Male
    Vancouver, BC
    Vehicle:
    2009 Magnetic Grey Access Cab - 2.7L I4 - 4x2
    Radio problems... The volume issue, and it sometimes jumps frequencies at random. And sometimes the passenger door won't lock/unlock (unless I do it manually). All minor things to me. Other than that, I have no complaints.
     
  3. May 2, 2009 at 7:28 PM
    #3
    timbo805

    timbo805 [OP] Well-Known Member

    Joined:
    Mar 8, 2009
    Member:
    #14483
    Messages:
    355
    Gender:
    Male
    SanDiego
    Vehicle:
    09 tacoma trd sport pre-runner
    anything else?? anyone
     
  4. Jun 7, 2009 at 6:38 AM
    #4
    64Wildcat

    64Wildcat Ancient or so i'm told

    Joined:
    May 17, 2009
    Member:
    #17334
    Messages:
    2,544
    Gender:
    Male
    First Name:
    Denis
    New Hampshire
    Vehicle:
    2010 Tundra Off Road
    I have 2009 dble cab 4 x 4 long bed SR5 that I've had for 3 weeks and have the same issue with the stereo, I showed the service manager what was happening and they ordered me a new stereo.
    I'm going to ask them about the rear end tsb and see what happens.

    Denis
     
  5. Jun 7, 2009 at 7:18 AM
    #5
    EricT

    EricT Well-Known Member

    Joined:
    Jun 1, 2009
    Member:
    #17887
    Messages:
    516
    Gender:
    Male
    Arizona
    Vehicle:
    '09 4x4 shortbed TRD Sport
    You guys seeing that with the upgraded jbl stereo, or the basic one?
     
  6. Jun 7, 2009 at 7:47 AM
    #6
    epa4wd

    epa4wd Well-Known Member

    Joined:
    Mar 17, 2009
    Member:
    #14828
    Messages:
    2,139
    Gender:
    Male
    First Name:
    Eduardo
    Vehicle:
    2015 TRD Sport
    Clazzio Seat Covers Extang Tri-Fold Soft Tonneau Cover TRD Skid Plate AMP Research Electric Steps 43% Llumar Security tint TRD Exhaust Fox 2.0 coilovers and rear shocks 16" TRD Fake Beadlocks Custom LED Cube mounts in foglight location TRD Pro Grill Wheelers progressive aal
    I have the basic one with the issues. I'm going to the dealer next week.
     
  7. Jun 7, 2009 at 7:52 AM
    #7
    64Wildcat

    64Wildcat Ancient or so i'm told

    Joined:
    May 17, 2009
    Member:
    #17334
    Messages:
    2,544
    Gender:
    Male
    First Name:
    Denis
    New Hampshire
    Vehicle:
    2010 Tundra Off Road
  8. Jun 7, 2009 at 8:16 AM
    #8
    Edrin55

    Edrin55 Well-Known Member

    Joined:
    Apr 11, 2009
    Member:
    #15858
    Messages:
    944
    Gender:
    Male
    First Name:
    Ron
    San Diego, CA (Scripps Ranch)
    Vehicle:
    2010 Magnetic Gray TRD Sport Access Cab
    Avid Off Road Light Bar Line-X'd, Black Sand Pearl Hood Scoope, Truck Covers USA metal roll up bed cover, Thule Custom lockable light bar, TRD Sport Exhaust, Line-X'd TRD skid plate, Slee Off Road Sliders, Upgraded 3.5" Rearview Mirror/Monitor, Anytime Foglight Mod. (TY Jeff), Smoked Foglights, SilverStar Headlight & Foglight Bulbs, Tinted windows all around, Vent visors, Bed mat with security mod, Wet Okoles front & back, Race/Sport Pedals, Tailgate Clamps, PopNLcok 5300 Tailgate Lock, All weather mats, Helo 17x8 Hubcentric Rims & BFG All Terrain 265/70/17, Blisteins 5100's all around with mini leaf add to the rears, AFE Pro Dry drop in filter, Go Rhino Hitch Step, TRD License Plate Frames and Tire Valve Covers. GrillCraft MX Mesh upper and lower grills with "old school TOYOTA" FJ emblem, Cobra CB Radio, Firestick CB Antenna with custom mount.
    I have the basic one as well. I started having radio issues about a month after I drove it off the lot. One day after work the radio started acting up. I drove it straight to the dealer without touching the radio. Dealer witnessed the problem and ordered me a new one. Only draw back was that it was a 6 week back order on the radio. I actually have an appointment tomorrow to get the new one installed.

    For those of you having radio issues take it in now. Toyota is well aware of the problems with the radios now. There is another thread on here also about radios.
     
  9. Jun 7, 2009 at 8:42 AM
    #9
    Hollywood22

    Hollywood22 Wranglin the Badger

    Joined:
    May 24, 2009
    Member:
    #17575
    Messages:
    613
    Gender:
    Male
    First Name:
    Johnny
    Southern Ontario
    Vehicle:
    Generation X
    OME Lift, LR UCA's
    I've got an 09 on order. I take it you have an automatic....anyone having problems with stick....thanks for the info regarding the radio...something to look out for....cheers.
     
  10. Jun 7, 2009 at 8:44 AM
    #10
    JeffRock

    JeffRock Well-Known Member

    Joined:
    Mar 18, 2009
    Member:
    #14910
    Messages:
    1,198
    Gender:
    Male
    Capital region, NY
    Vehicle:
    09 Tacoma accesscab 4x4 SR5 2.7L
    Toyota all weather floor mats. Mag light that clunks around in the jack compartment. Dog hair. Dog drool on the windows.
    I have had no problems with the manual tranny.
     
  11. Jun 7, 2009 at 8:49 AM
    #11
    Hollywood22

    Hollywood22 Wranglin the Badger

    Joined:
    May 24, 2009
    Member:
    #17575
    Messages:
    613
    Gender:
    Male
    First Name:
    Johnny
    Southern Ontario
    Vehicle:
    Generation X
    OME Lift, LR UCA's
    thanks man was worried there for a sec...i think i read that in a recent thread that the standard has a solid transmission...but had to ask...hopefully toyota is taking care of these guys with their problems...thanks agian
     
  12. Jun 7, 2009 at 9:02 AM
    #12
    fletch aka

    fletch aka www.BeLikeBrit.org

    Joined:
    Jan 4, 2009
    Member:
    #12223
    Messages:
    7,103
    Gender:
    Male
    First Name:
    Gary
    Left Coast
    Vehicle:
    09 Magnetic Gray TRD OffRoad
    TRD cat back exhaust, TRD Cold Air Intake, differential breather mod' Hellwig rear sway bar, 16x8 TRD Ivan Stewart's, Michelin LTX A/T2, DTRL Stealth Mode Mod, custom "Texas Edition" shift knob, Sock's "Classic" bedside decals, MetalMiller custom grill emblem, 20% front tinted windows, tinted taillights, Viper alarm, ScanGauge II, Flyzeye Designs V2W Tacoma Interior LED lighting, de-mud flapped, de-badged, extra D-rings under bed bolts, WeatherTech ED floor mats, G4 Elite Fold a Cover ,Toyota bed mat, tailgate theft deterrent device and absolutely no plasti-dip!
    My only stereo problem is the factory boom box sucks. I have read a few post with the same problem, makes a very strange sound, really notice when I use my iPod with it. I would love to pull the plug on the boom box if I could find it.

    The V6 tick use to drive me crazy, now I don't notice it so much anymore.

    Mine has stalled a dozen times or so at start up after it has sat for a while, starts right up afterward. Have never been able to predict it. :notsure:
     
  13. Jun 7, 2009 at 10:26 AM
    #13
    JDCPA

    JDCPA Well-Known Member

    Joined:
    Nov 15, 2008
    Member:
    #10777
    Messages:
    936
    Gender:
    Male
    First Name:
    Jim
    SW FL
    Vehicle:
    09 5 Lug Access Cab SR5
    Curt Hitch and etrailer.com wiring harness.
    I'm a bass player and could not put up with the way it sounded when I bought my '09. As it comes from the factory the subwoofer is very muddy and indistinct. Use the bass tone control and back off the bass to -2 or -3 and it sounds much, much better.
     
  14. Jun 7, 2009 at 11:15 AM
    #14
    mgrande

    mgrande iKill

    Joined:
    Apr 11, 2009
    Member:
    #15830
    Messages:
    5,357
    Gender:
    Male
    Orlando
    Vehicle:
    2011 TRD off road
    Kings, AP 3" leaf pack, timbrens front and rear, TC UCA's, pro comp 7189's, baja ATZ's, CBI sliders and rear, relentless front, dynomax catback
    I've noticed my trans seems alittle "jumpy" when I'm in stop and go traffic, think it's when going from first to second gear. Would this be worh taking it in for or is it fairly normal?
     
  15. Jun 17, 2009 at 7:37 AM
    #15
    BX1018

    BX1018 Member

    Joined:
    Jun 2, 2009
    Member:
    #17927
    Messages:
    15
    Gender:
    Male
    North Carolina
    Vehicle:
    09 Regular Cab
    If you feel it's a problem, absolutely take it in. Never know when a small issue will creep into a big one. If you're not satisfied, call Toyota and they'll get in contact with your dealership.
     
  16. Jun 17, 2009 at 12:37 PM
    #16
    techgeekwill

    techgeekwill Captain Funk

    Joined:
    Apr 2, 2009
    Member:
    #15497
    Messages:
    200
    Gender:
    Male
    Spring, TX
    Vehicle:
    09 Tiberland Mica DC LB
    I'm trying to go this afternoon. Here's the list


    Radio - Display will freak out, buttons on radio go dead. Hit to the dash seems to fix it.

    Brakes - Feel like they are warped stopping from 30-40MPH, no problem in Neutral.

    Transmission - I am now starting to notice a lag.

    Tires - Indentations in the sidewall, need balancing, see if I can get a replacement since they should still be under warranty.

    Drivers Door Tweeter Rattles.

    And I'm ready for the first oil change.



    I'll see what happens. I've had good luck at this dealer getting a TSB Taken care of for my wife's xB.
     
  17. Jun 17, 2009 at 12:59 PM
    #17
    rutherk1

    rutherk1 ElPhantasmo&TheChickenRunBlastarama

    Joined:
    Feb 26, 2008
    Member:
    #4966
    Messages:
    814
    Gender:
    Male
    Vehicle:
    09 Silver TRD 4door
    radio problem too. Dealer replacing... 9 week backorder. Go toyota.
     
  18. Jun 17, 2009 at 1:05 PM
    #18
    white91formula

    white91formula Well-Known Member

    Joined:
    Jan 25, 2009
    Member:
    #12973
    Messages:
    601
    Gender:
    Male
    Boston, MA
    Vehicle:
    05 6speed TRD OR
  19. Jun 17, 2009 at 1:36 PM
    #19
    40204ever

    40204ever Well-Known Member

    Joined:
    Nov 18, 2008
    Member:
    #10853
    Messages:
    398
    Gender:
    Male
    Caldwell, TX
    Vehicle:
    4x4 taco racing development
    I have 21,000 miles on my 09 double cab 4x4 6 spd. I have had no problems so far. The transmission was hard to speed shift until after 5000 miles or so. The clutch is weak in my opinion. I slipped it once in a real steep driveway. That was kind of a bummer. Everything works and I use the 4wd all of the time. I have been hunting for anything that may need attention. I will be out of warranty pretty quick. The back springs suck they were designed for a car or something.
     
  20. Jun 17, 2009 at 1:40 PM
    #20
    Richman21

    Richman21 I think therefore I'm a Democrat

    Joined:
    Jan 15, 2009
    Member:
    #12603
    Messages:
    442
    Gender:
    Male
    First Name:
    Jeff
    Albuquerque, NM
    Vehicle:
    09 DC Sport PreRunner
    Hardwire radar detector. Tube steps.
    Transmission lag.. I have 2,800 miles and has done it since I got it. I would like to hear what they have to say.
     
To Top