1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2012 brake Squeak?

Discussion in '2nd Gen. Tacomas' started by gthupman, Jul 6, 2012.

  1. Jul 7, 2012 at 9:58 PM
    #21
    jw1983

    jw1983 Well-Known Member

    Joined:
    Sep 18, 2011
    Member:
    #63738
    Messages:
    3,045
    Gender:
    Male
    First Name:
    Jason
    Alberta
    Vehicle:
    13' Tacoma Access 4x4 OR
    brake dust?
     
  2. Jul 7, 2012 at 10:06 PM
    #22
    TruckyTruck

    TruckyTruck Well-Known Member

    Joined:
    May 6, 2012
    Member:
    #78304
    Messages:
    487
    Gender:
    Male
    Vehicle:
    Tundra Crewmax TSS Off-Road 4x4, sr5/leather
    had the same problem. first time in was at the 5k mark and they took them apart and cleaned them. worked for about two hours before squealing again. the second time they machined them and now they are alot more quiet. still a small squeal sometimes though, so ill be mentioning it a third time. not sure how much they can do about it, but im going to ask them to change the drum pads. if they dont, ill be putting my own in. the only thing that would void is the pad and possibly the drum itself. no big deal. as long as they are quiet.
     
  3. Jul 8, 2012 at 9:52 PM
    #23
    gthupman

    gthupman [OP] Well-Known Member

    Joined:
    Feb 18, 2012
    Member:
    #73068
    Messages:
    190
    Gender:
    Male
    First Name:
    Tripp
    North Carolina
    Vehicle:
    '12 Super-White 4drlongbed Trd Sport
    Black Low Profile UWS toolbox, Painted Emblems, BHLM
    last night i took off the caliper and lubed the back of the brake pads on the front, did not touch the drums. the squeak now occurs every second or third stop rather than every time
    this helped a little but when you pay 30k + for a truck, i expect NO squeak
     
  4. Jul 9, 2012 at 6:58 PM
    #24
    TruckyTruck

    TruckyTruck Well-Known Member

    Joined:
    May 6, 2012
    Member:
    #78304
    Messages:
    487
    Gender:
    Male
    Vehicle:
    Tundra Crewmax TSS Off-Road 4x4, sr5/leather
    I agree. mine a squeek here and there even after the machined and cleaned them. when i go in again for the 10k service im going to tell them again. telling you they cant do anything about it is so lazy. just ask for the service manager and tell him you want it fixed. if they wont help, find a different dealer. i take mine to a different dealer from where i bought mine. they were such liars there i couldnt make myself go back. one of my better decisions too. this place makes an effort to get things right. so there are some good places out there. good luck
     
  5. Jul 21, 2012 at 7:12 PM
    #25
    dfrugia

    dfrugia Well-Known Member

    Joined:
    Feb 1, 2012
    Member:
    #71884
    Messages:
    435
    Gender:
    Male
    First Name:
    Goose
    Roswell, NM
    Vehicle:
    2012 DC TRD OFF RD 4X4
    Running boards w/steps, Weathertechs
    Mine just rolled 6k and started squeaking. Not happy about it.
     
  6. Jul 21, 2012 at 7:33 PM
    #26
    bash42

    bash42 Well-Known Member

    Joined:
    Jun 28, 2011
    Member:
    #59011
    Messages:
    775
    Gender:
    Male
    Eastern PA
    Vehicle:
    '13 Tacoma Access Cab 2.7L 4x4 5spd
    2012 DCSB o/r with about 2500 miles and same thing. It's annoying as shit! It only happens at the very end of a stop, within the last split second. I plan on bringing it up at my 5k service. Anyone have any resistance from the dealer about fixing this?

    After three times without being fixed, you should be able to claim lemon law and get a brand new truck! Haha
     
  7. Jul 21, 2012 at 7:49 PM
    #27
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    3,586
    Gender:
    Male
    SC
    Vehicle:
    Prerunner SR5
    My 2012 doesn't do this. I make sure to hose out the brakes whenever I wash it.
     
  8. Jul 21, 2012 at 8:04 PM
    #28
    Proyota

    Proyota Well-Known Member

    Joined:
    Dec 16, 2011
    Member:
    #68860
    Messages:
    200
    Gender:
    Male
    First Name:
    Brad
    Manteca
    Vehicle:
    2012 Tacoma TRD Off-Road Dbl Cab
    OME Suspension, Extended Rear Brake Lines, ProComp Wheels & Tires, PIAA Lamps, Warn Winch, All Pro Off-Road Bumpers and Rock Sliders, Budbuilt Skid Plate, BAMF Diff Guard and LCA Skids
    My 2012 Tacoma Dbl Cab is also squeaking from the rear drum brakes. Haven't been too worried about it. Figured at the next tire rotation I'd pull the drums off and take a look into it a little further. I have approx. 9500 miles on the trunk and it started within the first couple thousand miles and has been present ever since. It occurs right before I come to a complete stop and can be annoying in stop and go traffic.
     
  9. Jul 26, 2012 at 8:31 AM
    #29
    MCCipolla

    MCCipolla New Member

    Joined:
    Jul 26, 2012
    Member:
    #83462
    Messages:
    1
    Gender:
    Male
    First Name:
    Mike
    GA
    Vehicle:
    2012 Pre-Runner DCab V6 2x4
    My 2012 Double Cab with jut over 1000 miles has started squeaking first thing in the morning when I back out of the driveway. Then all is well. Wife is not happy since we bugged the dealer about getting this truck. Never had trouble with my '87 or '10 and it really is annoying with one this new. Saw on some old posts that Toyota had trouble with this back on the '07 models and there was a TSD, but guess that hasn't been address with ones this new yet. Dealer says they can't fix it if they can't dulipcate the problem. Just let them have it until they can.
     
  10. Jul 26, 2012 at 12:09 PM
    #30
    nut

    nut she'll ride

    Joined:
    Nov 6, 2011
    Member:
    #66555
    Messages:
    1,615
    Gender:
    Male
    First Name:
    Patrick
    Currently Richmond, VA
    Vehicle:
    Totaled
    TRD SKEWP DCSB 4x4 Silver Mica | URD TCAI/MAF CAL | BHLM | GrillCraft | FF Sliders | LED's All Around | 12v Constant On | EGR In Channel | 15% Tint | Trimmed mud flaps | Fog Light Anytime Mod | Debadged | Tailgate Hoseclamp | DTRL Switch | Disabled Lock Beep/Seatbelt Chime | Husky Liners | HID's | BedRug | WO Seat Covers | ABS Kill Switch | Oil Catch Can | Viper 5704 | Custom Carbon Cabin Filter | Backup Camera Anytime | 400W Anytime | In Cab Outlet W/USB | Firestone Ride Rites | Ams Oil All Around | 32" LED In Lower Grill | BlackVue DR500GW-HD |
    my 12 does it, its only the rears, the dealer scuffed the drums/pads for me, lasted about 7K miles, It's doing it again... just gonna live with it :rolleyes:
     
  11. Jul 27, 2012 at 2:40 PM
    #31
    4x4Taco2012

    4x4Taco2012 Well-Known Member

    Joined:
    Jan 14, 2012
    Member:
    #70671
    Messages:
    418
    Gender:
    Male
    Philadelphia, PA
    Vehicle:
    2013 DCSB TRD Sport 4x4
    Tacoma Bed Mat, TRD Front Skid Plate, Pop'N'Lock Tailgate Lock, Weathertech Digifit Floor Mats, BAK Roll-X Tonneau Cover, Toyota Wheel Locks, Sliding Rear Window Lock, Center Console and Glove Box Motion Detection LEDs, BFG Rugged Terrains, PrimusIQ Brake Controller, Toyota Cargo Net, Entune w/Nav.

    4k miles on the '12. 4Runner has 43K on it and it started doing it occasionally in cold weather at about 35K.
     
  12. Jul 27, 2012 at 4:36 PM
    #32
    pinktaco808

    pinktaco808 Hot Steppa

    Joined:
    Jul 23, 2010
    Member:
    #40651
    Messages:
    2,824
    Gender:
    Male
    mine does it after i wash my truck.
     
  13. Jul 30, 2012 at 5:08 PM
    #33
    B18blk

    B18blk Member

    Joined:
    Jan 20, 2012
    Member:
    #71066
    Messages:
    17
    Gender:
    Male
    (626)
    Vehicle:
    Pre runner sr5
    Same problem with mine too! 8k on it started around5k Just came back from the dealer and they want me to take back on Wednesday when the "Toyota" reps will be there to inspect my truck and approve the repair. So will see what kind of bs answer I get that day.
     
  14. Aug 3, 2012 at 10:43 PM
    #34
    B18blk

    B18blk Member

    Joined:
    Jan 20, 2012
    Member:
    #71066
    Messages:
    17
    Gender:
    Male
    (626)
    Vehicle:
    Pre runner sr5
    So I took it back to the dealer and the techs could not duplicate the squeak . I told them you have to gently brake and right before the complete stop the sqeak sounds. Long story short I got behind the wheel And duplicated the sound in front of them. They resurfaced and lubricated the back brakes and bam it's been 3 days and no squeak yet. Will see how long it lasts!
     
  15. Aug 4, 2012 at 12:58 PM
    #35
    gthupman

    gthupman [OP] Well-Known Member

    Joined:
    Feb 18, 2012
    Member:
    #73068
    Messages:
    190
    Gender:
    Male
    First Name:
    Tripp
    North Carolina
    Vehicle:
    '12 Super-White 4drlongbed Trd Sport
    Black Low Profile UWS toolbox, Painted Emblems, BHLM
    make sure to keep us updated!
    how could we possibly get tsb for this ?
     
  16. Aug 28, 2012 at 10:28 PM
    #36
    B18blk

    B18blk Member

    Joined:
    Jan 20, 2012
    Member:
    #71066
    Messages:
    17
    Gender:
    Male
    (626)
    Vehicle:
    Pre runner sr5
    Just hit 10k and the squeak is back!! I ll get looked at again when I go in for my oil change. Will keep u guys posted...
     
  17. Aug 29, 2012 at 12:00 PM
    #37
    gthupman

    gthupman [OP] Well-Known Member

    Joined:
    Feb 18, 2012
    Member:
    #73068
    Messages:
    190
    Gender:
    Male
    First Name:
    Tripp
    North Carolina
    Vehicle:
    '12 Super-White 4drlongbed Trd Sport
    Black Low Profile UWS toolbox, Painted Emblems, BHLM
    im trying a different dealer at my 10k change, hopefully i'll see some different results..
     
  18. Sep 18, 2012 at 10:18 PM
    #38
    MCM78LC

    MCM78LC Well-Known Member

    Joined:
    Oct 18, 2011
    Member:
    #65442
    Messages:
    47
    Gender:
    Female
    Saint Paul, MN
    Vehicle:
    2012 TX Pro Double Cab - V6 - 4x4
    Sub'd.
     
  19. Sep 21, 2012 at 1:41 PM
    #39
    1FSTLS1

    1FSTLS1 Well-Known Member

    Joined:
    Jun 21, 2010
    Member:
    #39249
    Messages:
    66
    Gender:
    Male
    My 2010 does it. Stupid drum brakes. Dealer is not touching my truck.
     
  20. Sep 21, 2012 at 3:14 PM
    #40
    knayrb

    knayrb Well-Known Member

    Joined:
    Mar 3, 2010
    Member:
    #32473
    Messages:
    715
    Gender:
    Male
    Utah
    Vehicle:
    2010 Dbl-Cab Off-Road
    Pure stock
    My 2010 did this since it was new. I put a little bearing grease where the brake pads touched the inside cover contact points and its been quite for 45000 miles.
     
To Top