1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2nd gen, Anytime-On Rear View Camera with Switch on Dash mod

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Crom, Sep 25, 2011.

  1. Jul 12, 2016 at 3:01 PM
    #261
    Tacospreader

    Tacospreader New Member

    Joined:
    Jul 11, 2016
    Member:
    #191819
    Messages:
    1
    Gender:
    Male
    First Name:
    Ty
    Victoria B.C.
    Vehicle:
    2014 Spruce Mica Trail Teams
    TRD exhaust
    Nice write up. Subbed for later
     
  2. Jan 3, 2017 at 2:07 PM
    #262
    BellyUpFish

    BellyUpFish Well-Known Member

    Joined:
    Feb 12, 2015
    Member:
    #148525
    Messages:
    61
    Gender:
    Male
  3. Jan 20, 2017 at 4:26 PM
    #263
    irish_11

    irish_11 Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34039
    Messages:
    428
    Gender:
    Male
    Everett, WA
    Vehicle:
    2011 DCSB
    Just keep throwin' money at it.
    Just to make sure that I am doing this right because I picked up a SPST switch (https://www.amazon.com/gp/product/B01IHF5KZY/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1) to match the dash. I have the correct relay.

    here is the switch wiring:
    [​IMG]

    From relay:
    • red wire (from the IN1 connector) goes to 87a
    • 85 is ground
    • 86 is power from switch (green on switch)
    • 30 is blue on switch
    From switch:
    • green wire from the switch to 87 on relay
    • blue 12v source from relay
    • yellow goes to dash illumination
    • black wire from switch goes to ground
     
  4. Jan 20, 2017 at 4:48 PM
    #264
    SpruceTaco

    SpruceTaco トヨタ

    Joined:
    May 18, 2012
    Member:
    #79082
    Messages:
    12,291
    Gender:
    Male
    First Name:
    Mike
    Clearwater, FL
    Vehicle:
    2012 Spruce Mica TRD Sport
    Tinted windows 5%, sill protectors, TRD stubby antenna, weathertech in channel rain guards, wheathertech floor mats, BHLM, Truxedo low pro qt, DTRL deleted, anytime backup camera, bed storage locks, fog lights on anytime, tailgate theft deterrent, painted engine cover, relocated horns, l.e.d bed lights, l.e.d engine bay lights, l.e.d lights above cup holders, in glove box, rear cup holder, in console storage & cubby next to steering wheel, Grillcraft grill, 17x8.5 SCS Ray10's, 35x12.50 Nitto Ridge Grapplers, Borla cat back exhaust, map & dome l.e.d's, TEQ badge on grill, Redline tuning hood struts, Maxtrac spindles, SPC Light Racing UCA's, Bilstein 5100's front set at 0 with OME 885's & extended length Bilstein 5100's in the rear, All Pro expedition leaf springs & 2" blocks, extended brake lines front & rear, 1.5" 4crawler drive shaft spacer, Beefed Taco carrier bearing drop, 1.25" spidertrax wheel spacers on rear, Kenwood DNX570 touchscreen with navigation, 30" led light bar in lower bumper opening, 1/4" top plate spacer drivers side, Bullet Proof Fabricating skid plate, Cali Raised ditch lights & Rago f Fabrication brackets, Amp Research power steps, smoked l.e.d 3rd brake light, Wet Okole seat covers, under cab LED'S tied to dome circuit
    2 things, 1) that's for a Hilux not a Tacoma & says nothing about Tacoma so don't know if it would fit. 2) you need a single pole double throw (SPDT) switch that's single pole single throw (SPST) switch.
     
    KRAMERICA likes this.
  5. Jan 22, 2017 at 6:29 AM
    #265
    59ksmall

    59ksmall Well-Known Member

    Joined:
    Nov 16, 2015
    Member:
    #169849
    Messages:
    83
    Gender:
    Male
    Florida
    Vehicle:
    2011 TRD Off-road Dbl Cab 6spd
    Sub'd.
    What he said.
     
  6. Jan 22, 2017 at 3:43 PM
    #266
    Robman

    Robman Well-Known Member

    Joined:
    May 26, 2014
    Member:
    #130638
    Messages:
    522
    Gender:
    Male
    First Name:
    Rob
    Hawaii
    Vehicle:
    '14 Tacoma Double Cab

    Sorry for the late reply. Not sure how to make it clearer than my original diagram you quoted and it's a little hard to follow on my phone ATM.

    Negative Ghost Rider, see the aforementioned diagram. You can use a standard SPDT relay to achieve the desired outcome.
     
    irish_11 likes this.
  7. Jan 24, 2017 at 1:45 PM
    #267
    irish_11

    irish_11 Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34039
    Messages:
    428
    Gender:
    Male
    Everett, WA
    Vehicle:
    2011 DCSB
    Just keep throwin' money at it.
    Okay, not to beat a dead horse with this one, but I am still learning more about electrical. I cannot seem to get this to work with the SPST switch and relay. I can get the display to switch over, but I get a transmission position sensor CEL.

    @Robamn, thanks for the help with this.

    I wired it up per your instructions (https://www.tacomaworld.com/media/reverse-camera-wiring-diagram.508572/full?d=1458263256) and I keep getting the CEL Christmas tree. I've tried both your diagram and @ddungo's (https://www.tacomaworld.com/threads...switch-on-dash-mod.179242/page-9#post-7437267) with the same result. Here is what I have currently:

    Relay:
    87 - Ignition
    87A - From Computer
    30 - Screen (in mirror)
    85 - Accessory wire from switch
    86 - Ground

    Switch:
    Blue - 12v source (add a fuse, combined with 87 on relay)
    Green - 85 on relay
    Yellow - Dash Illumination
    Black - Ground

    This combo makes the truck think its in Reverse and throws a transmission position sensor CEL. Anyone see what I am doing wrong here? I cut the IN1 connector and the camera no longer turns on when in reverse. Added in the male and female connectors, so when I remove all that I have done and connect it back together it functions correctly. This leads me to believe I cut the right wire.
     
  8. Jan 24, 2017 at 2:14 PM
    #268
    Robman

    Robman Well-Known Member

    Joined:
    May 26, 2014
    Member:
    #130638
    Messages:
    522
    Gender:
    Male
    First Name:
    Rob
    Hawaii
    Vehicle:
    '14 Tacoma Double Cab
    I've gone over some scenarios on paper, if you followed your diagram precisely you should be right as the rain. The only way to get the CEL you are seeing is by applying 12V to the wire you cut from the computer when the vehicle is in any other gear. I think the bottom line here is that you need to grab your ohmmeter and test each connection.

    When does the CEL kick in? As soon as you start the vehicle, in Park with the reverse camera switch off? Got any pics of your wiring?
     
  9. Jan 24, 2017 at 2:23 PM
    #269
    Robman

    Robman Well-Known Member

    Joined:
    May 26, 2014
    Member:
    #130638
    Messages:
    522
    Gender:
    Male
    First Name:
    Rob
    Hawaii
    Vehicle:
    '14 Tacoma Double Cab

    Also your wiring of the relay is backwards of mine wherein you are applying ground to pin 86 and 12V to pin 85. Now this shouldn't matter at all, relay coils typically work regardless of current direction but if you tied certain wires together following my diagram, you may not have wired it the way you think.
     
  10. Jan 24, 2017 at 3:26 PM
    #270
    irish_11

    irish_11 Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34039
    Messages:
    428
    Gender:
    Male
    Everett, WA
    Vehicle:
    2011 DCSB
    Just keep throwin' money at it.
    Once again thanks for all the help!

    I'll take a photo when I get home. I unwired everything last night to go over it again.

    Worth a shot.


    Edit: Rewired it and flipped 85 & 86. I still get the backup lights and the indicator showing R when I flip the switch, but no CEL so I'll take that as a win.
     
    Last edited: Jan 24, 2017
  11. Jan 24, 2017 at 6:54 PM
    #271
    Robman

    Robman Well-Known Member

    Joined:
    May 26, 2014
    Member:
    #130638
    Messages:
    522
    Gender:
    Male
    First Name:
    Rob
    Hawaii
    Vehicle:
    '14 Tacoma Double Cab
    Maybe I should've asked this at the outset, how did you physically wire the 30 pin to your camera? Did you cut the wire coming from the computer?
     
    seoulja99 likes this.
  12. Jan 24, 2017 at 7:17 PM
    #272
    nudavinci64

    nudavinci64 Taco Outlaw

    Joined:
    Nov 14, 2013
    Member:
    #116533
    Messages:
    6,840
    Gender:
    Male
    First Name:
    Robert
    San Mateo/Cayucos, CA
    Vehicle:
    13 S/C TRD OffRoad 4x4
    Boosted Money Pit....
    What Gauge is the hookup wire you used?
     
  13. Jan 24, 2017 at 7:25 PM
    #273
    irish_11

    irish_11 Well-Known Member

    Joined:
    Mar 27, 2010
    Member:
    #34039
    Messages:
    428
    Gender:
    Male
    Everett, WA
    Vehicle:
    2011 DCSB
    Just keep throwin' money at it.
    I cut the IN1 wire. Put a male connector on the computer side and female connector on the harness side. Took the 87a wire from my relay harness and connected it to the computer side, as well as the 30 to the harness side.

    Edit: threw a CEL last night when I tried this above 35mph, below 20mph no issues.
     
    Last edited: Jan 25, 2017
    seoulja99 likes this.
  14. Feb 26, 2017 at 12:39 PM
    #274
    nudavinci64

    nudavinci64 Taco Outlaw

    Joined:
    Nov 14, 2013
    Member:
    #116533
    Messages:
    6,840
    Gender:
    Male
    First Name:
    Robert
    San Mateo/Cayucos, CA
    Vehicle:
    13 S/C TRD OffRoad 4x4
    Boosted Money Pit....
    Wired up and tested. Works great. My issue is the airbag light is now on. Checked the fuse for it ( location 1) and no issue. Tried to revert back to see and same issue.

    IMG_5873.jpg IMG_5875.jpg
     
    Last edited: Feb 26, 2017
  15. Apr 23, 2017 at 8:52 AM
    #275
    88Hatchy

    88Hatchy Member

    Joined:
    Dec 26, 2015
    Member:
    #173192
    Messages:
    16
    Gender:
    Male
    First Name:
    Will
    Vehicle:
    2015 Tacoma TRD
    Can anyone verify if this will work on a '15 that has the camera display in the dash?
     
    Last edited: Apr 23, 2017
  16. Apr 25, 2017 at 7:16 AM
    #276
    AcerD

    AcerD Well-Known Member

    Joined:
    Feb 25, 2017
    Member:
    #211679
    Messages:
    157
    Gender:
    Male
    First Name:
    Austin
    Bend OR
    Vehicle:
    2013 Tacoma Shortbed
    Thanks for the good write up! SUB'D
     
  17. Apr 25, 2017 at 7:45 AM
    #277
    yonah

    yonah Well-Known Member

    Joined:
    Jul 25, 2015
    Member:
    #160294
    Messages:
    388
    Gender:
    Male
    Calling-in from east of the Rockies
    I would start checking all of your other fuses related to the gauge cluster and/or radio. Maybe something shorted - wires touched - during the install. Did you disconnect your battery before attempting this modification? I would recommend replacing the airbag fuse even if it looks okay.
     
  18. May 1, 2017 at 10:51 AM
    #278
    DougsGraphics

    DougsGraphics Duck Hunter!

    Joined:
    Jun 28, 2015
    Member:
    #158319
    Messages:
    244
    Gender:
    Male
    First Name:
    Doug
    Northern New Mexico
    Vehicle:
    2015 Pyrite Mica DCSB TRD OR
    3" Revtech Level, ARB Deluxe Bull Bar front bumper with WARN 9.5XP Winch and KC Pro-Sport LED Driving Lights, black Diamond Back HD tonneau cover, 4 cameras through Entunes display with capacity for two more, LED interior lights with map lights tied to dome, Bussman auxiliary fuse/relay box with 100 amp breaker/disconnect under hood.
    Old School likes this.
  19. May 20, 2017 at 4:37 PM
    #279
    Durdy

    Durdy Well-Known Member

    Joined:
    Jan 15, 2017
    Member:
    #207678
    Messages:
    71
    Gender:
    Male
    Utah
    Vehicle:
    2012 Black Sand Pearl Tacoma TRD Off Road
    Relentless Fab Bed Bars Prinsu Roof rack CVT Mt Shasta Extended Summit RTT CVT Pioneer 72"Awning Road Shower 7 Gallons Pelican Case Roof Mount EBC Stage 4 disc brakes EBC Green Stuff Pads Rear Axle Breather Relocation 12v plug in bed for RTT Rigid SR-M Diffused Bed Light Bilstein 6112 SPC Upper Control Arm Rad Rubber Designs Engine Splash Guards 2" Add-a-leaf 265/75/R16 Falken Wildpeak AT3W
    Will this work for 2012 mirror display? I'm shit at wiring and want to triple check everything before diving in.
     
  20. May 20, 2017 at 6:05 PM
    #280
    Darkgoatracer

    Darkgoatracer Well-Known Member

    Joined:
    Feb 18, 2017
    Member:
    #210945
    Messages:
    5,528
    Gender:
    Male
    First Name:
    Nick
    Northern VA
    Vehicle:
    2012 trd sport tacoma
    Stock
    I'm gonna have to do this!
     

Products Discussed in

To Top