1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2nd Gen, high mileage and issues.

Discussion in '2nd Gen. Tacomas' started by nagelg, May 11, 2010.

  1. May 11, 2010 at 8:35 AM
    #1
    nagelg

    nagelg [OP] Well-Known Member

    Joined:
    Mar 9, 2008
    Member:
    #5184
    Messages:
    444
    Gender:
    Male
    First Name:
    George
    Northern Wisconsin
    Vehicle:
    '08 Black, acc. cab, 4x4, 2.7
    Lots of threads asking about 'How many miles on your Taco'

    Lets hear from you guys who have:

    -High miles (how many)

    -Issues and how they were resolved

    -How have you driven it? (Just a daily driver?... beat the snot out of it offroad? etc.)

    -Your opinion about the durability of your 2nd gen Taco

    I'm perfectly happy with my baby, but there is so much complaining going on in so many threads....
     
  2. May 11, 2010 at 8:58 AM
    #2
    yosh2000

    yosh2000 Well-Known Member

    Joined:
    Sep 18, 2007
    Member:
    #2733
    Messages:
    2,895
    Gender:
    Male
    Denver, CO
    Vehicle:
    '05 4runner SR5 v8
    138k, no major work, daily driver, opinions mean nothing, actual data is everything! i am as happy as can be w/ my truck!
     
  3. May 11, 2010 at 8:59 AM
    #3
    tiresmokintacoma

    tiresmokintacoma Bean&Cheese Taco

    Joined:
    Jul 7, 2009
    Member:
    #19408
    Messages:
    424
    Gender:
    Male
    First Name:
    VIC
    Texas
    Vehicle:
    Lexus LX450
    No lift tucking 35s with sliders
    142,000+ miles. No problems whatsoever. Just oil changes and tune ups. Best truck ever.
     
  4. May 11, 2010 at 9:20 AM
    #4
    memario1214

    memario1214 Vivid Illumination Vendor

    Joined:
    Oct 1, 2009
    Member:
    #23628
    Messages:
    12,984
    Gender:
    Male
    First Name:
    Colton
    MT recently relocated to Willmar, MN
    Vehicle:
    05 Dub Cab TRD Sport 4x4
    TRD Cold Air Intake, rear cat delete with Aero Turbine 2525, Maglite mount mod, white LED's all around, white gauges w/blue needles, Tinted Tails, Morimoto 32" XBAR LED Bar, Truxedo Lo-Pro QT Tonneau, Pioneer AVIC X-920 BT touchscreen, FX-R Retrofit, LR UCAs, OME 3" Lift w/ Dakar leafs, DTLT Headers, Walbro 255 fuel pump, TRD S/C, Hankook Dynapro ATM tires
    82k on my truck, no major issues to this point... I just replaced the brakes last week, and it feels like my suspension is starting to get a little tired. Nothing else though!
     
  5. May 11, 2010 at 6:15 PM
    #5
    nagelg

    nagelg [OP] Well-Known Member

    Joined:
    Mar 9, 2008
    Member:
    #5184
    Messages:
    444
    Gender:
    Male
    First Name:
    George
    Northern Wisconsin
    Vehicle:
    '08 Black, acc. cab, 4x4, 2.7
  6. May 11, 2010 at 6:55 PM
    #6
    MxRacer190

    MxRacer190 Well-Known Member

    Joined:
    Apr 15, 2010
    Member:
    #35345
    Messages:
    2,471
    Gender:
    Male
    Georgia
    Vehicle:
    06 SR5 4x4 Indigo
    106k miles
    Daily driver, took her off road a few times, nothing hardcore. I think my power steering pump went out while doing doughnuts.

    - Timing chain cover oil leak (not fixing, costs too much)
    - Rear leafs of course. (2" AAL fixed that)
    - SR5 airbag light (clock spring is broke, fix when I can)
    - Power steering pump (ez fix)
     
  7. May 11, 2010 at 7:27 PM
    #7
    Airun

    Airun Well-Known Member

    Joined:
    Mar 19, 2010
    Member:
    #33516
    Messages:
    2,632
    Gender:
    Male
    First Name:
    Aaron
    Show Me State
    Vehicle:
    TRD sport, DCLB, 4wd
    Debadged, custom emblem, Husky liners, custom bedrail Yak Trak setup with load bars, , BakFlip Fibermax, OME 3" lift with LightRacing UCAs
    Just bought my 07 DC 4x4 two months ago with 98000 local highway miles with local dealer verifying all service and maintenance had been performed. Hit 100k on my way to work this morning and couldn't be happier. 50 mile round trip daily driver and gettin 21.5mpgs. Running Mobil1 and planning on switching to synthetic tranny, diff and transfer case lubes as well. Keeping my fingers crossed.
     
  8. May 11, 2010 at 7:31 PM
    #8
    Tillers_Rule

    Tillers_Rule ......................

    Joined:
    Mar 21, 2008
    Member:
    #5418
    Messages:
    803
    Gender:
    Male
    First Name:
    Jeff
    San Diego
    Vehicle:
    4x4 Sport, debadged
    Icon coil overs up front, Total Chaos UCA, Icon remote reservoir in the back with Deaver 11 pack leafs. Sunroof, Hella 500's behind grill.
    264,000 haven't even had to put gas in it yet
     
  9. May 11, 2010 at 7:34 PM
    #9
    MxRacer190

    MxRacer190 Well-Known Member

    Joined:
    Apr 15, 2010
    Member:
    #35345
    Messages:
    2,471
    Gender:
    Male
    Georgia
    Vehicle:
    06 SR5 4x4 Indigo
    what's gas?
     
  10. May 28, 2010 at 3:14 AM
    #10
    MotoXdoer

    MotoXdoer taco?

    Joined:
    May 26, 2009
    Member:
    #17677
    Messages:
    1,633
    Gender:
    Male
    First Name:
    Nate
    San Luis Obispo, Ca
    Vehicle:
    06 Prerunner 4.0 a/c beast
    k&n cai 63 series intake, blacked out headlights, blacked out tailights, magnaflow pro offroad 17115 dumped, URD competetion y-pipe, total chaos 3.5" long travel, fox 2.5x8" remote resevoir shocks, allied 4" spindles, toytec 2" AAL, 20% tint up front and 5% rear, satoshi grille, ddm 50w 6000k hid's. wet okole custom trd seat covers with heaters. 4:56 nitro gears with arb rd129 air locker, arb ckmta12 dual air compressor.
    im @ 91k and i have an oil leak coming from the passenger valve cover and my timing is definetly off. is there a ho wto on the timing chain tension spec.?
     
  11. May 28, 2010 at 9:25 AM
    #11
    MxRacer190

    MxRacer190 Well-Known Member

    Joined:
    Apr 15, 2010
    Member:
    #35345
    Messages:
    2,471
    Gender:
    Male
    Georgia
    Vehicle:
    06 SR5 4x4 Indigo
    Idk about a DIY, but the dealer quoted me $1450 to repair my timing chain cover leak.
     
  12. Jun 28, 2010 at 4:44 PM
    #12
    06yoter

    06yoter Active Member

    Joined:
    Nov 5, 2008
    Member:
    #10527
    Messages:
    35
    Gender:
    Male
    First Name:
    Chris
    Tampa/ Plant City, Florida
    Vehicle:
    06 Prerunner TRD Sport
    Doug Thorley long tubes, flowmasters, URD TCAI, custom dent in the bed from a fence
    i have an 06 with 103xxx miles and im hearing the same things on here. my timing chain cover is leaking, clockspring for airbag is out, rear suspension sucks, power steering pump leaking and messed up, and the flimsy ass metal sucks, but other than that they are great. Haha today the lady at toyota of tampa bay told me my airbag could go off at anytime because my clockspring is bad. is that even true?
     
To Top