1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

4Runner Engine lights

Discussion in '4Runners' started by suvh8er, Oct 16, 2013.

  1. Oct 16, 2013 at 5:11 PM
    #1
    suvh8er

    suvh8er [OP] Member

    Joined:
    Sep 24, 2013
    Member:
    #113167
    Messages:
    17
    Gender:
    Male
    First Name:
    Dave
    Delaware
    Vehicle:
    '01 Tacoma SR5
    My 04 4Runner (work truck) has the check engine light, the Maintenance light, the "VSC OFF" light, and the "TRAC" light all on right now. The check engine light flashes when I start the motor and I smell gas in the cab. I heard it may be that the gas cap isn't sealing correctly, any thoughts? I beat the piss out of this SUV on a daily basis btw.
     
    Last edited: Oct 22, 2013
  2. Oct 21, 2013 at 11:24 PM
    #2
    zbaldo

    zbaldo Well-Known Member

    Joined:
    Feb 10, 2012
    Member:
    #72550
    Messages:
    436
    Gender:
    Male
    First Name:
    Ozzy
    Torrance, Ca
    Vehicle:
    99 4Runner SR5 4X4
    Stock as Stock can be with duratracs and a roof rack
    Tacoma or 4runner?
     
  3. Oct 22, 2013 at 11:10 AM
    #3
    suvh8er

    suvh8er [OP] Member

    Joined:
    Sep 24, 2013
    Member:
    #113167
    Messages:
    17
    Gender:
    Male
    First Name:
    Dave
    Delaware
    Vehicle:
    '01 Tacoma SR5
    Whoops, meant 4runner! Edited
     
  4. Oct 22, 2013 at 5:34 PM
    #4
    Wishbone Runner

    Wishbone Runner Because 4R

    Joined:
    Sep 9, 2012
    Member:
    #86546
    Messages:
    2,641
    Gender:
    Male
    First Name:
    James
    CO
    Vehicle:
    04 SR5 4Runner
    • 04 SR5 V6 • King/Camburg/Icon/Metal Tech • 16" MT Classic Lock • Hankook RT03 295/75/16 • Shrockworks Sliders • RCI Skids • Hella 4000
    Likely the gas cap. Give that bitch a few extra cranks and it should solve it, it may take a few re-starts for the lights to clear.
     
To Top