1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

5125 Leaking after a couple of months

Discussion in 'Suspension' started by blake5995, Jan 24, 2013.

  1. Jan 24, 2013 at 11:57 PM
    #1
    blake5995

    blake5995 [OP] Well-Known Member

    Joined:
    Aug 12, 2012
    Member:
    #84632
    Messages:
    2,217
    Gender:
    Male
    First Name:
    Blake
    Truckee, CA
    Vehicle:
    98 Tacoma SR5 4x4 2.7L
    Has anyone had a problem with there 5125 not lasting very long i think mine have been on the truck 3 months and they are already leaking really bad.
     
  2. Jan 25, 2013 at 1:06 AM
    #2
    Sublime

    Sublime Well-Known Member

    Joined:
    Nov 14, 2009
    Member:
    #25918
    Messages:
    3,710
    Gender:
    Male
    First Name:
    Mike
    Phoenix, AZ
    Vehicle:
    08 TRD 4x4
    Icon/All Pro.....chopped for 35's
    Where did you get them? They should have lifetime warranty as long as you weren't desert racing with them. Are the lengths appropriate (not bottoming out or over extending)?
     
  3. Jan 25, 2013 at 11:44 AM
    #3
    blake5995

    blake5995 [OP] Well-Known Member

    Joined:
    Aug 12, 2012
    Member:
    #84632
    Messages:
    2,217
    Gender:
    Male
    First Name:
    Blake
    Truckee, CA
    Vehicle:
    98 Tacoma SR5 4x4 2.7L
    I bought them from all pro and they only have a 90 day warranty if I spent a little more for the 5100 they would have a lifetime but I didn't. I was just surprised how fast they started leaking and I don't do anything to my shocks like jumping my truck or anything like that. It was all street driving I comute 220 miles four times a week.
     
To Top