1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

8 months old, 13k miles, A/C just died; radio is messed up

Discussion in '2nd Gen. Tacomas (2005-2015)' started by xerri, Mar 27, 2010.

  1. Mar 27, 2010 at 2:53 PM
    #1
    xerri

    xerri [OP] Member

    Joined:
    Jun 13, 2009
    Member:
    #18422
    Messages:
    13
    Gender:
    Male
    MS
    Vehicle:
    09 Tacoma
    Well, it looks like I'm going to be taking my truck in to the shop sometime this week. My 8 month old, 2009 Tacoma's A/C is blowing warmer than the outside temperature.
    My radio just started glitching too. I haven't had any trouble with it up until yesterday; since then, the volume dial will randomly stop working. On/Off still functions. I read a few days ago that the '09s have been having some problems with the radio, and Toyota is looking to change suppliers.

    I'm kind of disappointed I'm having trouble with it so early on. I realize parts go bad or are defective from the manufacturer, but I never had any problems with my S-10 for the first 6 years (clutch went out). The A/C system on that truck lasted 9 years until it finally needed to be replaced.

    Does Toyota normally provide a loaner vehicle while the warranty is still in effect? And is there a fix in for the radio yet?

    Thanks
     
  2. Mar 27, 2010 at 2:58 PM
    #2
    CorrectionCop

    CorrectionCop Well-Known Member

    Joined:
    Jan 2, 2010
    Member:
    #28599
    Messages:
    202
    Gender:
    Male
    First Name:
    Dave
    Arizona
    Vehicle:
    07 PreRunner Off Road SR5 V6 access cab
    Locking differential,TSB 4 Leaf Spring, Bug deflector.
    All vehicles have problems. I consider a major problem leaving you alone side the road dead. The rest are yes frustrating and an inconvenience but, not the end of the world.

    you should be able to get a loaner vehicle, in fact I would insist. :laser:
     
  3. Mar 27, 2010 at 2:59 PM
    #3
    hendooman

    hendooman The Stroker Ace

    Joined:
    Mar 6, 2009
    Member:
    #14421
    Messages:
    3,040
    Gender:
    Male
    First Name:
    Jeff
    KC
    Vehicle:
    2015 TRD PRO 4Runner
    go back to the s10...things happen, toyota will fix it
     
  4. Mar 27, 2010 at 3:07 PM
    #4
    xerri

    xerri [OP] Member

    Joined:
    Jun 13, 2009
    Member:
    #18422
    Messages:
    13
    Gender:
    Male
    MS
    Vehicle:
    09 Tacoma
    Agreed. It's not the end of the world, just an inconvenience.
    It doesn't help that the closest dealership is 45 miles away, so it looks like I'll be taking a few hours off from work. S-10 got sold a few months ago.

    Luck of the draw I guess. :rolleyes:
     
  5. Mar 27, 2010 at 3:11 PM
    #5
    Kyouto42

    Kyouto42 Iron Beard

    Joined:
    Aug 18, 2008
    Member:
    #8614
    Messages:
    9,243
    Gender:
    Male
    First Name:
    Jake
    Ahwatukee, AZ
    Vehicle:
    BSP '10 4x4 TRD Off-Road DC
    See build thread in signature
    Go back to your cave.


    It is frustrating but Toyota should fix it. There have been a lot of issues with the 09+ radios, hopefully they'll have one on hand for a quick swap. As for the A/C... just to throw a couple of simple things out first... you do have the A/C button lighting up right? Also did you try the recirculate button to be on as well? Also the dials are on front, floor or front/floor. Other settings will turn a/c off. I know it sounds obvious and don't take it the wrong way, just sometimes the simplest things can bite you in the ass :D Also, the newer A/C systems do take quite a long time to start getting cold compared to the old setups. It sucks, but the feds forced out the good refrigerant to satisfy the hippies. I've also found it seems to cool down faster if you stay one notch before max fan (blowing to hard doesn't help cool the air as well).

    GL!
     
  6. Mar 27, 2010 at 3:21 PM
    #6
    xerri

    xerri [OP] Member

    Joined:
    Jun 13, 2009
    Member:
    #18422
    Messages:
    13
    Gender:
    Male
    MS
    Vehicle:
    09 Tacoma
    No offense taken. ;)

    The A/C light was on the entire time, I tried it with the recirculate button on and off, and there is no difference. Me and friend drove to a gun show today about 30 miles away, and it was the same all the way there. I cycled through all levels of the blower control (normally keep it on the 2nd from last setting too) and the only difference between them was the amount of warm air that got blown into the cab. :D
     
  7. Mar 27, 2010 at 3:29 PM
    #7
    MachoTaco10

    MachoTaco10 Well-Known Member

    Joined:
    Feb 14, 2010
    Member:
    #31366
    Messages:
    390
    Gender:
    Male
    First Name:
    Nick
    New Hampshire
    Vehicle:
    2010 Tacoma TRD Sport
    A/C has to be recharged. Faulty radio. most minor of minor problems.
     
  8. Mar 27, 2010 at 4:06 PM
    #8
    LTech221

    LTech221 Lurker

    Joined:
    Jan 11, 2010
    Member:
    #29156
    Messages:
    28
    Gender:
    Male
    First Name:
    Mark
    So Cal
    Vehicle:
    05 TRD Sport Prerunner DCSB
    Bilstein 5100 @ .85, 3 Leaf with Wheelers HD prog pack & 5100. Solid Fold 2.0 Tonneau. Sound stuff.
    Had some AC trouble with my 05 recently, also needed to be recharged. What ended up happening was a rock punctured the condenser unit & there was refridgerant leaking all over. Pressure test verified no pressure, just replaced the condenser and recharged, was good to go after that.
     
  9. Mar 27, 2010 at 4:10 PM
    #9
    Chad

    Chad Rand Paul 2016

    Joined:
    Oct 2, 2008
    Member:
    #9636
    Messages:
    2,365
    Gender:
    Male
    First Name:
    Chad
    Raleigh, NC
    Vehicle:
    09 V6 Access Cab TRD Sport
    Pioneer AVIC-X920BT Headunit -- BHLM -- Pioneer TS-A1685R 4-way Coax Speakers in Front -- Suntek CXP 40 Front Tint -- Access Vanish Roll-up Tonneau -- Wet Okole Seat Covers -- Fog Lights on Anytime -- PnL Powered Tailgate Lock -- DTRL "Stealth Mode" -- LED Footwell and Cup Holder Lights -- Map Lights ON with Dome Light -- Shorty Antenna -- AC Line Extension Mod -- 09+ Access Cab Rear Headrest Removal
    My 09 has the volume knob problem, but knock-on-wood, it hasn't occurred for a while... As for the AC, no problems here.
     
  10. Mar 27, 2010 at 7:26 PM
    #10
    Shades_Of_Red

    Shades_Of_Red Well-Known Member

    Joined:
    May 2, 2009
    Member:
    #16713
    Messages:
    92
    Gender:
    Male
    Pittsburgh, PA
    Vehicle:
    09 Tacoma TRD Sport AC
    I'm having the same radio problem (volume knob stopped working) on my 09 and it's 11 months old.
     
  11. Mar 27, 2010 at 7:46 PM
    #11
    uood8

    uood8 If You Search...You Shall Find.

    Joined:
    Jun 6, 2009
    Member:
    #18086
    Messages:
    1,372
    Gender:
    Male
    Greensboro, NC
    Vehicle:
    '16 Sr5 4x4 DCSB
    Pretty much stock
    If the a/c needs to be charged then that means there is a leak somewhere.
     
To Top