1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

87 suburban issues

Discussion in 'General Automotive' started by 95 taco, Apr 6, 2013.

  1. Apr 6, 2013 at 8:37 AM
    #1
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    We have a 87 suburban with the 5.7 back here in MISS, and she's running rough, she doesn't want to idle and when it does idle the RPM's constantly rise and fall, after fluctuating a few times it dies.
    It also seems to be running rich, if I punch the gas in gear it might rev a little but if I let off the gas a little it will raise the RPM's to where they should be.

    It seems to rev fine in neutral and park, the water pump was replaced 3 (?) years ago, and it has a coolant leak where the bottom hose on the radiator meets the block.

    I'll add more info when I get to my computer (tonight)
    Any input is appreciated

    Edit: forgot to mention its fuel injected, and we replaced the injectors a few years ago
     
    Last edited: Apr 6, 2013
  2. Apr 6, 2013 at 5:37 PM
    #2
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    Sounds like a vaccum leak
     
  3. Apr 6, 2013 at 5:47 PM
    #3
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    I'll have to check that tomorrow, thanks Doug.
     
  4. Apr 7, 2013 at 9:31 PM
    #4
    Speed Freek

    Speed Freek Turbo Meister

    Joined:
    Dec 17, 2008
    Member:
    #11676
    Messages:
    2,507
    Gender:
    Male
    First Name:
    Jason
    Vista, Ca, Lake Havasu, Az.
    Vehicle:
    98' 2.4 extra cab w/LS1 Aluminum V8
    ARP Head Studs, Ported Head, MLS Head Gasket, GT3076R Garrett BB Turbo, Synapse Tubular SS Exhaust Manifold, PSI Forward Facing Sheet Metal Intake, Intercooler, 550cc injectors,255lph Fuel Pump, Speed-Trac Traction bars, Heim joint Strut bars, URD Short Shifter, CC Twindisk Clutch, , Haltech Platinum Sport 1000 Standalone ECU, Pre-runner rear springs, V6 rearend with TRD limited-slip Differential New list....LS1 with T56 6-speed trans...simply awesome.
    Check your Idle Air control valve, its probably sticking..
     
  5. Apr 7, 2013 at 9:35 PM
    #5
    steve o 77

    steve o 77 braaap

    Joined:
    Nov 29, 2009
    Member:
    #26726
    Messages:
    19,953
    Gender:
    Male
    First Name:
    Steven
    In a corn field, OH
    Vehicle:
    2001 4x4 5Spd Xtra Cab V6
    205k+ miles, 265/75/16 BFG A/T's, OME 881's, Wheelers 5 leaf pack, 5100's, Home Made Sliders
    this.
     
  6. Apr 7, 2013 at 9:45 PM
    #6
    fireturk41

    fireturk41 I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,498
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
  7. Apr 8, 2013 at 7:00 AM
    #7
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    allright, thanks jason.
    if it's sticking do i just shoot it with carb cleaner?
    i pulled the air pump for the smog system since it wasn't hooked up, to plug it i'm gonna use a big bolt ( if we have one, if not then i'll make a wood plug), would it hurt anything to put some silicone on the threads to help seal it?
     
  8. Apr 8, 2013 at 10:38 AM
    #8
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    i pulled the IAC valve and it looked like this
    [​IMG]

    i cleaned it with carb cleaner, and it looked cleaner, but i think it's stuck in the position, i reinstalled it, did the IAC reset, and it still runs funny.

    after lunch i'm gonna unhook the TPS and check for vacuum leaks.
     
  9. Apr 8, 2013 at 11:54 AM
    #9
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    i haven't checked for vacuum leaks, but i did some reading and found out that i can test the IAC valve when it isn't in the TB, so i did and it didn't move at all so i'm assuming that that's the problem.
     
  10. Apr 8, 2013 at 1:36 PM
    #10
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    Just took it for a drive with the valve removed, it will bog with anything over a very light touch of the pedal, until its revving pretty good (no tach, but it sounds about halfway to redline) , once you get it passed that point you can floor it and it will slowly and smoothly accelerate.
     
  11. Apr 8, 2013 at 1:43 PM
    #11
    95 taco

    95 taco [OP] Redneck rich

    Joined:
    May 3, 2012
    Member:
    #78175
    Messages:
    10,683
    Gender:
    Male
    South Miss.
    Vehicle:
    2003 4x4 TRD SR5
    OME 883 front, OMD 3.5" rear Relentless front bumper
    Forgot to say that the idle smoothed out after it warmed up, but it was idling fast.
     
    Last edited: Apr 8, 2013
To Top