1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

98 Tacoma 2.7L won't start

Discussion in '4 Cylinder' started by haroldpo, Jan 23, 2013.

  1. Jan 23, 2013 at 4:30 PM
    #1
    haroldpo

    haroldpo [OP] Member

    Joined:
    Jan 23, 2013
    Member:
    #95928
    Messages:
    5
    Gender:
    Male
    Vehicle:
    98 tacoma 2.7L
    The check engine light start flashing and it started running rough, but made it home. Next day it would not start. Things i have checked or replaced.

    Since toy decided not to put a fuel test port on the fuel rail i checked the fuel pressure at the fuel filter, all OK
    Have fire to all plug wires, installed new plugs anyway.
    Cam sensor had oil all over it so i installed a new one, not easy, no change.
    Cleaned TB
    The codes where PO300/
    PO302/PO304 cylinder #2&#4 misfire.
    1/2 tank fuel
    Compression is 175/180/176/180
    All fuses is good.
    Still the truck will not start, where should i look next?
    Truck has 180,000
     
  2. Jan 24, 2013 at 4:24 PM
    #2
    haroldpo

    haroldpo [OP] Member

    Joined:
    Jan 23, 2013
    Member:
    #95928
    Messages:
    5
    Gender:
    Male
    Vehicle:
    98 tacoma 2.7L
    Bamatoy1997 you out there?
     
  3. Feb 1, 2013 at 10:00 AM
    #3
    haroldpo

    haroldpo [OP] Member

    Joined:
    Jan 23, 2013
    Member:
    #95928
    Messages:
    5
    Gender:
    Male
    Vehicle:
    98 tacoma 2.7L
    Pulled it to a repair shop and he said i had bent valves, jumped time he thought. Wants $1800 for repair. I don't see how a bent valve would let me have 175-180 psi on all cylinders. Pulling it home tomorrow.
     
  4. Feb 9, 2013 at 5:58 AM
    #4
    haroldpo

    haroldpo [OP] Member

    Joined:
    Jan 23, 2013
    Member:
    #95928
    Messages:
    5
    Gender:
    Male
    Vehicle:
    98 tacoma 2.7L

    Fixed
     
  5. Feb 11, 2013 at 10:02 PM
    #5
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    1,964
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, 31" tires, Michelin LTX AT2, stock gears, Tranny skidplate, TC skidplate, CBI rear bumper, sliders, UltraGauge, PowerTank, CB
    Well, what was it, and what did you do :confused:
     
  6. Feb 13, 2013 at 7:41 AM
    #6
    haroldpo

    haroldpo [OP] Member

    Joined:
    Jan 23, 2013
    Member:
    #95928
    Messages:
    5
    Gender:
    Male
    Vehicle:
    98 tacoma 2.7L
    Just think, 188 views and no help offered.
     
  7. Feb 13, 2013 at 1:24 PM
    #7
    SpeedoJosh

    SpeedoJosh Well-Known Member

    Joined:
    Aug 15, 2011
    Member:
    #61730
    Messages:
    1,995
    Gender:
    Male
    Florida
    Vehicle:
    2010 Access cab, Base, 4x4
    The 4cyl section doesn't get checked much. Better luck can be had in the 1st Gen section.
    Glad you got it all sorted though.
     
To Top