1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

'99 Tacoma turn signal issue

Discussion in 'Technical Chat' started by rathbone, Jan 26, 2013.

  1. rathbone

    rathbone [OP] New Member

    Joined:
    Jan 26, 2013
    Member:
    #96151
    Messages:
    1
    Gender:
    Male
    First Name:
    Doug
    Colorado
    Vehicle:
    99 Tacoma 4WD 3.4ltr
    I have a 3.4 V6 4X4 Xtracab, recently the turn signal lever has started malfunctioning. When I lift it for right turn the signal activates at the halfway point but when it clicks into position the signal light (dash and front and back lights) goes out and there is a very fast clicking sound. The left position works fine and if I hold the in the halfway position the right signal works. Sometimes I can pull in or push out the signal level while I lift and the signal will work fine. What should I expect to have to replace to fix the problem? thanks
     
  2. tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    1,821
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, stock gears, stock-size tires, Michelin LTX AT2, Tranny skidplate, sliders, UltraGauge, PowerTank, CB
    I would start by replacing the switch.
    10 or 20 bucks at the wreckers.
     
To Top