1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

A/C Cluster Light (I think I need a bulb)

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Plinkerton, Jan 1, 2010.

  1. Jan 1, 2010 at 12:43 PM
    #1
    Plinkerton

    Plinkerton [OP] Well-Known Member

    Joined:
    Oct 24, 2009
    Member:
    #24847
    Messages:
    82
    Gender:
    Male
    NorCal
    Vehicle:
    2013 DCLB 4x4 SR5
    I have a 05 Access cab, and my light on my a/c cluster just stopped working.

    Only on the right side, on the selector knob that selects whether it's defrost, feet vents only, etc.

    All the other lights work fine. I pulled the cluster, and I can see where the light goes inside, so I hope it's replaceable.

    I've heard that these are bulbs and not LEDs.

    Are they possible to order from somewhere, and install myself?

    I've googled all over, and haven't been able to find anything.

    Anyone know?

    Thanks! And happy new year!
     
  2. Jan 1, 2010 at 3:52 PM
    #2
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    take the bulb out and go to autozone and try to match it up.it may be a dealer item.
     
To Top