1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

A couple problems engine and heat

Discussion in '2nd Gen. Tacomas (2005-2015)' started by airsoft_warrior, Dec 6, 2009.

  1. Dec 6, 2009 at 1:04 PM
    #1
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    I drove 125 miles yesterday and while on the highway I noticed that the truck was shifting harshly and that the engine wasn't running any higher than 2000 Rpms. I have not experienced this problem yet and wanted some advice before just running to the mechanic. The other problem was with the heater. When only the heater is on ther is a whirring sound from the blower under the dash. I checked and there isn't anything under there. It only happens with the g
    heat on and very annoying. Any ideas?
     
  2. Dec 6, 2009 at 1:20 PM
    #2
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    sounds fucked? maybe its in safe mode? Any CEL?
     
  3. Dec 6, 2009 at 1:25 PM
    #3
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    What is cel? I didn't do anything to put in safe mode ( at least that I know of)
     
  4. Dec 6, 2009 at 1:33 PM
    #4
    LEBM

    LEBM Thread Killer

    Joined:
    Nov 26, 2009
    Member:
    #26586
    Messages:
    411
    Gender:
    Male
    Eleanor, WV
    Vehicle:
    15 DCSB TRD Sport 4x4 - Pyrite Mica

    CEL = check engine light
     
  5. Dec 6, 2009 at 1:44 PM
    #5
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Nope the check engine light never came on. I had went hunting last week and had the truck in 4wd then when I unlocked them the truck jolted I dont know if that may have something to do with it or not.
     
  6. Dec 6, 2009 at 2:00 PM
    #6
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Thanks I will try that when it warms up some. There is still some snow outside and dont feel like getting soaked while doing this. The strange part it its only the heat not the A/C. I ran the A/C for a while and no noise at all. I also noticed that i might have blown a tweeteror speaker at some point, I dont put my music up loud so I dont know how that would happen. It is the troublesome time of the year.
     
  7. Dec 6, 2009 at 3:03 PM
    #7
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    Well, does it feel like it still has power, its just not revving as high? I think safemode only reduces power, not sure about RPM control.
     
  8. Dec 6, 2009 at 3:07 PM
    #8
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    It still feels like it has some power I was able to get up to 70mph but not much more. It felt like it was lagging. If that makes sense.:confused:
     
  9. Dec 6, 2009 at 3:13 PM
    #9
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Kinda sounds like you have something blocking the airway......Pop the air filter housing and see if everything is OK...
     
  10. Dec 6, 2009 at 3:15 PM
    #10
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Yeah I havnt checked that yet. Will do that tomorrow
     
  11. Dec 15, 2009 at 8:46 PM
    #11
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    How do I check to see if it is in safe mode? The battery was drained (oops!) right before i noticed it revving different.
     
  12. Dec 16, 2009 at 5:04 AM
    #12
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,839
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Disconnect your battery cable again for a few minutes, then see what happens.
     
  13. Jan 9, 2010 at 12:21 PM
    #13
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Did this. The filter was dirty but nothing blocking passage. Can I just remove the clamps on the battery? They are bolted down. I dont want to get shocked.
     
  14. Jan 9, 2010 at 12:42 PM
    #14
    vbibi

    vbibi Well-Known Member

    Joined:
    Jul 23, 2009
    Member:
    #20060
    Messages:
    515
    Gender:
    Male
    san fransisco bay area
    Vehicle:
    2009 4door long bed
    You are in for a rough ride my friend.... and you do not get shocked from disconnecting your battery. Just take them off one at the time, negative first.
    take care
    vbibi:(
     
  15. Jan 9, 2010 at 1:00 PM
    #15
    Taco-NB

    Taco-NB MMMMM Taco's

    Joined:
    May 1, 2009
    Member:
    #16662
    Messages:
    1,744
    Gender:
    Male
    New Brunswick
    Vehicle:
    '09 4X4 SR5 Access Cab V6 - Black Sand Pearl
    You have an '08 so it should still be under warranty?? Sounds like it's time for a trip to the shop.

    :cheers:
     
  16. Jan 9, 2010 at 6:03 PM
    #16
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    Yeah I was thinking about that. I tinkered with the blower today i think it is okay for now. I dont feel like taking it to the shop because then i am out of the truck for 2 days.
     
  17. Jan 9, 2010 at 9:08 PM
    #17
    05sctaco

    05sctaco Well-Known Member

    Joined:
    Jun 18, 2007
    Member:
    #1868
    Messages:
    905
    Gender:
    Male
    First Name:
    Ken
    Santa Cruz
    check to see if you have any blown fuses. Also check your fluids that you can check. Are you shifting hard also, the engine might be fine but your tranny might be bad, I've read the stories of exploding transmissions.
     
  18. Jan 10, 2010 at 5:56 AM
    #18
    airsoft_warrior

    airsoft_warrior [OP] Batman

    Joined:
    Feb 21, 2008
    Member:
    #4861
    Messages:
    1,107
    Gender:
    Male
    First Name:
    Batman
    Edgewater, Maryland
    Vehicle:
    Batmobile
    Smoked Tail lights, Secondary Air filter removed, Super 40 Flowmaster Muffler, Drop in AFE filter, Mesh Grillecraft, Bilstein 5100, Halo Projector headlights, Blinglights foglights, Batman Emblem, Roll/Show Bar, 20% tinted windows, Rear TSB
    It seems almost like the same problem with the 2010s except there is no TSB for mine.
     
To Top