1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

a WIX air filter did not fit my 06 four liter.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by aficianado, Apr 27, 2011.

  1. Apr 27, 2011 at 10:55 AM
    #1
    aficianado

    aficianado [OP] Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,459
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    back to bone stock.
    just a heads-up. i bought a WIX. for the most part, i like WIX products. all their filters seem to be decent.

    but it didnt fit! it was too wide on the tapered end of the filter to slide into the housing. i returned it, and got OEM. i've used them before, i think.

    not bashing or advocating..just putting the info out there.
     
  2. Apr 27, 2011 at 1:38 PM
    #2
    maxamillion2345

    maxamillion2345 Go home if you don't like guns liquor and whores.

    Joined:
    Feb 20, 2010
    Member:
    #31761
    Messages:
    7,880
    Gender:
    Male
    First Name:
    Max
    Nevada
    Vehicle:
    80 series LC
    Too many
    The 1GR-FE ?

    I'm running the wix brand air filter currently, no issues here.
     
  3. Apr 27, 2011 at 5:53 PM
    #3
    aficianado

    aficianado [OP] Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,459
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    back to bone stock.
    yes,,that motor.

    i swear i ran that filter before too. it was weird.
     
To Top