1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

ABS

Discussion in '2nd Gen. Tacomas' started by 06 tacoma owner, Jan 7, 2013.

  1. Jan 7, 2013 at 1:36 PM
    #1
    06 tacoma owner

    06 tacoma owner [OP] Well-Known Member

    Joined:
    Jul 31, 2012
    Member:
    #83845
    Messages:
    1,258
    Gender:
    Male
    First Name:
    Will
    Western KY
    Vehicle:
    2006 AC super white 4x4
    4 inch lift, 6000k HIDs, weathertechs, Pioneer head unit with bluetooth, 285/70 trail grapplers, aero turbine muffler w/ flowmaster 3 inch stainless tip
    My ABS light came on and I am wondering what exactly is wrong with the brakes.
     
  2. Jan 7, 2013 at 1:38 PM
    #2
    Pugga

    Pugga Pasti-Dip Free Since 1983

    Joined:
    Jun 18, 2010
    Member:
    #39131
    Messages:
    28,925
    Gender:
    Male
    First Name:
    Mike
    Massachusetts
    Vehicle:
    '13 Ford F-150 SCREW
    F-150 Mod
    If it came on randomly and you haven't done any recent repairs, check your brake fluid. The fluid needs to be at the upper end of the fill marks.
     
  3. Jan 7, 2013 at 2:14 PM
    #3
    06 tacoma owner

    06 tacoma owner [OP] Well-Known Member

    Joined:
    Jul 31, 2012
    Member:
    #83845
    Messages:
    1,258
    Gender:
    Male
    First Name:
    Will
    Western KY
    Vehicle:
    2006 AC super white 4x4
    4 inch lift, 6000k HIDs, weathertechs, Pioneer head unit with bluetooth, 285/70 trail grapplers, aero turbine muffler w/ flowmaster 3 inch stainless tip
    I checked and the fluid level was fine. Could it be that I need the pads replaced?
    I have been needing to.
     
To Top